Bug 121289 - NullPointerException at org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler.checkUpdateElements
NullPointerException at org.netbeans.modules.autoupdate.ui.actions.Autoupdate...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, release601_fixes_c...
:
: 122703 126412 128291 130847 132446 133807 135653 138058 146698 152602 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 13:16 UTC by Marian Mirilovic
Modified: 2012-10-27 20:31 UTC (History)
27 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (576 bytes, text/plain)
2007-11-06 13:16 UTC, Marian Mirilovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2007-11-06 13:16:39 UTC
Build: NetBeans IDE Dev (Build 200710060000)
VM: Java HotSpot(TM) Client VM, 1.5.0_12-b04
OS: Linux, 2.6.12-10-686, i386

User Comments:
Comment 1 Marian Mirilovic 2007-11-06 13:16:43 UTC
Created attachment 52594 [details]
stacktrace
Comment 2 Jiri Rechtacek 2007-11-06 14:02:54 UTC
Unreproducible on last build.

  Product Version         = NetBeans IDE Dev (Build 200711060000)
  Operating System        = Linux version 2.6.22-14-generic running on i386
  Java; VM; Vendor        = 1.6.0_05-ea; Java HotSpot(TM) Client VM 1.6.0_05-ea-b05; Sun Microsystems Inc.
  Java Home               = /usr/local/share/java/jdk1.6.0_05/jre
  System Locale; Encoding = en_US (nb); UTF-8
  Home Directory          = /space/home/jirka
  Current Directory       = /tmp
  User Directory          = /tmp/xoc
  Installation            = /tmp/netbeans-6.0-200711060000/nb6.0
                            /tmp/netbeans-6.0-200711060000/ide8
                            /tmp/netbeans-6.0-200711060000/java1
                            /tmp/netbeans-6.0-200711060000/xml1
                            /tmp/netbeans-6.0-200711060000/apisupport1
                            /tmp/netbeans-6.0-200711060000/enterprise4
                            /tmp/netbeans-6.0-200711060000/mobility8
                            /tmp/netbeans-6.0-200711060000/profiler2
                            /tmp/netbeans-6.0-200711060000/ruby1
                            /tmp/netbeans-6.0-200711060000/visualweb1
                            /tmp/netbeans-6.0-200711060000/soa1
                            /tmp/netbeans-6.0-200711060000/identity1
                            /tmp/netbeans-6.0-200711060000/uml4
                            /tmp/netbeans-6.0-200711060000/harness
                            /tmp/netbeans-6.0-200711060000/cnd1
                            /tmp/netbeans-6.0-200711060000/platform7
Comment 3 Jesse Glick 2007-11-12 18:02:26 UTC
Happened to me in 071106 during startup. (See exception reporter.)

Generally, I don't think WORKSFORME is an acceptable resolution for an NPE. Clearly your code does sometimes throw an
NPE here. If you can't fix the problem you can at least insert an assertion of some kind which would indicate better for
you what is wrong. For example, in this case it is clear that operationInfo == null, which means oc.add(element)
returned null. It is not clear if that is allowed because this method has no Javadoc (in an API class!!).
Comment 4 Jiri Rechtacek 2007-11-14 10:42:45 UTC
NPE fixed:
Checking in AutoupdateCheckScheduler.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/actions/AutoupdateCheckScheduler.java,v
 <--  AutoupdateCheckScheduler.java
new revision: 1.11; previous revision: 1.10
done

The Javodoc was improved in last week (for NB6) but it's not public on netbeans.org. The note about possible null was
added into Javadoc.
Checking in OperationContainer.java;
/shared/data/ccvs/repository/autoupdate/services/src/org/netbeans/api/autoupdate/OperationContainer.java,v  <-- 
OperationContainer.java
new revision: 1.11; previous revision: 1.10
done
Comment 5 Jiri Rechtacek 2007-11-29 15:16:38 UTC
*** Issue 122703 has been marked as a duplicate of this issue. ***
Comment 6 Jiri Rechtacek 2008-02-06 12:28:56 UTC
*** Issue 126412 has been marked as a duplicate of this issue. ***
Comment 7 Exceptions Reporter 2008-02-18 03:01:22 UTC
THIS ISSUE HAS ALREADY 100 DUPLICATES
Comment 8 Jaromir Uhrik 2008-02-25 08:10:54 UTC
This issue seems to be fixed - Radek has confirmed that it is not possible to get the exception from the code now.
Although there are reports from some builds after the fix integration it seems that normal configuration cannot cause
the exception now. VERIFIED.
Comment 9 Jaromir Uhrik 2008-02-25 09:19:38 UTC
I see it is clear now - the target milestone is 6.1 so that it is allright that this issue appeared to users in 6.0. and
6.0.1
Comment 10 Jiri Rechtacek 2008-02-26 11:53:49 UTC
Just a note. The patch must contain fix of AutoupdateCheckScheduler.java in Autoupdate UI module, change of Javadoc in
Autoupdate Services is not important for this patch.
NPE fixed:
Checking in AutoupdateCheckScheduler.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/actions/AutoupdateCheckScheduler.java,v
 <--  AutoupdateCheckScheduler.java
new revision: 1.11; previous revision: 1.10
done
Comment 11 Jiri Rechtacek 2008-02-28 09:10:32 UTC
*** Issue 128291 has been marked as a duplicate of this issue. ***
Comment 12 rbalada 2008-03-05 17:52:16 UTC
Fix ported to release601_fixes branch. 

Unfortunately I made the commit with incorrect commit message "IZ 121854 ClassCastException:
org.openide.filesystems.MultiFileObject$VoidValue cannot be cast to java.lang.String". 
The integration has been made including Javadoc change in autoupdate/services module. Change in autoupdate/services
won't be published on Update Center because 1) it does not change a code, 2) the change is in code contained in
updater.jar, which cannot be updated in 6.0.x codeline (issue 37133, fixed in 6.1M2).

Checking in AutoupdateCheckScheduler.java;
/cvs/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/actions/AutoupdateCheckScheduler.java,v
 <--  AutoupdateCheckScheduler.java
new revision: 1.10.6.1; previous revision: 1.10
Checking in AutoupdateCheckScheduler.java;
/cvs/autoupdate/services/src/org/netbeans/api/autoupdate/OperationContainer.java,v
 <--  OperationContainer.java
new revision: 1.8.4.1.4.1; previous revision: 1.8.4.1
done

Comment 13 Jiri Rechtacek 2008-04-09 18:36:52 UTC
*** Issue 132446 has been marked as a duplicate of this issue. ***
Comment 14 Lukas Hasik 2008-04-25 09:55:04 UTC
*** Issue 133807 has been marked as a duplicate of this issue. ***
Comment 15 Jiri Prox 2008-05-23 09:17:30 UTC
*** Issue 135653 has been marked as a duplicate of this issue. ***
Comment 16 Lukas Hasik 2008-06-24 14:53:39 UTC
*** Issue 138058 has been marked as a duplicate of this issue. ***
Comment 17 Lukas Hasik 2008-09-10 08:30:48 UTC
*** Issue 146698 has been marked as a duplicate of this issue. ***
Comment 18 rizwaanmd 2008-10-06 05:21:20 UTC
Reopening - reproduced in NetBeans IDE 6.0 (Build 200711261600)
Comment 19 Lukas Hasik 2008-10-06 08:59:53 UTC
this issue was fixed in NB 6.1 ad in patch2 for NB6.0. If you are using NB6.0 without a patch then you can reproduce it.

Please, reopen if you are able to reproduce in NB6.0+patch2. 
Comment 20 rbalada 2008-10-06 09:49:29 UTC
rizwaanmd,

would you please confirm that installation of the latest NetBeans 6.0 Patch helped you? I would like to return this
issue into VERIFIED-FIXED state. If I don't hear from you in next seven days, I'll consider it confirmed and will
proceed with return to VERIFIED-FIXED state.

Information about how to update your IDE can be found at
http://hg.netbeans.org/main/raw-file/63c0534adb36/usersguide/javahelp/org/netbeans/modules/usersguide/configure/modules/autoupdate.html

For more information about NetBeans 6.0 and 6.0.1 patches, please visit this hub
http://wiki.netbeans.org/NetBeans6.0PatchesInfo

-R10a
Comment 21 Marian Mirilovic 2008-10-15 10:59:48 UTC
still getting duplicates, but all are too old  - verified
Comment 22 Jiri Rechtacek 2008-10-22 13:06:47 UTC
anilkumar832 don't change platform/os for this issue. It's reproducible case on _all_ platform.
Comment 23 Jiri Rechtacek 2008-10-22 13:06:48 UTC
anilkumar832 don't change platform/os for this issue. It's reproducible case on _all_ platform.
Comment 24 dlipin 2008-11-12 15:03:27 UTC
*** Issue 130847 has been marked as a duplicate of this issue. ***
Comment 25 dlipin 2008-11-16 11:11:41 UTC
*** Issue 152602 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo