Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 122703 - NPE in autoupdate
NPE in autoupdate
Status: CLOSED DUPLICATE of bug 121289
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
PC All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-25 12:35 UTC by kirillkh
Modified: 2008-02-22 16:38 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kirillkh 2007-11-25 12:35:11 UTC
Product Version: NetBeans IDE 6.0 RC2 (Build 200711201000)
Java: 1.6.0_01; Java HotSpot(TM) Client VM 1.6.0_01-b06
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
-----------------------------------------------------------------

I wasn't doing anything with the update. In fact, I hadn't touched the IDE at all for some time before the exception
alert popped up.


java.lang.NullPointerException
	at
org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler.checkUpdateElements(AutoupdateCheckScheduler.java:189)
	at org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler.access$300(AutoupdateCheckScheduler.java:77)
	at org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler$4.run(AutoupdateCheckScheduler.java:148)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)
Comment 1 Jiri Rechtacek 2007-11-29 15:16:42 UTC
Fixed in NB6.1

*** This issue has been marked as a duplicate of 121289 ***
Comment 2 Jaromir Uhrik 2008-02-22 16:38:38 UTC
The stacktrace is identical with 121289 => Verified->Closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo