Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 126412 - NPE on restart
NPE on restart
Status: CLOSED DUPLICATE of bug 121289
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-31 16:54 UTC by _ tboudreau
Modified: 2008-02-22 16:38 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2008-01-31 16:54:53 UTC
Started NetBeans on an existing userdir with some nb source modules open, read mail while it started, when I switched to it, this exception had been thrown:

java.lang.NullPointerException
	at org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler.checkUpdateElements(AutoupdateCheckScheduler.java:189)
	at org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler.access$300(AutoupdateCheckScheduler.java:77)
	at org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler$4.run(AutoupdateCheckScheduler.java:148)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)
Comment 1 Jiri Rechtacek 2008-02-06 12:28:59 UTC
Already fixed in NB6.1M1

*** This issue has been marked as a duplicate of 121289 ***
Comment 2 Jaromir Uhrik 2008-02-22 16:38:25 UTC
The stacktrace is identical with 121289 => Verified->Closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo