Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 130847 - Autoupdater fails
Autoupdater fails
Status: RESOLVED DUPLICATE of bug 121289
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
All Windows XP
: P4 (vote)
: TBD
Assigned To: Jiri Rechtacek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-22 18:16 UTC by kuvos
Modified: 2008-11-12 15:03 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kuvos 2008-03-22 18:16:53 UTC
I don't have a lot of information, but when starting a fresh install of Netbeans 6.01 with JDK 6.05 I get the following 
error:

java.lang.NullPointerException
	at org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler.checkUpdateElements
(AutoupdateCheckScheduler.java:189)
	at org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler.access$300
(AutoupdateCheckScheduler.java:77)
	at org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler$4.run(AutoupdateCheckScheduler.java:148)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)


It might be good to know I disabled java's auto-update-scheduler (in Windows), but I'm not sure whether that relates to 
Netbeans (is it the Netbeans autoupdater that crashes or a check for Java's updater that crashes?). I was unable to 
find any options relating to the Java updater. Did not find a related issue either.

I can't seem to find any setting relating to the auto-updater of Netbeans, but I guess that's a feature request. Good 
luck with it, sorry I can't give any more information. A nullpointer exception is bad either way :p
Comment 1 dlipin 2008-11-12 15:03:37 UTC
The stacktrace looks like similar to the one in the Issue 121289 so closing as the duplicate.
According to the issue, it is fixed in Patch 2 for 6.0.1 and certainly in 6.1/6.5.

*** This issue has been marked as a duplicate of 121289 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo