Bug 59242 - Current implementation of org.openide.awt.ToolbarPool is terrible!
Current implementation of org.openide.awt.ToolbarPool is terrible!
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
5.x
All All
: P1 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
:
: 25396 42146 62033 (view as bug list)
Depends on: 65736 153835 166787
Blocks: 140464 140863
  Show dependency treegraph
 
Reported: 2005-05-25 14:49 UTC by Jan Jancura
Modified: 2009-06-09 14:54 UTC (History)
1 user (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Jancura 2005-05-25 14:49:12 UTC
Whats wrong:
1) ToolbarPool & Toolbar are based directly on Data System. (Thats why this UI
component is part of DataSystems API) Thats bad they should use some specific
model, like other Swing components. They should follow MVC.

2) Toolbar implemetation is splitted to two modules - openide&core. I have never
seen such *@%$@# thing - UI component is in one module and its Layout is in
another one.

3) All implementation is unnecessarily complicated.

4) ToolbarPool is not reusable. There are direct calls from ToolbarLayout to
ToopbarPool.getDeafult () for example.

There are many other smaller problems. 
This part of IDE should be rewritten.
Comment 1 David Simonek 2005-05-25 15:19:40 UTC
AFAIK this is duplicate, I entered such task long time ago. No resources, sorry.
Comment 2 Stanislav Aubrecht 2008-10-14 12:11:08 UTC
*** Issue 62033 has been marked as a duplicate of this issue. ***
Comment 3 Stanislav Aubrecht 2008-10-16 09:47:37 UTC
*** Issue 25396 has been marked as a duplicate of this issue. ***
Comment 4 Stanislav Aubrecht 2008-10-16 09:52:30 UTC
*** Issue 42146 has been marked as a duplicate of this issue. ***
Comment 5 Stanislav Aubrecht 2008-11-28 11:20:42 UTC
fixed

4f828389f2be
Comment 6 Quality Engineering 2008-11-29 05:02:05 UTC
Integrated into 'main-golden', will be available in build *200811290201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/4f828389f2be
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #59242 - toolbar rewrite
Comment 7 aldobrucale 2008-12-23 08:47:36 UTC
Just curious: how was it fixed? Where all the four listed points addressed? Is it now possible to use ToolbarPool for
toolbars other than the default one? 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo