Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 42146 - Rewrite toolbar implementation
Rewrite toolbar implementation
Status: RESOLVED DUPLICATE of bug 59242
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
All All
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
: UMBRELLA
Depends on:
Blocks: 63758 12573 17439 19602 38063 44160 62033 65291 68083
  Show dependency treegraph
 
Reported: 2004-04-19 23:24 UTC by _ tboudreau
Modified: 2008-12-22 14:43 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2004-04-19 23:24:06 UTC
A bunch of problems here that need to be fixed:
 - Toolbar initialization causes main window revalidation
 - GUI components that implement an interface controlled/
loaded by random threads is a bad idea; GUI components that 
implement anything are usually a bad idea
 - The UI design is not well thought out, just a legacy of 
NetBeans Developer X2 five years later - lots of really useless 
functionality like renaming toolbars that just needs to go away
 - The draggable grip/ui stuff should be moved into the plaf 
library - for Aqua and GTK the visual presentation is already 
there, but for other LFs it is implemented as a subcomponent, 
making the code considerably more complex than it needs to be
Comment 1 Jan Chalupa 2004-11-01 16:56:30 UTC
Re-assigning Tim's issues to Dafe.
Comment 2 David Simonek 2005-05-06 22:24:41 UTC
Still valid I think.
Comment 3 Stanislav Aubrecht 2008-10-16 09:52:31 UTC

*** This issue has been marked as a duplicate of 59242 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo