Bug 140863 - [65cat] [toolbar] Toolbar resize problem after width reduction
[65cat] [toolbar] Toolbar resize problem after width reduction
Status: RESOLVED DUPLICATE of bug 120019
Product: platform
Classification: Unclassified
Component: Window System
6.x
PC Windows XP
: P4 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
:
: 147144 (view as bug list)
Depends on: 59242
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-19 03:28 UTC by karmagfa
Modified: 2008-12-22 14:21 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot 01 (35.24 KB, image/jpeg)
2008-07-19 03:30 UTC, karmagfa
Details
screenshot 02 (29.10 KB, image/jpeg)
2008-07-19 03:30 UTC, karmagfa
Details
screenshot 03 (20.33 KB, image/jpeg)
2008-07-19 03:30 UTC, karmagfa
Details
screenshot 04 (33.84 KB, image/jpeg)
2008-07-19 03:31 UTC, karmagfa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description karmagfa 2008-07-19 03:28:14 UTC
[ BUILD # : 200807170007 ]
[ JDK VERSION : 1.6.0_05 ]

How to reproduce:
- Resize the width of Netbeans to something small.
- Restore its width to its original one.

Problem A:
In the toolbar, after we reduce the width, the search component
overlap the other toolbar components. They are not rearranged on
another toolbar row until they left edge is hidden by the search
component.

Problem B: When we restore the width to something bigger after the
toolbar components has been rearranged on many toolbar rows, the
toolbar doesn't come back to its initial configuration. From the
user's point of view, the resize of the window is damaging the layout
that he may spent some time to manually setup.

See the 4 attached screenshot for visual reference.
Comment 1 karmagfa 2008-07-19 03:30:12 UTC
Created attachment 65010 [details]
screenshot 01
Comment 2 karmagfa 2008-07-19 03:30:34 UTC
Created attachment 65011 [details]
screenshot 02
Comment 3 karmagfa 2008-07-19 03:30:55 UTC
Created attachment 65012 [details]
screenshot 03
Comment 4 karmagfa 2008-07-19 03:31:19 UTC
Created attachment 65013 [details]
screenshot 04
Comment 5 Marian Mirilovic 2008-07-21 07:33:34 UTC
The first problem is already reported ..., but I am not sure for second one ...
Comment 6 David Simonek 2008-07-21 08:35:46 UTC
Passing to Standa, both problems are already filed I think. Unfortunately fixing this would mean total toolbar rewrite
AFAIK.
Comment 7 Stanislav Aubrecht 2008-07-21 09:53:32 UTC
the first part is a duplicate of 140464

as for the second part - that's how toolbars in netbeans work, you may try using 'reset toolbars' action to put them all
back in a single row.
Comment 8 Stanislav Aubrecht 2008-07-21 10:25:30 UTC
ad part 1 - how often do you resize the main window so that each toolbar is on its own row?:)
Comment 9 karmagfa 2008-07-21 18:40:09 UTC
Not that often. Mostly only when I take screenshots for blogs or bug reports. :)
Comment 10 Stanislav Aubrecht 2008-09-15 10:16:20 UTC
*** Issue 147144 has been marked as a duplicate of this issue. ***
Comment 11 _ ludo 2008-09-15 16:31:59 UTC
P4: who are we kidding?
This is the foundation of a windowing system and we cannot even implement it correctly.

The duplicate bug I filed was a P2 bug imo.

So we put priority P4 for bugs that we do not want to show up in the bug dashboard?
Comment 12 Stanislav Aubrecht 2008-09-15 16:42:32 UTC
ludo, feel free to raise priority as you seem fit but this bug needs total rewrite of toolbars implementation and that's
not going to happen within 6.5 timeframe.

and same question as to the original reporter of this bug: how often do you resize your ide window to less than half of
its default width?
Comment 13 _ ludo 2008-09-15 17:17:49 UTC
I am using now virtualbox a lot now (fro xp, ubuntum opensolaris, and many times it is a limited size (1024*800)

So resizing in these small configurations is a big deal.
Comment 14 adrienclerc 2008-10-23 13:07:53 UTC
Hard to find but the Problem B was reported in the issue #120019 I have also a linked problem that should motivate
developers to do something :) For the problem B, this bug should be marked as duplicate
Comment 15 Lukas Hasik 2008-11-19 15:22:30 UTC
*** Issue 120019 has been marked as a duplicate of this issue. ***
Comment 16 Lukas Hasik 2008-11-20 16:52:43 UTC

*** This issue has been marked as a duplicate of 120019 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo