Bug 140464 - Quicksearch is painted over near by toolbar
Quicksearch is painted over near by toolbar
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
:
: 142121 143423 146117 (view as bug list)
Depends on: 59242
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-17 09:08 UTC by Petr Chytil
Modified: 2009-02-19 22:53 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
quicksearch toolbar screenshot (42.18 KB, image/png)
2008-07-17 09:09 UTC, Petr Chytil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Chytil 2008-07-17 09:08:38 UTC
Product Version: NetBeans IDE Dev (Build 200807170007)
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b13
System: Linux version 2.6.24-19-generic running on i386; UTF-8; en_US (nb)
Userdir: /home/petr/.netbeans/dev-0717

steps to reproduce:
- just make IDE window small enough and you'll see same state as in attached screenshot (tested on GTK and Nimbus)
Comment 1 Petr Chytil 2008-07-17 09:09:24 UTC
Created attachment 64803 [details]
quicksearch toolbar screenshot
Comment 2 Petr Chytil 2008-07-17 10:28:33 UTC
In my opinion, quick search should force other toolbars to go to next line of toolbars instead of being drawn over them,
when there is not enough space for all toolbars and quick search to fit in one line.

Ondrej, could you please add your opinion? There is always possibility, that i got it completely wrong ;-).
Comment 3 Ondrej Langr 2008-07-17 10:43:51 UTC
I tend to agree. However, first of all, we need to fix the toolbar, so that (unless users customize it) everything fits
on 1024px horizontally (which is the lowest supported res). Thus, this defect will almost be eliminated. I doubt that
someone actually wants to use 2-line toolbar ;-).

Limiting the number of items in the toolbar should be done in: http://www.netbeans.org/issues/show_bug.cgi?id=138633
Comment 4 Lukas Hasik 2008-07-30 09:18:12 UTC
*** Issue 142121 has been marked as a duplicate of this issue. ***
Comment 5 Lukas Hasik 2008-09-09 18:17:47 UTC
*** Issue 143423 has been marked as a duplicate of this issue. ***
Comment 6 Petr Chytil 2008-09-16 07:07:04 UTC
*** Issue 146117 has been marked as a duplicate of this issue. ***
Comment 7 Stanislav Aubrecht 2008-11-28 11:23:18 UTC
fixed

4f828389f2be


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo