Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 225542 - Provide full-featured high-quality dark Look And Feel(s)
Provide full-featured high-quality dark Look And Feel(s)
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: UI
7.3
PC Windows 7
: P2 (vote)
: 7.4
Assigned To: Petr Somol
issues@ide
http://plugins.netbeans.org/plugin/46...
issue_reviewed
: UI
: 228218 (view as bug list)
Depends on: 227525 215874 215877 215904 224841 225548 226032 226033 226133 226134 226159 226160 226161 226180 226183 226213 226273 226314 226315 226332 226385 227520 227522 227528 227529 227530 227533 227662 228363 228367 228380 228428 228907 231979 243064
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 15:03 UTC by Petr Somol
Modified: 2014-04-18 14:10 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Metal-based dark LaF under construction (97.48 KB, image/png)
2013-01-30 15:03 UTC, Petr Somol
Details
Screenshot of MySQL table view. (31.19 KB, image/png)
2013-05-17 14:27 UTC, sjzurek
Details
CVS screen in Dark Metal (29.29 KB, image/png)
2013-06-18 21:59 UTC, twolf2919
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Somol 2013-01-30 15:03:31 UTC
Created attachment 130842 [details]
Metal-based dark LaF under construction

This is a kind of umbrella issue, covering not only the creation of one or more good dark look-and-feels, but also the necessary adjustments across NB codebase.

Currently NB supports editor themes, which make it easily possible to set dark editor window background with bright text. However, the rest of IDE remains unaffected. Globally it is possible to run IDE in a specific look and feel (LaF), see http://wiki.netbeans.org/NBLookAndFeels, but the available choices do not include a dark LaF.

Creation of a dark LaF is now subject of UI Steering Committee interest: see http://wiki.netbeans.org/UIReviewsAreas#Alternative_Look_.26_Feels_-_Dark.2FInverted_Background

A Nimbus-based dark LaF plugin has been made available at http://plugins.netbeans.org/plugin/46003/?show=true. 

Many issues, however remain unresolved. The standard icons may look too bright, wizards have large white areas hardcoded, html display used in wizards and JavaDoc window does not adapt and displays dark text on dark background, etc.

In addition to the Nimbus based LaF, which renders dark window panes in a semi-dark IDE, we intend to provide one more dark LaF based on Metal, with more uniformly dark (though with distinctive differences in hue) backgrounds and IDE as a whole. See attachment for mockup. 

We intend to improve on both of the dark LaFs (Nimbus-based, Metal-based) to resolve all crucial UI and UEX problems so that the use of any of them does not compromise usability not readability.
Comment 1 Stanislav Aubrecht 2013-01-31 11:46:55 UTC
core-main 1df8daf75020

To run the IDE with a dark theme use this command line switch:

--laf Metal -J-Dnetbeans.plaf.dark.theme=true

or 

--laf Nimbus -J-Dnetbeans.plaf.dark.theme=true


Would be nice to have some sort of l&f switcher in Options window...
Comment 2 Stanislav Aubrecht 2013-01-31 16:15:59 UTC
(In reply to comment #1)
> 
> Would be nice to have some sort of l&f switcher in Options window...

core-main 73a10ce5b4a3
Comment 3 Quality Engineering 2013-02-02 02:36:26 UTC
Integrated into 'main-golden', will be available in build *201302020001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/1df8daf75020
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #225542 - dark color theme for Metal and Nimbus l&f
Comment 4 Stanislav Aubrecht 2013-02-14 09:59:17 UTC
87f6b4533f3f, 3520bac37e63, 9f7b072aaf4b
Comment 5 Stanislav Aubrecht 2013-02-14 11:49:21 UTC
7987f86a6227
Comment 6 Antonin Nebuzelsky 2013-02-19 15:41:04 UTC
acfc61559cb5
Comment 7 Stanislav Aubrecht 2013-02-20 09:47:41 UTC
76aff3f66c09
Comment 8 Stanislav Aubrecht 2013-04-05 09:06:08 UTC
*** Bug 228218 has been marked as a duplicate of this bug. ***
Comment 9 sjzurek 2013-05-17 14:27:24 UTC
Created attachment 134571 [details]
Screenshot of MySQL table view.

Hi Peter,

I have attached a screenshot of SQL view that has got *wrong background* color.
Text color is correct (light grey), probably inherited from the rest of scheme, but background color needs to be changed to something dark, for the text to be readable.

I believe this part of this project hasn't being touched yet.

Best regards,
-Simon.
Comment 10 twolf2919 2013-06-17 18:21:47 UTC
I just tried this in the 7.4 beta and there are still a number of windows that are unreadable because the foreground color wasn't changed from black to white - most notably, in "Dark Nimbus" the Output window (but works in "Dark Metal") and the Exception Reporter (fairly unreadable in both).
Also, in "Dark Nimbus", tree expansion buttons on the nodes (the '+' or '-') are nearly impossible to see.

I'm re-opening this bug.  If that is not the proper thing to do, I can open a new bug.
Comment 11 twolf2919 2013-06-17 18:24:11 UTC
(In reply to comment #10)

Oh, the "close" ('x') on the editor tabs is also very difficult to see in "Dark Nimbus".
Comment 12 Stanislav Aubrecht 2013-06-18 07:43:56 UTC
(In reply to comment #10)
> I just tried this in the 7.4 beta and there are still a number of windows that
> are unreadable because the foreground color wasn't changed from black to white
> - most notably, in "Dark Nimbus" the Output window (but works in "Dark Metal")
> and the Exception Reporter (fairly unreadable in both).
> Also, in "Dark Nimbus", tree expansion buttons on the nodes (the '+' or '-')
> are nearly impossible to see.
> 
> I'm re-opening this bug.  If that is not the proper thing to do, I can open a
> new bug.

Please file new issues specific to each problem, thanks.
Comment 13 twolf2919 2013-06-18 21:56:38 UTC
(In reply to comment #12)
> (In reply to comment #10)
> > I just tried this in the 7.4 beta and there are still a number of windows that
> > are unreadable because the foreground color wasn't changed from black to white
> > - most notably, in "Dark Nimbus" the Output window (but works in "Dark Metal")
> > and the Exception Reporter (fairly unreadable in both).
> > Also, in "Dark Nimbus", tree expansion buttons on the nodes (the '+' or '-')
> > are nearly impossible to see.
> > 
> > I'm re-opening this bug.  If that is not the proper thing to do, I can open a
> > new bug.
> 
> Please file new issues specific to each problem, thanks.

Stanislav,
That makes little sense to me.  This bug was created to implement a "full featured" dark theme - it does not do this in the areas I already mentioned as well as others I continue to discover quite easily (e.g. just now I noticed that the CVS screen is also unreadable - see attached screen shot).  Why create N bugs for individual screens when they could/should be addressed in this one?  Especially since those individual bugs will probably have little chance of being fixed in 7.4.

Unrelated to this: I created a feature bug way back in 2008 (https://netbeans.org/bugzilla/show_bug.cgi?id=151069) which has 16 votes that is pretty much addressed by this, newer, bug.  Shouldn't this bug reference that one - or vice versa?
Comment 14 twolf2919 2013-06-18 21:59:53 UTC
Created attachment 136000 [details]
CVS screen in Dark Metal

Note that the "Locally Modified" files are in a blue that is *very* difficult to read.  Note that the "Remotely Modified" files are nearly impossible to read.
Comment 15 Marian Mirilovic 2013-06-19 06:05:01 UTC
(In reply to comment #14)
> Created attachment 136000 [details]
> CVS screen in Dark Metal
> 
> Note that the "Locally Modified" files are in a blue that is *very* difficult
> to read.  Note that the "Remotely Modified" files are nearly impossible to
> read.

twolf2919, thanks for your feedback and your help. We appreciate that a lot, but to make life easier and speed-up bugfixing of each particular problem please follow http://wiki.netbeans.org/IssueReportingGuidelines : 
"One problem - One issue" part says :
Please submit one issue per problem. Different problems are most likely to be handled by different people. It's difficult to handle this issue for all involved parties. 

Thanks for your understanding and help, M


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo