Bug 227529 - [dark] Matisse color issues
[dark] Matisse color issues
Status: RESOLVED FIXED
Product: guibuilder
Classification: Unclassified
Component: Code
7.4
PC Linux
: P3 (vote)
: TBD
Assigned To: Tomas Pavek
issues@guibuilder
:
Depends on:
Blocks: 225542
  Show dependency treegraph
 
Reported: 2013-03-15 14:17 UTC by Antonin Nebuzelsky
Modified: 2013-05-31 16:01 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Matisse (28.64 KB, image/png)
2013-03-15 14:17 UTC, Antonin Nebuzelsky
Details
AnagramGame's About.java in Matisse (11.40 KB, image/png)
2013-03-15 14:22 UTC, Antonin Nebuzelsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antonin Nebuzelsky 2013-03-15 14:17:30 UTC
Created attachment 132656 [details]
Matisse

With Dark themes editing a Swing UI in Matisse changes colors quite wildly when clicking around in the design mode. An example is attached.
Comment 1 Antonin Nebuzelsky 2013-03-15 14:22:17 UTC
Created attachment 132657 [details]
AnagramGame's About.java in Matisse

This example shows AnagramGame sample's About dialog in design mode.

Can the overall fix for matisse be to not apply any dark colors to whatever UI is opened/created in the design mode?
Comment 2 Quality Engineering 2013-03-20 02:07:38 UTC
Integrated into 'main-golden', will be available in build *201303192300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/45d4615ecdd1
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #227529 - [dark] Matisse color issues
Comment 3 Stanislav Aubrecht 2013-03-20 09:04:20 UTC
I fixed the hardcoded colors of resizing hints in core-main 45d4615ecdd1

However the second problem is that .form file cache some colors so after switching look and feel the form may render incorrectly if Swing/AWT palette colors are used.
Reassigning to form editor module.
Comment 4 Tomas Pavek 2013-05-31 15:45:09 UTC
I don't understand the last comment about colors in the .form file and switching look and feels, sorry. Can you provide step by step description? Thanks.
Comment 5 Stanislav Aubrecht 2013-05-31 16:01:20 UTC
Never mind, I can't reproduce the second part of this issue anyway.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo