Bug 93196 - Provide a way to rename a server node
Provide a way to rename a server node
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
5.x
All All
: P3 with 1 vote (vote)
: 8.0
Assigned To: Petr Hejl
issues@serverplugins
:
: 110806 116331 129071 173572 215103 236417 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-25 14:43 UTC by alexismp
Modified: 2013-11-08 14:02 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alexismp 2007-01-25 14:43:42 UTC
The typical use-case is that you typically use the AS version as the name of the
node (i.e. "GlassFish v1") and after adding a domain you want to have consistent
naming ("GlassFish v1 - domain1" and "GlassFish v1 - domain2").
Comment 1 Petr Hejl 2007-09-21 15:22:54 UTC
*** Issue 116331 has been marked as a duplicate of this issue. ***
Comment 2 Petr Hejl 2008-04-08 08:54:26 UTC
*** Issue 110806 has been marked as a duplicate of this issue. ***
Comment 3 MackSix 2013-04-19 11:01:12 UTC
*** Bug 173572 has been marked as a duplicate of this bug. ***
Comment 4 Petr Hejl 2013-09-04 13:05:31 UTC
*** Bug 129071 has been marked as a duplicate of this bug. ***
Comment 5 Petr Hejl 2013-09-04 13:07:06 UTC
*** Bug 215103 has been marked as a duplicate of this bug. ***
Comment 6 Petr Hejl 2013-09-25 13:54:27 UTC
Backend is now able to change the server name: web-main a85784962fbe.
Comment 7 Petr Hejl 2013-09-25 13:54:44 UTC
UI and common api part still missing.
Comment 8 Quality Engineering 2013-09-26 02:07:21 UTC
Integrated into 'main-silver', will be available in build *201309260002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/a85784962fbe
User: Petr Hejl <phejl@netbeans.org>
Log: #93196 - Provide a way to rename a server node
Comment 9 Petr Hejl 2013-09-26 11:27:09 UTC
Fixed in web-main d027bc6cfac0.
Comment 10 Petr Hejl 2013-09-26 11:34:46 UTC
Though as glassfish is using a common server api it has to solve it on its own. I would strongly recommend to migrate it to j2eeserver api. I filed issu #236417 and issue #236418.
Comment 11 Quality Engineering 2013-09-27 02:10:39 UTC
Integrated into 'main-silver', will be available in build *201309270002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/d027bc6cfac0
User: Petr Hejl <phejl@netbeans.org>
Log: #93196 - Provide a way to rename a server node
Comment 12 TomasKraus 2013-11-08 14:02:26 UTC
Server node name is unique and is used as key attribute. Renaming it may cause problems with already running tasks.
Comment 13 TomasKraus 2013-11-08 14:02:31 UTC
*** Bug 236417 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo