Bug 117172 - Blank window when running the installer
Blank window when running the installer
Status: RESOLVED WONTFIX
Product: installer
Classification: Unclassified
Component: Code
6.x
PC Linux
: P3 with 1 vote (vote)
: TBD
Assigned To: issues@installer
issues@installer
: RELNOTE
: 119770 120406 122446 122715 134119 135505 154840 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-30 18:43 UTC by mssever
Modified: 2008-12-08 11:37 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Output from the --verbose flag (42.05 KB, text/plain)
2007-09-30 18:48 UTC, mssever
Details
Output of df (928 bytes, text/plain)
2007-09-30 18:48 UTC, mssever
Details
Screenshot (233.52 KB, image/png)
2007-09-30 18:50 UTC, mssever
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mssever 2007-09-30 18:43:45 UTC
I'm submitting this at the request of Dmitry Lipin.

I'm trying to install NetBeans 6.0 beta 1 Ruby on Ubuntu Feisty. I'm having problems, though. When I run the installer,
I get a blank window with nothing on it. I'm attaching the output of running with the --verbose switch, as well as a
screenshot.

By the way, I tried also the latest nightly build with identical results.
Comment 1 mssever 2007-09-30 18:48:00 UTC
Created attachment 49841 [details]
Output from the --verbose flag
Comment 2 mssever 2007-09-30 18:48:59 UTC
Created attachment 49842 [details]
Output of df
Comment 3 mssever 2007-09-30 18:50:10 UTC
Created attachment 49843 [details]
Screenshot
Comment 4 dlipin 2007-10-01 08:32:45 UTC
Scott,

could you please run installer with different L&F and check whether the issue is reproducible?

please try the following commands:
<installer.sh> --look-and-feel javax.swing.plaf.metal.MetalLookAndFeel
<installer.sh> --look-and-feel com.sun.java.swing.plaf.motif.MotifLookAndFeel
 
Thanks,
Dmitry
Comment 5 dlipin 2007-10-01 09:25:51 UTC
Scott,

could you please check the installer with the different JVM?
E.g. with jdk 1.5.0_12 or 1.6.0_02.

Thanks in advance,
Dmitry
Comment 6 dlipin 2007-10-01 09:31:48 UTC
Scott,

please also try set (for some time) the system theme to default not to Murrine - it can (and most probably is the 
issue).

Thanks,
Dmitry
Comment 7 dlipin 2007-10-01 09:56:27 UTC
Mikhail, Julia,

please check if the bug is reproducible with Ubuntu used by QE. 
Please install Murrine (http://murrine.netsons.org) when checking.

Thanks,
Dmitry
Comment 8 mssever 2007-10-02 16:47:17 UTC
I've tried the things you suggested. Switching the look and feel had no effect. I switched from sun-java6-* to
sun-java5-*. No dice. I switched the GTK theme first to Gilouche, then to the default Ubuntu theme, but that didn't
change anything, either.
Comment 9 dlipin 2007-10-02 18:06:43 UTC
Scott,

are all the other java GUI application normally running?
Comment 11 mssever 2007-10-02 19:21:47 UTC
Dmitry,

I can't answer whether other Java apps are working, since I have long avoided Java as much as possible. I tried Aptana a
while back, and it consistently crashed immediately after startup.

The export AWT_TOOLKIT=MToolkit workaround worked for me. Both Beryl and Compiz had problems. So I suppose that this is
a bug in Swing, then.

Thanks for your help on this.
Comment 12 dlipin 2007-10-02 19:26:38 UTC
Scott,
you are welcome :)

marking as will not fix as it is the JDK/Swing/Beryl issue.

Dmitry
Comment 13 dlipin 2007-10-23 14:07:17 UTC
*** Issue 119770 has been marked as a duplicate of this issue. ***
Comment 14 dlipin 2007-10-23 14:10:31 UTC
Irina,

please add this issue to the release notes.

Description: The installer appears as the blank/grey dialog when running on Ubunty with Beryl/Compiz/Compiz Fusion 
installed.
Wordkaround: execute command 'export AWT_TOOLKIT=MToolkit' before running the installer.
Dmitry
Comment 15 Irina Filippova 2007-10-23 14:14:15 UTC
OK - thanks for notification. I will add this issue to Beta 2 RNs
Comment 17 dlipin 2007-10-30 08:34:23 UTC
*** Issue 120406 has been marked as a duplicate of this issue. ***
Comment 18 dlipin 2007-11-21 07:22:31 UTC
*** Issue 122446 has been marked as a duplicate of this issue. ***
Comment 19 dlipin 2007-11-28 19:03:47 UTC
*** Issue 122715 has been marked as a duplicate of this issue. ***
Comment 20 mvyver 2007-11-29 07:39:33 UTC
You can add openSUSE 10.2 to this list of distro's.
This is not limited to the rc2, it goes back to netbeans-6.0-200709111200
The following is what I see:

 # /home/mv/bin/netbeans-6.0-200709111200/uninstall.sh
 Configuring the installer...
 Searching for JVM on the system...
 Extracting installation data...
 Running the installer wizard...

At this point I see the grey dialog box.
Then, things change (for the worse)...

 # export AWT_TOOLKIT=MToolkit
 # /home/mv/bin/netbeans-6.0-200709111200/uninstall.sh
 Configuring the installer...
 Searching for JVM on the system...
 Extracting installation data...
 Running the installer wizard...
 java: xcb_xlib.c:52: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
 /home/mv/bin/netbeans-6.0-200709111200/uninstall.sh: line 1266:  5275 Aborted                
 /usr/lib/jvm/java-1.6.0-sun-1.6.0/bin/java -Xmx256m -Xms64m -Dnbi.local.directory.path=/home/mv/.nbi 
 -Djava.io.tmpdir=/tmp -classpath /tmp/.nbi-4112921.tmp/uninstall.jar org.netbeans.installer.Installer --target nb-base   
 6.0.0.0.200709111200 --force-uninstall


This is a well known java issue which was previously fixed by:

# sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-1.6.0-sun-1.6.0/jre/lib/i386/xawt/libmawt.so

However it seems that the rc2 or the uninstall is not using that file?

Any suggestions?



 

with 

# /home/mv/bin/netbeans-6.0-200709111200/uninstall.sh
Configuring the installer...
Searching for JVM on the system...
Extracting installation data...
Running the installer wizard...
java: xcb_xlib.c:52: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
/home/mv/bin/netbeans-6.0-200709111200/uninstall.sh: line 1266:  6633 Aborted                
/usr/lib/jvm/java-1.6.0-sun-1.6.0/bin/java -Xmx256m -Xms64m -Dnbi.local.directory.path=/home/mv/.nbi
-Djava.io.tmpdir=/tmp -classpath /tmp/.nbi-4113001.tmp/uninstall.jar org.netbeans.installer.Installer --target nb-base
6.0.0.0.200709111200 --force-uninstall
 
Comment 21 dlipin 2007-11-29 08:46:27 UTC
mvyver,

I don`t understand what you requesting and asking..
1) Add OpenSuse to the list of the distros where this bug is reproducible on. Correct?

2) You mix here two issues : one with blank windows (with "MToolkit" workaround) and xlib.lock assertion issue (with 
"sed" workaround). As far as I know both workaround works more or less fine. Then what is your question (Any 
suggestions?) about?

Comment 22 mvyver 2007-11-29 22:29:17 UTC
Hi dlipin 
Thanks for the prompt response.  Apologies for not being clearer.
Q1) Yes.
Q2) I experience blank windows.  Following the suggested "MToolkit" workaround _generates_/leads to the  xlib.lock
assertion issue.  Under compiz-fusion-plugins-main-0.6.0-2.2 the sed work around _fails_ and I see the xlib.lock
assertion error reported.  The first workaround 'works' or at least leads on to the xlib.lock assertion issue.  That is
the sed work around does not work.

OK, my question:  Is there a Java distribution with which netbeans is known to 'just work'?
Comment 23 mvyver 2007-11-29 22:46:57 UTC
In case it helps:

# rpm -qa |grep -i compiz
libcompizconfig-backend-gconf-0.6.0-1.2
libcompizconfig-backend-kconfig-0.6.0-1.2
compiz-fusion-plugins-extra-0.6.0-1.4
compiz-fusion-kde-0.6.2-3.1
compiz-0.6.2-3.1
libcompizconfig-0.6.0-1.3
compiz-gnome-0.6.2-3.1
compizconfig-settings-manager-0.6.0-1.4
compiz-kde-0.6.2-3.1
python-compizconfig-0.6.0-1.2
compiz-fusion-plugins-main-0.6.0-2.2

> rpm -qa |grep -i java
gcc-java-4.1.3-29
java-1_6_0-sun-demo-1.6.0-3.1
java-1_6_0-sun-src-1.6.0-3.1
classpath-javadocs-0.92-20
java-1_6_0-sun-plugin-1.6.0-3.1
kdebindings3-javascript-devel-3.5.8-7.1
kdebindings3-javascript-3.5.8-7.1
java-1_4_2-gcj-compat-devel-1.4.2.0-66
kdebindings3-java-3.5.8-13.1
java-1_6_0-sun-1.6.0-3.1
gcc41-java-4.1.2_20061115-5
java-1_6_0-sun-alsa-1.6.0-3.1
mysql-connector-java-3.1.12-35
java-1_6_0-sun-jdbc-1.6.0-3.1
java-1_4_2-gcj-compat-1.4.2.0-66
java-1_6_0-sun-devel-1.6.0-3.1
Comment 24 mvyver 2007-11-30 04:24:20 UTC
OK, upgrading to sun's 1.6u3 fixes this issue for me (opensuse10.2 with compiz)... no sed hacks required.
This is not yet available via the openSUSE repositories so has to be done manually using Sun's bin installer.
After installing then:
ln -s /usr/java/jdk1.6.0_03 /usr/lib/jvm/java-1.6.0-sun
ln -s /usr/java/jdk1.6.0_03/jre /usr/lib/jvm/jre-1.6.0-sun

HTH?
Mark
Comment 25 dlipin 2007-11-30 08:39:14 UTC
OK.

Looking into the bug comments at BugTrack I see that sometimes the sed workaround doesn`t work.
Unfortunately I don`t know why...

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373
http://forums.fedoraforum.org/showthread.php?t=171763&page=1&pp=15
http://www.netbeans.org/servlets/ReadMsg?list=nbusers&msgNo=98765
http://lwjgl.org/forum/index.php/topic,2168.0.html

Using Java installed by Sun binary installer is a good solution in that case.
If I understand the issue correctly, the problems lies in the fact that most of Java package distributions uses dynamic 
linking of libXinerama though Sun`s binary distribution uses static.
I`ll call Release Notes writers to add a "xlib assertion issue" to the release notes. It`s worth be there since it 
arrise alsmost every day at netbeans mail lists and I wonder why it is not there yet.

Mark - thanks for that workaround. We`ll add it as the alternative to sed workaround...


Thanks,
Dmitry
Comment 26 rivasdiaz 2007-12-21 00:41:48 UTC
With the following steps the installer works OK on Ubuntu Gutsy:

Step 1: Install Sun Java SE 6 SDK

From the console, run:

$ sudo apt-get install sun-java6-jdk sun-java6-jre sun-java6-bin sun-java6-plugin sun-java6-demo sun-java6-fonts
sun-java6-javadb sun-java6-source

This packages can be installed from synaptic too. NetBeans requires the whole jdk, not only jre. Also Java DB is required.

Step 2: Set Sun Java SE 6 as Default

From the console, run:

$ sudo update-java-alternatives --set java-6-sun

This command will set Sun Java SE 6 as your default java implementation, so when you run java from the command line, Sun
Java SE 6 will be the one found.

(Optional) Step 3: Define your JAVA_HOME environment variable

Edit as root the file /etc/environment, using gedit or nano, and add the following line at the end:

JAVA_HOME="/usr/lib/jvm/java-6-sun"

(After this step you need to logout/login)

Adding this environment variable will simplify a lot your java problems.

After that, running java applications will run as expected as Java SE 6 Update 3 works OK with Compiz Fussion.

NOTE: Beryl will not work so if you are using Beryl, you should update to Compiz Fussion. On the other hand, if you
cannot install Sun Java SE 6 Update 3 for some reason, and you need java applications like NetBeans, you will need to
avoid using Compiz Fussion/Beryl/Compiz (Visual Effects). To remove Visual Effects in Gutsy go to
System/Preferences/Appearance. Select "Visual Effects" tab and click on option "None".
Comment 27 thinkdoggie 2008-04-29 07:25:45 UTC
*** Issue 134119 has been marked as a duplicate of this issue. ***
Comment 28 dlipin 2008-05-21 15:31:06 UTC
*** Issue 135505 has been marked as a duplicate of this issue. ***
Comment 29 xdark 2008-08-06 13:59:43 UTC
Thank you rivasdiaz. Works just well for Netbeans (not tested on the installer).
Comment 30 Bradley Schmidt 2008-08-19 12:08:56 UTC
The Relnote workaround may need an update. Nabble claims using JDK 6 update 10 or higher resolves this issue. Since JDK6
u10 will be out before 6.5 FCS, this would be nice for the release notes. Can QA confirm that this workaround is valid?

See http://www.nabble.com/Netbeans-on-Linux%2C-need-help...-td18499573.html#a18521605
Comment 31 dlipin 2008-12-08 11:37:49 UTC
*** Issue 154840 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo