Bug 154840 - Unable to unistall netbeans-rc2 from ubuntu 8.04
Unable to unistall netbeans-rc2 from ubuntu 8.04
Status: RESOLVED DUPLICATE of bug 117172
Product: installer
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: TBD
Assigned To: mslama
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 16:35 UTC by bernaulli
Modified: 2008-12-08 11:37 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bernaulli 2008-12-06 16:35:46 UTC
I am trying to uninstall netbeans-rc2 from my ubuntu 8.04. When I run uninstall.sh I am getting blank unistaller machine.
I am not able to unistall it by sudo apr-get remove netbeans becuase my ubuntu 8.4 doesn't recognice that netbeans is
installed. Console output I am getting is:

Configuring the installer...
Searching for JVM on the system...
Extracting installation data...
Running the installer wizard...
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb7f52767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb7f528b1]
#2 /usr/lib/libX11.so.6(_XReply+0xfd) [0xa28921bd]
#3 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so [0xa2b56dce]
#4 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so [0xa2b40d77]
#5 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so [0xa2b40ef3]
#6
/usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x26)
[0xa2b41136]
#7 [0xb2601c1b]
#8 [0xb25fbb3b]
#9 [0xb25fbb3b]
#10 [0xb25f9219]
#11 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb77b92bc]
#12 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb78cded8]
#13 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb77b90ef]
#14 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x32d) [0xb7816b9d]
#15
/usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d)
[0xb75ad30d]
#16 [0xb26014bb]
#17 [0xb25fba64]
#18 [0xb25f9219]
#19 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb77b92bc]
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb7f52767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb7f5281e]
#2 /usr/lib/libX11.so.6 [0xa2891518]
#3 /usr/lib/libX11.so.6(XGetVisualInfo+0x26) [0xa28880a6]
#4 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so [0xa2b400b9]
#5 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so [0xa2b40303]
#6 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so [0xa2b40fa1]
#7
/usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x26)
[0xa2b41136]
#8 [0xb2601c1b]
#9 [0xb25fbb3b]
#10 [0xb25fbb3b]
#11 [0xb25f9219]
#12 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb77b92bc]
#13 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb78cded8]
#14 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb77b90ef]
#15 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x32d) [0xb7816b9d]
#16
/usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d)
[0xb75ad30d]
#17 [0xb26014bb]
#18 [0xb25fba64]
#19 [0xb25f9219]
arvind@arvind-desktop:~/Desktop$ cd /usr/local
arvind@arvind-desktop:/usr/local$ cd /netbeans-6.5rc2/
bash: cd: /netbeans-6.5rc2/: No such file or directory
arvind@arvind-desktop:/usr/local$ cd netbeans-6.5rc2
arvind@arvind-desktop:/usr/local/netbeans-6.5rc2$ sudo sh uninstall.sh
Configuring the installer...
Searching for JVM on the system...
Extracting installation data...
Running the installer wizard...
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb7f59767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb7f598b1]
#2 /usr/lib/libX11.so.6(_XReply+0xfd) [0xb1a691bd]
#3 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so [0xb1b3bdce]
#4 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so [0xb1b25d77]
#5 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so [0xb1b25ef3]
#6
/usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x26)
[0xb1b26136]
#7 [0xb2608c1b]
#8 [0xb2602b3b]
#9 [0xb2602b3b]
#10 [0xb2600219]
#11 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb77c02bc]
#12 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb78d4ed8]
#13 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb77c00ef]
#14 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x32d) [0xb781db9d]
#15
/usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d)
[0xb75b430d]
#16 [0xb26084bb]
#17 [0xb2602a64]
#18 [0xb2600219]
#19 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb77c02bc]
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb7f59767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb7f5981e]
#2 /usr/lib/libX11.so.6 [0xb1a68518]
#3 /usr/lib/libX11.so.6(XGetVisualInfo+0x26) [0xb1a5f0a6]
#4 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so [0xb1b250b9]
#5 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so [0xb1b25303]
#6 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so [0xb1b25fa1]
#7
/usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x26)
[0xb1b26136]
#8 [0xb2608c1b]
#9 [0xb2602b3b]
#10 [0xb2602b3b]
#11 [0xb2600219]
#12 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb77c02bc]
#13 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb78d4ed8]
#14 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb77c00ef]
#15 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x32d) [0xb781db9d]
#16
/usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d)
[0xb75b430d]
#17 [0xb26084bb]
#18 [0xb2602a64]
#19 [0xb2600219]


What should i do to unistall netbeans-6.5rc2
Comment 1 dlipin 2008-12-08 11:37:53 UTC
If does not UI appear, then you can either
1) Run uninstaller on the JVM other than 1.5. (e.g. on 1.6 or openjdk) using "--javahome <path-to-java>" installer 
arguments
2) Do "export AWT_TOOLKIT=MToolkit" before running uninstaller
3) Just remove installation directory
rm -rf /usr/local/netbeans-6.5rc2

*** This issue has been marked as a duplicate of 117172 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo