Bug 233540 - java.util.NoSuchElementException at java.util.LinkedList.getFirst
java.util.NoSuchElementException at java.util.LinkedList.getFirst
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
7.4
All All
: P3 (vote)
: 7.4
Assigned To: Stanislav Aubrecht
issues@platform
http://bugs.sun.com/bugdatabase/view_...
EXCEPTIONS_REPORT, jdk_bug_8023148
: JDK_8
: 233998 236441 238187 240483 241538 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-27 14:13 UTC by sreimers
Modified: 2014-03-05 15:57 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.87 KB, text/plain)
2013-07-27 14:13 UTC, sreimers
Details
stacktrace (6.38 KB, text/plain)
2014-02-16 19:04 UTC, kimsp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sreimers 2013-07-27 14:13:11 UTC
Build: NetBeans IDE Dev (Build 201307262300)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b41, Java(TM) SE Runtime Environment, 1.8.0-ea-b99
OS: Mac OS X

User Comments:
sreimers: Starting NetBeans (MacOS, jdk8 b99)




Stacktrace: 
java.util.NoSuchElementException
   at java.util.LinkedList.getFirst(LinkedList.java:244)
   at java.awt.DefaultKeyboardFocusManager.repostIfFollowsKeyEvents(DefaultKeyboardFocusManager.java:290)
   at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:325)
   at java.awt.Component.dispatchEventImpl(Component.java:4749)
   at java.awt.Container.dispatchEventImpl(Container.java:2287)
   at java.awt.Window.dispatchEventImpl(Window.java:2724)
Comment 1 sreimers 2013-07-27 14:13:12 UTC
Created attachment 137899 [details]
stacktrace
Comment 2 Stanislav Aubrecht 2013-08-19 08:09:42 UTC
*** Bug 233998 has been marked as a duplicate of this bug. ***
Comment 3 Ralph Ruijs 2013-09-30 08:20:59 UTC
*** Bug 236441 has been marked as a duplicate of this bug. ***
Comment 4 Ralph Ruijs 2013-11-27 15:18:13 UTC
*** Bug 238187 has been marked as a duplicate of this bug. ***
Comment 5 ionuion 2013-12-10 13:22:39 UTC
Why is this bug set on WONTFIX? 
This is one of the frequent issues I encounter. It seems to have a lot of duplicates:
http://statistics.netbeans.org/analytics/detail.do?id=202589
Is this due to a JDK bug? 

Thank you
Comment 6 Stanislav Aubrecht 2013-12-10 14:21:40 UTC
(In reply to ionuion from comment #5)
> Why is this bug set on WONTFIX? 
> This is one of the frequent issues I encounter. It seems to have a lot of
> duplicates:
> http://statistics.netbeans.org/analytics/detail.do?id=202589
> Is this due to a JDK bug? 

Just switch to JDK 7 and you should be fine.
Comment 7 Ralph Ruijs 2014-01-24 10:43:26 UTC
*** Bug 240483 has been marked as a duplicate of this bug. ***
Comment 8 athompson 2014-01-28 16:20:20 UTC
(In reply to Stanislav Aubrecht from comment #6)
> Just switch to JDK 7 and you should be fine.

I'm using JDK 7 and I just got this error...
Comment 9 Stanislav Aubrecht 2014-02-10 10:39:44 UTC
*** Bug 241538 has been marked as a duplicate of this bug. ***
Comment 10 ytn01 2014-02-16 05:25:03 UTC
I'm still getting this exception:
http://statistics.netbeans.org/analytics/exception.do?id=712562
Comment 11 kimsp 2014-02-16 19:04:29 UTC
Created attachment 145264 [details]
stacktrace

I was participating in the Netcat, about to open a class with the same name as one I just closed (but in a different package).
Comment 12 Stanislav Aubrecht 2014-02-17 10:16:51 UTC
(In reply to ytn01 from comment #10)
> I'm still getting this exception:
> http://statistics.netbeans.org/analytics/exception.do?id=712562

Sure because it's a JDK bug which is fixed in dev builds of JDK 9 only.
Comment 13 kimsp 2014-02-17 11:03:20 UTC
(In reply to Stanislav Aubrecht from comment #12)
> (In reply to ytn01 from comment #10)
> > I'm still getting this exception:
> > http://statistics.netbeans.org/analytics/exception.do?id=712562
> 
> Sure because it's a JDK bug which is fixed in dev builds of JDK 9 only.

Is netbeans (being part of oracle) asking the JDK team to backport the JDK 9 fix to JDK 8?
Comment 14 kimsp 2014-02-17 19:02:36 UTC
(In reply to kimsp from comment #13)
> (In reply to Stanislav Aubrecht from comment #12)
> > (In reply to ytn01 from comment #10)
> > > I'm still getting this exception:
> > > http://statistics.netbeans.org/analytics/exception.do?id=712562
> > 
> > Sure because it's a JDK bug which is fixed in dev builds of JDK 9 only.
> 
> Is netbeans (being part of oracle) asking the JDK team to backport the JDK 9
> fix to JDK 8?

And there must be workaround. Perhaps with a different implementation of the affected code. This bug comes very often and gives a very bad UX.
Comment 15 Stanislav Aubrecht 2014-02-18 09:07:33 UTC
(In reply to kimsp from comment #14)
> (In reply to kimsp from comment #13)
> > (In reply to Stanislav Aubrecht from comment #12)
> > > (In reply to ytn01 from comment #10)
> > > > I'm still getting this exception:
> > > > http://statistics.netbeans.org/analytics/exception.do?id=712562
> > > 
> > > Sure because it's a JDK bug which is fixed in dev builds of JDK 9 only.
> > 
> > Is netbeans (being part of oracle) asking the JDK team to backport the JDK 9
> > fix to JDK 8?
> 
> And there must be workaround. Perhaps with a different implementation of the
> affected code. This bug comes very often and gives a very bad UX.

The LinkedList is in DefaultKeyboardFocusManager which is an AWT class so there's no workaround.
Comment 16 _ gtzabari 2014-03-05 15:57:41 UTC
I'll repeat the question: did anyone ask Oracle to backport the fix to JDK8?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo