Bug 236441 - java.util.NoSuchElementException at java.util.LinkedList.getFirst
java.util.NoSuchElementException at java.util.LinkedList.getFirst
Status: RESOLVED DUPLICATE of bug 233540
Product: editor
Classification: Unclassified
Component: Refactoring
7.4
All All
: P3 (vote)
: TBD
Assigned To: Ralph Ruijs
issues@editor
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 22:54 UTC by sreimers
Modified: 2013-09-30 08:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (6.85 KB, text/plain)
2013-09-26 22:54 UTC, sreimers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sreimers 2013-09-26 22:54:57 UTC
Build: NetBeans IDE Dev (Build 201309250002)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b50, Java(TM) SE Runtime Environment, 1.8.0-ea-b108
OS: Mac OS X

User Comments:
GUEST: tried to connect to javadb

sreimers: Doing refactoring using keyboard shortcuts

swpalmer: Hin fn-Delete to delete a class (.java file) that I didn't need.

GUEST: Trying to rename a package in the list view of the project.




Stacktrace: 
java.util.NoSuchElementException
   at java.util.LinkedList.getFirst(LinkedList.java:244)
   at java.awt.DefaultKeyboardFocusManager.repostIfFollowsKeyEvents(DefaultKeyboardFocusManager.java:290)
   at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:325)
   at java.awt.Component.dispatchEventImpl(Component.java:4749)
   at java.awt.Container.dispatchEventImpl(Container.java:2287)
   at java.awt.Window.dispatchEventImpl(Window.java:2706)
Comment 1 sreimers 2013-09-26 22:54:59 UTC
Created attachment 140523 [details]
stacktrace
Comment 2 Ralph Ruijs 2013-09-30 08:20:58 UTC

*** This bug has been marked as a duplicate of bug 233540 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo