Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 238187 - java.util.NoSuchElementException at java.util.LinkedList.getFirst
java.util.NoSuchElementException at java.util.LinkedList.getFirst
Status: RESOLVED DUPLICATE of bug 233540
Product: editor
Classification: Unclassified
Component: Refactoring
8.0
All All
: P3 (vote)
: 8.0
Assigned To: Ralph Ruijs
issues@editor
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-09 11:24 UTC by sreimers
Modified: 2013-11-27 15:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.05 KB, text/plain)
2013-11-09 11:24 UTC, sreimers
Details
stacktrace (4.04 KB, text/plain)
2013-11-09 13:03 UTC, sreimers
Details
stacktrace (5.05 KB, text/plain)
2013-11-23 16:46 UTC, sreimers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sreimers 2013-11-09 11:24:29 UTC
Build: NetBeans IDE Dev (Build 201311080001)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b56, Java(TM) SE Runtime Environment, 1.8.0-ea-b114
OS: Mac OS X

User Comments:
sreimers: Deleting Java File in modules proejct

ionuion: renamed method




Stacktrace: 
java.util.NoSuchElementException
   at java.util.LinkedList.getFirst(LinkedList.java:244)
   at java.awt.DefaultKeyboardFocusManager.repostIfFollowsKeyEvents(DefaultKeyboardFocusManager.java:290)
   at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:325)
   at java.awt.Component.dispatchEventImpl(Component.java:4756)
   at java.awt.Container.dispatchEventImpl(Container.java:2293)
   at java.awt.Window.dispatchEventImpl(Window.java:2741)
Comment 1 sreimers 2013-11-09 11:24:31 UTC
Created attachment 142020 [details]
stacktrace
Comment 2 sreimers 2013-11-09 13:03:16 UTC
Created attachment 142021 [details]
stacktrace

Deleting line of code in java source file
Comment 3 sreimers 2013-11-23 16:46:01 UTC
Created attachment 142509 [details]
stacktrace

Deleting Source File in project view, running on JDK8 b116
Comment 4 Exceptions Reporter 2013-11-23 16:46:05 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=204915
Comment 5 Ralph Ruijs 2013-11-27 15:18:13 UTC

*** This bug has been marked as a duplicate of bug 233540 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo