Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 240483 - java.util.NoSuchElementException at java.util.LinkedList.getFirst
java.util.NoSuchElementException at java.util.LinkedList.getFirst
Status: RESOLVED DUPLICATE of bug 233540
Product: editor
Classification: Unclassified
Component: Refactoring
8.0
All All
: P3 (vote)
: 8.0
Assigned To: Ralph Ruijs
issues@editor
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-15 09:19 UTC by mrpc
Modified: 2014-01-24 10:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.82 KB, text/plain)
2014-01-15 09:19 UTC, mrpc
Details
stacktrace (4.98 KB, text/plain)
2014-01-24 02:58 UTC, manikantannaren
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mrpc 2014-01-15 09:19:02 UTC
Build: NetBeans IDE Dev (Build 201401150002)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b63, Java(TM) SE Runtime Environment, 1.8.0-ea-b121
OS: Windows 8

User Comments:
mrpc: Tried to rename a directory of a new project with existing sources by clicking on the directory on projects window.




Stacktrace: 
java.util.NoSuchElementException
   at java.util.LinkedList.getFirst(LinkedList.java:244)
   at java.awt.DefaultKeyboardFocusManager.repostIfFollowsKeyEvents(DefaultKeyboardFocusManager.java:290)
   at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:325)
   at java.awt.Component.dispatchEventImpl(Component.java:4754)
   at java.awt.Container.dispatchEventImpl(Container.java:2292)
   at java.awt.Window.dispatchEventImpl(Window.java:2739)
Comment 1 mrpc 2014-01-15 09:19:05 UTC
Created attachment 143972 [details]
stacktrace
Comment 2 manikantannaren 2014-01-24 02:58:00 UTC
Created attachment 144328 [details]
stacktrace

Downloaded the latest build
Installed and Started IDE
Pressed Cmd+shift+n (Mac OSX)
Got this error.
Comment 3 Ralph Ruijs 2014-01-24 10:43:26 UTC

*** This bug has been marked as a duplicate of bug 233540 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo