Bug 227232 - unknown: LowPerformance took 20971 ms.
unknown: LowPerformance took 20971 ms.
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
7.4
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: Antonin Nebuzelsky
issues@platform
EXCEPTIONS_REPORT perf-profileme jdk_...
: JDK_8, PERFORMANCE
: 195278 238267 239056 239125 239614 239649 240415 240709 240876 240997 241101 241161 241196 241437 241623 241784 242008 242842 243434 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-09 11:57 UTC by sreimers
Modified: 2014-04-04 08:10 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (26.58 KB, application/nps)
2013-03-09 11:57 UTC, sreimers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sreimers 2013-03-09 11:57:36 UTC
This bug was originally marked as duplicate of bug 181584, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201303032300)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b21, Java(TM) SE Runtime Environment, 1.8.0-ea-b80
OS: Windows 7
Maximum slowness yet reported was 20971 ms, average is 20971
Comment 1 sreimers 2013-03-09 11:57:38 UTC
Created attachment 132398 [details]
nps snapshot
Comment 2 Petr Cyhelsky 2013-03-11 12:07:56 UTC
The whole time in AWT is spent in sun.awt.Win32GraphicsDevice.isPixFmtSupported[native]() - reassigning to jdk problems to evaluate whether this is some known or new jdk problem.
Comment 3 Marian Mirilovic 2013-06-26 15:03:26 UTC
the only report is on JDK8
Comment 4 Antonin Nebuzelsky 2013-06-28 12:19:18 UTC
JDK bug filed.
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8019378

Closing wontfix on NetBeans side.
Comment 5 Petr Cyhelsky 2013-11-12 11:43:53 UTC
*** Bug 238267 has been marked as a duplicate of this bug. ***
Comment 6 Petr Cyhelsky 2013-11-12 11:53:53 UTC
a workaround is suggested in http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6477756 :
-Dsun.awt.nopixfmt=true
should be used - if the application doesn't use OpenGL this shouldn't cause any problems.
Comment 7 Petr Cyhelsky 2013-12-03 10:36:01 UTC
*** Bug 239056 has been marked as a duplicate of this bug. ***
Comment 8 Petr Cyhelsky 2013-12-05 09:53:02 UTC
*** Bug 239125 has been marked as a duplicate of this bug. ***
Comment 9 Antonin Nebuzelsky 2013-12-16 12:47:49 UTC
*** Bug 195278 has been marked as a duplicate of this bug. ***
Comment 10 Antonin Nebuzelsky 2013-12-19 13:39:14 UTC
*** Bug 239649 has been marked as a duplicate of this bug. ***
Comment 11 Petr Cyhelsky 2013-12-20 13:26:17 UTC
*** Bug 239614 has been marked as a duplicate of this bug. ***
Comment 12 Tomas Hurka 2014-01-13 14:01:41 UTC
*** Bug 240415 has been marked as a duplicate of this bug. ***
Comment 13 Tomas Hurka 2014-01-29 14:36:45 UTC
*** Bug 240709 has been marked as a duplicate of this bug. ***
Comment 14 Tomas Hurka 2014-01-30 08:48:27 UTC
*** Bug 240876 has been marked as a duplicate of this bug. ***
Comment 15 Tomas Hurka 2014-01-30 08:50:31 UTC
*** Bug 240997 has been marked as a duplicate of this bug. ***
Comment 16 Tomas Hurka 2014-01-30 08:52:48 UTC
*** Bug 241101 has been marked as a duplicate of this bug. ***
Comment 17 Tomas Hurka 2014-01-30 12:31:53 UTC
*** Bug 241161 has been marked as a duplicate of this bug. ***
Comment 18 Tomas Hurka 2014-01-31 06:02:07 UTC
*** Bug 241196 has been marked as a duplicate of this bug. ***
Comment 19 Tomas Hurka 2014-02-05 12:46:15 UTC
*** Bug 241437 has been marked as a duplicate of this bug. ***
Comment 20 Tomas Hurka 2014-02-10 08:10:35 UTC
*** Bug 241623 has been marked as a duplicate of this bug. ***
Comment 21 Tomas Hurka 2014-02-13 05:42:14 UTC
*** Bug 241784 has been marked as a duplicate of this bug. ***
Comment 22 Petr Cyhelsky 2014-02-18 09:43:42 UTC
*** Bug 242008 has been marked as a duplicate of this bug. ***
Comment 23 Antonin Nebuzelsky 2014-02-18 10:11:11 UTC
Increased priority of the JDK bug.

https://bugs.openjdk.java.net/browse/JDK-6477756
Comment 24 Petr Cyhelsky 2014-03-13 12:40:29 UTC
*** Bug 242842 has been marked as a duplicate of this bug. ***
Comment 25 Petr Cyhelsky 2014-04-04 08:10:48 UTC
*** Bug 243434 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo