Bug 195278 - LowPerformance took 3931 ms.
LowPerformance took 3931 ms.
Status: RESOLVED DUPLICATE of bug 227232
Product: platform
Classification: Unclassified
Component: JDK Problems
7.0
All All
: P1 with 1 vote (vote)
: 7.0.1
Assigned To: Antonin Nebuzelsky
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 231830 232503 236986 239597 247972 252181 257847 258561 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-10 09:31 UTC by scotth1
Modified: 2016-04-29 07:45 UTC (History)
55 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (7.84 KB, application/nps)
2011-02-10 09:31 UTC, scotth1
Details

Note You need to log in before you can comment on or make changes to this bug.
Description scotth1 2011-02-10 09:31:22 UTC
This bug was originally marked as duplicate of bug 181584, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.0 Beta (Build 201011152355)
VM: Java HotSpot(TM) 64-Bit Server VM, 17.0-b16, Java(TM) SE Runtime Environment, 1.6.0_21-b06
OS: Linux

User Comments:
scotth1: editing a JSF 2.0 facelets client page.
typed:
<h:
and was waiting for list of tags.



Maximum slowness yet reported was 3931 ms, average is 3931
Comment 1 scotth1 2011-02-10 09:31:26 UTC
Created attachment 105833 [details]
nps snapshot
Comment 2 Martin Fousek 2011-06-02 13:08:41 UTC
OK so I tried to quickly evaluate all snapshots 7.0 a newer (last evaluated number was 512503).

Most of the snapshots were broken, some of them seems to not be caused by NB and the rest is in the category "could be valid" but I don't evaluate it for longer time if I saw that it should be another area.

broken snapshots: 512503, 510102, 511279, 512503, 511896, 511137, 510748, 510741, 479982
not NB related/extra slow native calls: 510770, 511784, 512265, 511461, 511229 
could be valid:  510400, 511382, 511299(JSP), 510410(JSF)

The original snapshot for JSF editor was badly uploaded as well. For the second JSF report I entered issue #199110. I'm reassigning this issue to JSP for evaluation of 511299.
Comment 3 Martin Fousek 2011-06-13 05:04:44 UTC
broken npss: 512613, 512705, 513065, 513619, 513265, 513491, 513829, 514051, 514194, 514244
not NB issues (slow java2d call): 512624, 513541

There is no valid profiler snapshot from the last 10 days. All mentioned snapshots are broken or NetBeans unrelated. Last investigated nps was 514244.
Comment 4 Martin Fousek 2011-06-13 05:30:12 UTC
I entered new issue #199371 for the JSP problems so this issue became stack of invalid and mostly broken exception reports. More than 50-60% of all attached snapshots are broken, perhaps cancelled by users. More than 85% of new snapshots from last 10 days were broken. Perhaps would be good to implement some filter for broken snapshots.

BTW, valid JSP, JSF troubles were separated so I'm closing this one.
Comment 5 muellermi 2011-06-22 06:39:06 UTC
Problem still exist in current nightly build, sometimes up to more than 20 seconds.
Comment 6 Martin Fousek 2011-06-24 07:38:11 UTC
muellermi can you please specify which what is slow? Especially your troubles seems to be perhaps related to JDK. It's suspicious that most of sun.java2d slownesses are under JDK 1.6 build 26. Please try to switch to another one, it should help.

Most of reports looks broken again or not directly nb related. Really roughly investigated...

broken snapshot: 516037, 515930, 515888, 515822, 515758, 515744, 515732, 515609, 515386, 515308, 515284, 514925, 514857

slow swing call: 514319

slow zipfile native calls by scanning: 515048

perhaps lack of resources: 515090

slow sun.java2d native call: 515764, 515697, 515695, 515470, 515467, 514834, 514328


I'm moving that to product Platform... could somebody evaluate mentioned sun.java2d calls? Is it possible to do with that anything? Perhaps feel free to close that as wontfix (I don't see actually way how to improve that). Thanks. 

In addition I will increase priority for filtering out broken snapshots since its more than 50% of this issue (see issue #199372).
Comment 7 Stanislav Aubrecht 2011-06-24 09:24:18 UTC
the slow native calls are in sun.java2d.windows.GDIBlitLoops.nativeBlit.
so it's either a bug in graphics driver or in JDK or both. cannot be fixed in netbeans.

try updating graphics driver and/or some other JDK update
Comment 8 ceklock 2011-06-24 13:07:55 UTC
I hope JavaFX 2.0 can save us from this neverending GUI bugs...
Comment 9 Tomas Mysik 2011-08-22 13:44:53 UTC
*** Bug 201138 has been marked as a duplicate of this bug. ***
Comment 10 Egor Ushakov 2012-10-30 05:36:03 UTC
is there a java bug on slow nativeBlit?
Comment 11 Petr Cyhelsky 2013-06-26 12:22:53 UTC
*** Bug 231830 has been marked as a duplicate of this bug. ***
Comment 12 Petr Cyhelsky 2013-07-22 10:42:03 UTC
*** Bug 232503 has been marked as a duplicate of this bug. ***
Comment 13 Petr Cyhelsky 2013-10-11 08:53:58 UTC
*** Bug 236986 has been marked as a duplicate of this bug. ***
Comment 14 Petr Cyhelsky 2013-10-11 08:58:19 UTC
the sun.java2d.windows.GDIBlitLoops.nativeBlit[native]
reports are still coming in, reassigning to jdk problems - is there a jdk bug filed for this? If not it should be filed.
Comment 15 Stanislav Aubrecht 2013-10-11 09:20:53 UTC
According to recent reports this looks like a duplicate of java bug #6477756
Comment 16 Antonin Nebuzelsky 2013-12-16 12:47:49 UTC

*** This bug has been marked as a duplicate of bug 227232 ***
Comment 17 Tomas Hurka 2013-12-18 12:40:03 UTC
*** Bug 239597 has been marked as a duplicate of this bug. ***
Comment 18 Tomas Hurka 2014-10-17 13:10:30 UTC
*** Bug 247972 has been marked as a duplicate of this bug. ***
Comment 19 Tomas Hurka 2015-04-30 11:34:33 UTC
*** Bug 252181 has been marked as a duplicate of this bug. ***
Comment 20 Tomas Hurka 2016-04-29 07:33:46 UTC
*** Bug 258561 has been marked as a duplicate of this bug. ***
Comment 21 Tomas Hurka 2016-04-29 07:45:53 UTC
*** Bug 257847 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo