Bug 217817 - IDE becomes unresponsive
IDE becomes unresponsive
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
7.3
PC Mac OS X
: P1 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
jdk_bug_7197298
: RELNOTE
: 214202 217883 218284 221874 223622 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 14:10 UTC by Petr Jiricka
Modified: 2012-12-12 09:11 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (17.15 KB, text/plain)
2012-09-04 14:10 UTC, Petr Jiricka
Details
IDE log file (41.33 KB, application/octet-stream)
2012-09-04 14:12 UTC, Petr Jiricka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2012-09-04 14:10:23 UTC
Created attachment 123883 [details]
Thread dump

At some point the IDE displays the beachball of death and needs to be killed from the console or the activity monitor. I am attaching a thread dump and IDE log after this happens; it is stuck in 
sun.lwawt.macosx.CCursorManager.nativeGetCursorPosition(Native Method).
Comment 1 Petr Jiricka 2012-09-04 14:12:28 UTC
Created attachment 123885 [details]
IDE log file

When this happened I also found this in the console (looks suspicious):

Sep  4 14:58:29 dhcp-prague08-second-floor-10-163-21-238.cz.oracle.com java[89995] <Error>: kCGErrorRangeCheck: CGSSetSurfaceShape
Sep  4 14:58:29 dhcp-prague08-second-floor-10-163-21-238.cz.oracle.com java[89995] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
2012-09-04 14:58:29.073 java[89995:707] CGSSetSurfaceShape failed - error 1007 (window:34399, surface:375770944, bounds:{{0, 0}, {2147483647, 2608}}
2012-09-04 14:58:29.084 java[89995:707] *** -[NSMutableArray initWithCapacity:]: Request for large capacity 25165824
WA
Comment 2 Petr Jiricka 2012-09-07 15:33:05 UTC
This now happens pretty consistently on JDK 7 -> P1. The only workaround is to use JDK 6.
Comment 3 Antonin Nebuzelsky 2012-09-10 14:57:40 UTC
JDK bug created:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7197298
Comment 4 Stanislav Aubrecht 2012-09-11 08:48:43 UTC
*** Bug 217883 has been marked as a duplicate of this bug. ***
Comment 5 Kenneth Ganfield 2012-09-11 10:19:21 UTC
Should this be release noted or something? It is a P1 that we will not fix and according to the issue the workaround is to use JDK 6
Comment 6 Antonin Nebuzelsky 2012-09-11 12:21:23 UTC
Ken, Petr, please try reproducing with the latest 7u10 b06.
http://jdk7.java.net/download.html

It could be fixed in b06 by the fix of
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7160609
Comment 7 Kenneth Ganfield 2012-09-11 12:35:55 UTC
I am using 7u10 b06 and I no longer have the problem.
The link to the JDK bug is not working for me.
Comment 8 Antonin Nebuzelsky 2012-09-17 09:18:41 UTC
*** Bug 218284 has been marked as a duplicate of this bug. ***
Comment 9 Petr Jiricka 2012-09-22 11:50:16 UTC
I suggest we don't allow the IDE to start on the affected JDK. I filed bug 218822 for this.
Comment 10 AlyonaStashkova 2012-11-06 11:12:08 UTC
Added to NB 7.3 Beta 2 Release Notes
Comment 11 Marian Mirilovic 2012-11-10 16:48:09 UTC
*** Bug 221874 has been marked as a duplicate of this bug. ***
Comment 12 Marian Mirilovic 2012-12-11 09:23:29 UTC
*** Bug 214202 has been marked as a duplicate of this bug. ***
Comment 13 Marian Mirilovic 2012-12-11 09:26:13 UTC
*** Bug 223622 has been marked as a duplicate of this bug. ***
Comment 14 Antonin Nebuzelsky 2012-12-12 09:11:00 UTC
7u10 was released as final yesterday.

Everyone on OS-X should upgrade to it, to prevent from running into this bug.

http://www.oracle.com/technetwork/java/javase/downloads/index.html


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo