Bug 214202 - Opening javadoc from navigator by Meta-F1 does not work
Opening javadoc from navigator by Meta-F1 does not work
Status: RESOLVED DUPLICATE of bug 217817
Product: java
Classification: Unclassified
Component: Navigation
7.2
PC Mac OS X
: P3 (vote)
: 7.3
Assigned To: Tomas Zezula
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 12:40 UTC by Jiri Prox
Modified: 2012-12-11 09:23 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2012-06-14 12:40:20 UTC
Opening javadoc window from navigator by pressing Meta-F1 does nothing.

Steps to reproduce:
1) open some java file
2) hover mouse over some item, until popup is opened
3) press meta-f1
-> at the bottom of the popup there is written 'Press Meta-F1 to enlarge', but it does nothing and the shortcut cannot be customized in Options

This is mac specific

Product Version: NetBeans IDE Dev (Build 201206140001)
Java: 1.7.0_05; Java HotSpot(TM) 64-Bit Server VM 23.1-b03
System: Mac OS X version 10.7.4 running on x86_64; US-ASCII; en_US (nb)
User directory: /Users/tester/Library/Application Support/NetBeans/dev
Cache directory: /Users/tester/Library/Caches/NetBeans/dev
Comment 1 Tomas Zezula 2012-10-19 07:12:03 UTC
Works fine on Apple JDK 1.6.
The JDK 7 u7-u9 blocks in 3s after IDE start in 

"AWT-EventQueue-1" prio=5 tid=0x00007fe8e9c67000 nid=0xa40b runnable [0x00000001639df000]
   java.lang.Thread.State: RUNNABLE
	at sun.lwawt.macosx.CCursorManager.nativeGetCursorPosition(Native Method)
	at sun.lwawt.macosx.CCursorManager.getCursorPosition(CCursorManager.java:63)
	at sun.lwawt.LWCursorManager.updateCursorImpl(LWCursorManager.java:79)
	at sun.lwawt.LWCursorManager.updateCursor(LWCursorManager.java:56)
	at sun.lwawt.LWComponentPeer.updateCursorImmediately(LWComponentPeer.java:885)
	at java.awt.Component.updateCursorImmediately(Component.java:3120)

so cannot be reproduced.
Anyway it's a JDK issue, maybe already fixed but I cannot verify because of the mentioned life lock.
Closing as incomplete until there will be a way to reproduce on u9.
Comment 2 Marian Mirilovic 2012-12-11 09:23:29 UTC

*** This bug has been marked as a duplicate of bug 217817 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo