Bug 218284 - NetBeans freezes on Mac after activating Java SE
NetBeans freezes on Mac after activating Java SE
Status: RESOLVED DUPLICATE of bug 217817
Product: ide
Classification: Unclassified
Component: Features On Demand
7.3
PC Mac OS X
: P2 with 1 vote (vote)
: 7.3
Assigned To: Jaroslav Tulach
issues@performance
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 11:57 UTC by host
Modified: 2012-09-17 20:23 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Activity monitor showing NetBeans freezing (156.03 KB, image/png)
2012-09-13 11:59 UTC, host
Details
Stacktrace (14.84 KB, text/plain)
2012-09-13 12:45 UTC, host
Details

Note You need to log in before you can comment on or make changes to this bug.
Description host 2012-09-13 11:57:40 UTC
I downloaded and performed a clean install of the full/all package of the latest nightly build.

If I start NetBeans now then it starts without problems (using Java JDK 1.7.0_07 on OS X 10.7.4).

Now I go to the plugins window where I activate Java SE and get a message that the activation was succesful.

Directly after this NetBeans freezes completely and I have to kill the NetBeans process. 

When I restart NetBeans then after the startup the IDE freezes again (almost) immediately.
Comment 1 host 2012-09-13 11:59:41 UTC
Created attachment 124297 [details]
Activity monitor showing NetBeans freezing
Comment 2 Petr Somol 2012-09-13 12:18:19 UTC
Thanks for the report. The problem is that we need more info to be able to dig into it. Especially the thread dump would help. See the following links for info on how to collect more valuable info about the problem:
http://wiki.netbeans.org/IssuezillaRules
http://wiki.netbeans.org/GenerateThreadDump

Reassigning to FOD as so far it seems activation related.
Comment 3 host 2012-09-13 12:45:36 UTC
Created attachment 124301 [details]
Stacktrace
Comment 4 host 2012-09-13 13:13:15 UTC
I forgot to mention that NB 7.2 runs without any problems in the same environment.
Comment 5 host 2012-09-15 16:03:40 UTC
Following a hint from another NetCAT participant, I switched to JDK 1.6.0_35 and started the same NB daily build. Now, NB works without any problems (modulo the normal bugs of course :-)) but does not freeze anymore.
Comment 6 Antonin Nebuzelsky 2012-09-17 09:18:41 UTC
A dup of already reported JDK bug.

Can you please try running with the latest 7u10 preview build and reopen this issue if you encounter the same threaddump with 

   CCursorManager.nativeGetCursorPosition

in AWT thread? Thanks!

7u10 developer preview builds: 
http://jdk7.java.net/download.html

*** This bug has been marked as a duplicate of bug 217817 ***
Comment 7 host 2012-09-17 20:23:58 UTC
I can acknowledge that with the change to JDK 7 U 10 (Preview) the freezing does not happen anymore.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo