Bug 218822 - IDE should refuse to start on JDK 7 lower than u10 due to bug 217817, bug 213926
IDE should refuse to start on JDK 7 lower than u10 due to bug 217817, bug 213926
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Launchers&CLI
7.3
All All
: P2 (vote)
: 7.3
Assigned To: Libor Fischmeistr
issues@platform
http://wiki.netbeans.org/Recommended7u10
: RELNOTE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-22 11:49 UTC by Petr Jiricka
Modified: 2013-01-29 08:18 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
a diff with implementation (57.89 KB, patch)
2012-12-18 18:16 UTC, Jiri Rechtacek
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2012-09-22 11:49:16 UTC
Bug 217817 (caused by a JDK issue) causes the IDE to hang when running on JDK 7 lower than update 10 on Mac OS X. I suggest that because of this problem, the IDE should refuse to start, and instruct the user to either upgrade to JDK 7u10 or newer, or use JDK 6.
Comment 1 Antonin Nebuzelsky 2012-09-24 08:36:27 UTC
This change can be implemented only after 7u10 is finally released.

Thus not for 7.3 Beta, nor 7.3 Beta 2. For these releases a release notes item should be added.
Comment 2 Petr Jiricka 2012-11-05 09:36:07 UTC
Looks like we may want to do this on other platforms as well besides Mac, because of bug 213926.
Comment 3 Jiri Rechtacek 2012-11-28 17:42:31 UTC
Started - http://hg.netbeans.org/core-main/rev/6ea2a82b29d8
Impl. on branch recommended_7u10_218822 @ core-main
Comment 4 Jiri Rechtacek 2012-12-18 18:16:01 UTC
Created attachment 129516 [details]
a diff with implementation

The branch recommended_7u10_218822@core-main is ready for merge. The diff of changes is in the attachment. The internal bits with these changes are available internally - let me know if anyone is interested.
Comment 5 Jiri Rechtacek 2012-12-20 17:34:32 UTC
http://hg.netbeans.org/core-main/rev/c325a48941c7
Comment 6 Quality Engineering 2012-12-21 02:33:10 UTC
Integrated into 'main-golden', will be available in build *201212210001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/c325a48941c7
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #218822: IDE should refuse to start on JDK 7 lower than u10
Comment 7 bunam 2013-01-29 08:18:45 UTC
same with RC 1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo