Bug 158522 - Categories in the new project wizard do not follow the permanent UI spec
Categories in the new project wizard do not follow the permanent UI spec
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: Features On Demand
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@performance
: ERGONOMICS
: 158376 158390 158549 158578 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 13:51 UTC by Petr Jiricka
Modified: 2009-06-21 13:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2009-02-13 13:51:41 UTC
1. Start the IDE with a fresh userdir
2. Select File -> New Project

The first category is called "Standard". The correct name should be "Java", per the permanent UI spec:
http://wiki.netbeans.org/NewProjectWizard

I suspect this is ergonomics-related, because after creating the project and selecting the wizard again, the category
name is now correct. And now I see that an analogous problem exists also for the other categories.
Comment 1 Petr Jiricka 2009-02-13 13:52:46 UTC
Here is the build info:

Product Version: NetBeans IDE Dev (Build 20090213032312)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-132
System: Mac OS X version 10.4.11 running on i386; MacRoman; en_US (nb)
Userdir: /Users/petrjiricka/.netbeans/dev
Comment 2 Jan Jancura 2009-02-13 16:32:23 UTC
> ergonomic
Comment 3 Jan Jancura 2009-02-14 09:53:00 UTC
*** Issue 158549 has been marked as a duplicate of this issue. ***
Comment 4 Jaroslav Tulach 2009-02-16 15:53:55 UTC
*** Issue 158578 has been marked as a duplicate of this issue. ***
Comment 5 Jaroslav Tulach 2009-02-16 16:45:16 UTC
ergonomics#44501498c884
Comment 6 Jan Jancura 2009-02-17 15:51:04 UTC
*** Issue 158376 has been marked as a duplicate of this issue. ***
Comment 7 Quality Engineering 2009-02-18 10:43:56 UTC
Integrated into 'main-golden', will be available in build *200902180201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/44501498c884
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #158522: Greatly improved dynamic verification and little tweak to static analysis to use localized names on folders
Comment 8 Jaroslav Tulach 2009-03-11 16:05:14 UTC
*** Issue 158390 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo