Bug 158578 - Cannot create new C/C++ project/sample
Cannot create new C/C++ project/sample
Status: RESOLVED DUPLICATE of bug 158522
Product: ide
Classification: Unclassified
Component: Features On Demand
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
: ERGONOMICS, REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-15 10:47 UTC by Alexander Simon
Modified: 2009-06-21 13:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Works for me (71.57 KB, image/png)
2009-02-16 11:11 UTC, Jaroslav Tulach
Details
Works on Windows XP too (61.45 KB, image/png)
2009-02-16 11:32 UTC, Jaroslav Tulach
Details
broken start page names (11.33 KB, image/png)
2009-02-16 13:28 UTC, Vladimir Voskresensky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2009-02-15 10:47:00 UTC
Steps:
- start IDE with fresh user dir
- start new project wizard
No C/++ category in the dialog
After opening old C/C++ project all OK

     [exec] -------------------------------------------------------------------------------
     [exec] >Log Session: Sunday, February 15, 2009 1:33:14 PM MSK
     [exec] >System Info:
     [exec]   Product Version         = NetBeans IDE Dev (Build 090214)
     [exec]   Operating System        = Windows XP version 5.1 running on x86
     [exec]   Java; VM; Vendor        = 1.5.0_16; Java HotSpot(TM) Server VM 1.5.0_16-b02; Sun Microsystems Inc.
     [exec]   Runtime                 = Java(TM) 2 Runtime Environment, Standard Edition 1.5.0_16-b02
     [exec]   Java Home               = D:\Program Files\Java\jdk1.5.0_16\jre
     [exec]   System Locale; Encoding = ru_RU (nb); Cp1251
     [exec]   Home Directory          = C:\Documents and Settings\Alex
     [exec]   Current Directory       = D:\Program Files\Java\jdk1.5.0_16\jre\bin
     [exec]   User Directory          = D:\tec\main\nbbuild\testuserdir
     [exec]   Installation            = D:\tec\main\nbbuild\netbeans\nb7.0
Comment 1 Vladimir Voskresensky 2009-02-15 11:17:06 UTC
it's ergonomic problem
Comment 2 Alexander Simon 2009-02-15 11:33:09 UTC
Repeated on development build:
Product Version: NetBeans IDE Dev (Build 200902140319)
Java: 1.6.0_11; Java HotSpot(TM) Server VM 11.0-b16
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)
Userdir: C:\Documents and Settings\Alex\.netbeans\dev
Comment 3 Jaroslav Tulach 2009-02-16 11:11:11 UTC
Created attachment 77016 [details]
Works for me
Comment 4 Jaroslav Tulach 2009-02-16 11:20:53 UTC
I've just tested everything on
/net/smetiste/space/builds/netbeans/trunk/daily/2009-02-13_15-48-59/zip/netbeans-trunk-nightly-200902131548.zip
and it works ok on my linux computer.

I'll check on Windows XP running in VirtualBox now.
Comment 5 Jaroslav Tulach 2009-02-16 11:32:32 UTC
Created attachment 77017 [details]
Works on Windows XP too
Comment 6 Jaroslav Tulach 2009-02-16 11:40:15 UTC
So far everything indicates that this is not a blocker for M2. Please run with 
-J-Dorg.netbeans.modules.ide.ergonomics.level=100
to give us some clue of what can be wrong in your case.
Comment 7 Vladimir Voskresensky 2009-02-16 13:20:37 UTC
Hi, Jarda,
The correct name MUST BE not "Native", but "C/C++" (which is right in non-ergonomic) - that's why we all missed familiar
folder. For C/C++ team it is the blocker.

=> Localazing bundle is not loaded
our cnd.makeproject/src/org/netbeans/modules/cnd/makeproject/ui/resources/layer.xml has needed settings
    <folder name="Templates">
        <folder name="Project">
            <folder name="Native">
                <attr name="SystemFileSystem.localizingBundle"
stringvalue="org.netbeans.modules.cnd.makeproject.ui.wizards.Bundle"/>


May be the problem is that bundle is in not the same package as layer.xml file itself
Comment 8 Vladimir Voskresensky 2009-02-16 13:24:38 UTC
Btw, on the Start Page there is also text "Native", but not C/C++
Comment 9 Vladimir Voskresensky 2009-02-16 13:26:51 UTC
Oh, you can see problems in other names in attached image, not only C++ has problems :-)
Comment 10 Vladimir Voskresensky 2009-02-16 13:28:30 UTC
Created attachment 77021 [details]
broken start page names
Comment 11 Jaroslav Tulach 2009-02-16 15:53:55 UTC
I am surprised that nobody noticed this sooner. And suddenly two bug reports in last three days. Marking duplicate of 
issue 158522.

Btw. however annoying this can be, it is not P1, but I'll do my best to fix it for M2.

*** This issue has been marked as a duplicate of 158522 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo