Bug 89894 - Add word wrap for text files
Add word wrap for text files
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
All All
: P1 with 201 votes (vote)
: 6.x
Assigned To: issues@editor
issues@editor
:
: 33419 34719 138309 142239 (view as bug list)
Depends on: 121357
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-22 20:19 UTC by whartung
Modified: 2013-03-07 10:31 UTC (History)
13 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description whartung 2006-11-22 20:19:04 UTC
Simply put, once in the IDE it would be nice to remain in the IDE. I write
little design scribblings and other ramblings in simple text files.

It would be nice if when in "text file mode" (vs, say, Java Code mode), if the
editor would word wrap. It could be at the window margin or at the text limit
margin, whichever.
Comment 1 Vitezslav Stejskal 2006-11-22 22:58:48 UTC
It's on our wishlist. Although it sounds like an easy feature it's actually not
that easy to implement. Anyway, may be ready for 6.0, but it's not a priority.
Thanks for the report.
Comment 2 olo 2008-01-19 13:18:45 UTC
I've always wondered, why there's no soft word-wrap for Java source editing (and for that matter, as a basic
functionality for all possible text editors, e.g. by use of inheritance)?

It makes me mad when managing JPA query annotations, which are put on on extremely long line (imagine a line 660
characters long). I imagine that complex, deeply nested HTML and XML files give the same problem.

Soft word wrap would make this much easier to read and edit. What's intriguing is that Eclipse also doesn't have soft
word wrap by default, but at least there's a plugin for Eclipse for that. I couldn't find any for Netbeans.

Comment 3 Vitezslav Stejskal 2008-01-21 09:46:55 UTC
Even though the feature may look trivial from the user's point of view it actually complicates things a lot.
Comment 4 Miloslav Metelka 2008-01-21 15:51:53 UTC
Line wrapping is part of issue 121357. The new view hierarchy is currently planned for NB7.0.
Comment 5 Vitezslav Stejskal 2008-06-06 11:06:49 UTC
*** Issue 34719 has been marked as a duplicate of this issue. ***
Comment 6 Vitezslav Stejskal 2008-06-06 11:06:53 UTC
*** Issue 33419 has been marked as a duplicate of this issue. ***
Comment 7 Vitezslav Stejskal 2008-06-06 11:07:50 UTC
Please see comments in the duplicates for more details on the subject.
Comment 8 Vitezslav Stejskal 2008-08-01 13:28:43 UTC
*** Issue 142239 has been marked as a duplicate of this issue. ***
Comment 9 Petr Pisl 2008-08-13 09:46:28 UTC
I got last week more than 5 requests to provide this functionality in php and html editor. I'm increasing to P1
priority, because this is one of the basic functionality of an editor and also there are many users requests. 
Comment 10 Petr Dvorak 2008-08-15 01:42:44 UTC
*** Issue 138309 has been marked as a duplicate of this issue. ***
Comment 11 mrmorris 2008-08-25 20:17:13 UTC
I'd like to suggest this be done such that it preserves indentation/scope, i.e. wrapping is done to the same column on
the next line rather than wrapping to column 0 which can often be observed in naive implementations of this feature.

Editplus is a good example of wrapping the way I suggest: 
http://www.editplus.com/ss/editplus.gif

Visual studio and DreamWeaver are examples of how not to do it:
http://visualstudiotips.files.wordpress.com/2006/04/WordWrap8.png
http://www.learnwebdesignonline.com/images/dreamweaver/dw8codecollapse/pict2.gif

I don't believe any Java IDE offer this capability today, in other words, it could set NetBeans apart from the rest!
Comment 12 glemigh 2008-08-25 20:35:22 UTC
I find the soft wrapping in Kate (KDE's Advanced text editor) to be an excellent example of soft wrapping.

And what mrmorris said. :)
Comment 13 ejvyas 2008-10-20 20:10:54 UTC
This is a very basic part of coding and IDE features. What is the status of this issue?
Comment 14 Vitezslav Stejskal 2008-10-22 09:56:17 UTC
AFAIK there is no plan to work on this in the near future, I'm sorry.
Comment 15 mbedward 2008-10-23 01:24:37 UTC
Adding my voice and vote to this, esp. for Java and HTML editing. Since this has been raised to P1 and attracts so much
interest I hope that it can receive some attention soon (?)  Thanks.
Comment 16 benko 2008-10-23 10:28:01 UTC
I can't believe that a text editor does not support word-wrap. This is a basic feature, text editors I used 20y back had word-wrap. This is a must-have 
feature.
Comment 17 szgy 2008-11-15 11:38:08 UTC
It is really frustrating to develop web pages (with HTML/PHP) when there is no word wrapping. 
Comment 18 oneofone 2008-12-04 23:03:50 UTC
I'm voting for this as well, Netbeans is by far the best IDE and has the best editor with the exception of this bug.
Comment 19 catweasle 2008-12-21 10:46:34 UTC
IntelliJ IDEA has got this, in a nice configurable way.
Comment 20 nosi 2008-12-26 10:51:00 UTC
It's a must for html editing!
Comment 21 kissedsmiley 2008-12-28 02:54:52 UTC
Especially when the system may have trouble with window size already, like on a small crt or linux, wordwrap is vital.
it would also help lot here in the comments as we are editing. My comment window is eons wide. Thank you!
Comment 22 cyberskin 2008-12-30 19:24:44 UTC
It's unfathomable why this hasn't been implemented.  I'm looking to switch from Eclipse (with MyEclipse) mainly 
because editing html/php is such a pain without word wrap and they are not looking to implement it any time soon.  I 
generally fall back on Homesite but it's lack of a decent debugger makes it a stop gap solution at best.  Please, 
please, please implement this and I will be a loyal customer for life!
Comment 23 mcorsi 2009-01-23 17:12:10 UTC
<code>AFAIK there is no plan to work on this in the near future, I'm sorry.</code>


Has this situation changed? This feature is a must for working on legacy code or for working with large blocks of text 
on a php/html page. Is there anything I can do to help get development on this moving? 

Regards,

mark-at-corsi-dot-us
Comment 24 shumisha 2009-02-09 08:49:53 UTC
Hi all,

Just adding my voice. Considering switching away from Eclipse, I had hoped Netbeans would provide this while Eclipse
does not (there is no working plugin for Eclipse), but we're stuck it seems. Aptana does it nice, but not Ant
integration. Someday someone will have all the bascis I guess ...
Comment 25 dgo 2009-02-11 13:36:37 UTC
I agree with all this...
apart from the missing word wrap function, Netbeans is a great tool for my PHP development...
this is SOOOOOOOOOOOO frustrating...
please please please please implement word wrap !!
Comment 26 3dd13 2009-02-24 00:19:06 UTC
Voting for wordwrap. Used Aptana studio > very slow > no wordwrap. Changed to NetBeans > very fast! > but no wordwrap
:-/. Got Aptana update 1.2 > yeah wordwrap > but scrolling is getting slow when writing CSS-Reset YUI in one line and
1000+ lines of code. Waiting for wordwrap to change completely to NetBeans. Meanwhile back to Notepad++ + Aptana.
Need that wordwrap, please. Keep up the good work.
Comment 27 sunburned 2009-03-22 13:05:42 UTC
This issue is important.  Line breaks in the wrong places in html files can cause unexpected results in some versions 
of (naturally) Internet Explorer.  Netbeans has a lot of good features, and it looks very pretty.  But perhaps some of 
the effort spent to polish up the flair would have been better spent on including _basic_ functionality.  Line wrapping 
is a basic editor function, and the lack of an option for it is similar to what the situation would be if there were no 
option to view line numbers.

Netbeans has good features for javascript and html editing (necessary for good jsp development), but the lack of word-
wrapping means it is actually less useful than a basic text editor with syntax highlighting and line-wrap.  The lack of 
line-wrap makes netbeans UNSUITABLE for use when heavy html coding is involved, and if that's not viewed as a serious 
issue it should be.
Comment 28 synchro 2009-03-25 15:00:25 UTC
BBEdit handles line wrapping really nicely. It indents wrapped lines to match the current indent, just like mrmorris suggests.
Comment 29 synchro 2009-03-25 15:02:03 UTC
BBEdit handles line wrapping really nicely. It indents wrapped lines to match the current indent, just like mrmorris suggests. It would also be good to have 
different wrapping schemes - fixed width or window width.
Comment 30 jgneff 2009-05-07 16:44:28 UTC
Instead of adding the formatting or word-wrapping to the NetBeans editor
itself, I would be happy to have a way to pass selected text or the entire
document to external tools on the system.  That's what "gedit" on Linux
does, for example.  It has text wrapping, but I use its External Tools
feature to do any wrapping and formatting instead.

I map Ctrl-T to the following command for HTML formatting:

  # HTML Tidy
  tidy -config $HOME/.tidy/tidy.conf

I map Alt-Shift-F to the following command for Java formatting:

  # Java Formatter
  astyle --style=java

And I map Ctrl-R to the following command to reformat the selected plain
text:

  # Paragraph Formatter
  fmt --uniform-spacing --width=78

If NetBeans had a way to run the currently selected text or the current
document through external tools, I could use all the nice text processing
tools that I use every day on my system, and I wouldn't need this word
wrap feature added.  Just a simple "select text, Ctrl-R" would do the trick.
Comment 31 Petr Jiricka 2009-05-11 11:39:32 UTC
I think what you are describing is already tracked as issue 35582. And yes, I agree it would be a very useful addition.
Comment 32 alexanderceb 2009-05-26 15:11:46 UTC
This feature is necessary, for simple usability because is impossible read a line code with thousands columns.
Comment 33 ab2qik 2009-06-15 22:53:57 UTC
Tried searching for word wrap on n.b-6.7 but does not look like its an option anywhere.

Otherwise, its an awesome editor. 

Please can it be made awesomer by implementing word wrap in an intelligent way.

thankyou.
Comment 34 sandrob57 2009-06-15 22:56:26 UTC
I'm loving netbeans...except for this one issue.

It's just so painful to use the editor when editing long lines of code.

This is such a necessary feature; I really hope this is getting some consideration.
Comment 35 edlucas 2009-06-17 16:18:38 UTC
I'm demoing NetBeans now for PHP/XHTML/CSS use and the lack of this feature is the only thing keeping me from making
this my primary editor.
Comment 36 treffynnon 2009-06-17 18:02:30 UTC
Looking forward to the addition of this feature.  When leave comments don't forget to vote for the issue as well.
Comment 37 xplorer 2009-07-16 20:31:01 UTC
I really miss this "all-other-editors-have-even-notepad" feature when editing project specs :-(
Comment 38 leomaheo 2009-08-23 15:57:09 UTC
Voted.  :-)
Comment 39 marnen 2009-11-14 00:01:54 UTC
Voting for word wrap. This is an essential feature for usability. I mostly use KomodoEdit, and word wrap is one big reason. Whether it's easy to implement or not is frankly immaterial -- the lack of word wrap is making the program far less usable than it should be.
Comment 40 marnen 2009-11-14 00:03:06 UTC
BTW, what's the point of making this a P1 feature if, still, nothing gets done on it? Why bother having priorities if you don't pay attention to them?
Comment 41 Petr Jiricka 2009-12-17 02:52:30 UTC
Two more blogs that request this feature:
http://www.rarst.net/software/netbeans-php/
http://www.davidtan.org/no-word-wrap-in-netbeans-ide/
Comment 42 misterx 2009-12-17 06:50:56 UTC
Word wrap is a *basic requirement* for text editing. Many voices say "we need this!", and many others say "I can't use Netbeans because it doesn't have this basic feature. Yet even as a P1, Vitezslav says it is not being worked on. How can this be? 

I would very much like to hear what the logic is behind not adding this functionality. Do the needs of the php/html community carry no weight?
Comment 43 misterx 2009-12-17 06:51:41 UTC
Word wrap is a *basic requirement* for text editing. Many voices say "we need this!", and many others say "I can't use Netbeans because it doesn't have this basic feature". Yet even as a P1, Vitezslav says it is not being worked on. How can this be? 

I would very much like to hear what the logic is behind not adding this functionality. Do the needs of the php/html community carry no weight?
Comment 44 frell 2009-12-17 07:01:00 UTC
This bug suggests it is being worked on.

https://netbeans.org/bugzilla/show_bug.cgi?id=121357

So ive got my fingers crossed.
Comment 45 misterx 2009-12-17 07:29:10 UTC
Frell- Thank you for pointing that out! I am glad someone is working on it. (and sorry for the double post earlier)
Comment 46 SebastianJu 2010-01-06 04:22:46 UTC
Thats pretty important.

And no it doesnt help to make manual wordwraps with enter. I see it at work. When a azubi is using another resolution or maximize its window and make manual wordwraps then everone that has another resolution has a problem like you can imagine.

Its bad to work without softwrap.

Can someone explain wheres the problem in coding that? I would be pleased by a simple wrap when a space occurs. So I dont see the point where it should be hard to code...
Comment 47 baffyofdaffy 2010-01-06 07:34:05 UTC
"So I dont see the point where it should be
hard to code..."

Believe me, this difficulty was not pointed out without reason.

Based on my experience and what I have gathered, the word wrap requires some structural rewriting. The original system does not leave room for the feature,, and I believe the original system is a dependency for several other systems which may have to be touched and certainly have to be considered.

To all those who thinks it is easy. :/
Comment 48 gregorybolkenstijn 2010-01-06 07:42:19 UTC
It might sound harsh, but we users don't care about how hard it is. We just want the feature.

Every other editor I tried had this feature. I was actually quite surprised that netbeans didn't have word wrap in the first place. Thank god it has other great features.
Comment 49 SebastianJu 2010-01-06 07:49:26 UTC
I used Aptana Studio before which is based on Eclipse. And there isnt softwrap too. It was really annoying so I read how someone wrote to the wordwraptopic that he is now using Netbeans and is pleased... So Im trying and... it doesnt have word wrap too...
Really painful...

But I like Netbeans more than Aptana now. But still need wordwrap.
Comment 50 synchro 2010-01-06 09:06:35 UTC
Eclipse and JetBrains WebIDE also lack word wrap. My guess is that they're all using the same underlying framework for the editor, and nobody wants to touch it as it's "somebody else's problem".
Comment 51 Miloslav Metelka 2010-01-07 08:41:06 UTC
NB editor is Swing based. Wordwrap in javax.swing.text is generally done by breaking individual views by javas.swing.text.View.breakView(). You may want to see e.g. WrappedPlainView with its logical/physical views mechanism. We are implementing sort of a similar mechanism but more memory efficient and more optimized for our particular case. Target NB6.9 still remains.
Comment 52 SebastianJu 2010-01-07 08:48:30 UTC
Thats great news... Thanks for working on it...

Is there a timeline when 6.9 will be born?
Comment 53 baffyofdaffy 2010-01-07 08:51:57 UTC
http://netbeans.org/community/releases/roadmap.html

This shows time between previous releases.

It will (soon?) show the target date for the next release
Comment 54 puffin 2010-01-08 15:36:33 UTC
Yikes, 3+ years since the first request for this absolutely essential feature...
Comment 55 omerbarlas 2010-01-13 08:40:18 UTC
the wordwrap is a must and even if I like netbeans *very* much, I will stick with Geany for a long time I guess.
Comment 56 Winter_Mute 2010-01-25 18:29:58 UTC
The comments by the developers whining about how hard it is to add this common feature available in popular development software packages is why the open source community will never overtake commercial alternatives.  Even TextPad, a far smaller program, has word wrap.  This is why Linux is barely a blip in the desktop marketshare.  
If the arrogance of open source developers like the ones who created Netbeans matched their laziness and indifference to criticism, maybe you guys would have a prayer of turning Netbeans into something really spectacular.  You talk all day about how great your code is, but all that great code doesn't mean squat if the product in question sucks.  
If word wrap is incredibly daunting to add now, it means you screwed up royally somewhere along the way and you really have no good idea what your code is designed to do.  You planned poorly from the beginning, didn't properly document your so-called superior code, and now implementing word wrap across all your modules is next to impossible because of how tangled and interdependent your previous generations of features have become.  
I'd much rather pay full price for Visual Studio or send some money to Helix Software for TextPad than to deal with all your non-sensical design decisions.  I've already done both and Netbeans is getting flushed off my hard drive.  I'm sorry, Netbeans, it's nothing personal, but your creators aren't worth a penny.
Comment 57 brettz9 2010-01-25 18:48:35 UTC
What I understand less is comments attacking the developers who have done a very fine job bringing us a _free_ product. If you want to pay for a commercial product which implements the features you want, then do so. I hardly see the developers being arrogant here. 

It's fine to argue you want this to be a higher priority, that it is a basic feature needed by IDEs, etc., but if you're tempted to go beyond this and stoop to personal attacks, submit a patch yourself and prove your own skills rather than harassing the developers who I think have otherwise provided a very good product.

Sheesh.
Comment 58 00kell 2010-01-26 00:47:39 UTC
Re: comment 56

Before a flame war starts, I would just like to add that most people undoubtably agree with brettz9 (comment 57) otherwise it would not have taken 56 comments and 3 years to find someone who wanted to attack the developers.

Let me also remind readers that the issue that Word Wrap depends upon is now being worked on (121357 - see link at top or in comment 44).  Still, if you have voted for this feature then you should show Miloslav some support and also vote for it.
Comment 59 djrobbins 2010-01-28 11:22:50 UTC
I think the developer bashing is totally un-called for.

Netbeans is a great IDE and the developers have done a tremendous job to provide a free product to the world over. I've tried using several over IDE's over the years and it is by far the only that satisfies all of my needs. Especially with the nbgit plugin. It uses less resources than any other java based IDE I have used that is this feature packed. 

Now down to wordwrap. Real programming does not need word wrap, plain and simple. Every language has a way to wrap statements, expressions, strings, etc. The only time word wrap comes in handy at all is with HTML and even then in most cases you can wrap the html yourself and even then, you shouldn't be hard-coding HTML these days.

Leaving extremely long horizontal statements in your code is discourteous to any other programmer that needs to read or modify your code. It is annoying and it makes it extremely difficult to read, __even__ when wrapped. Best coding practice is to wrap your code yourself with real line breaks. It's easier to read and understand if indented correctly. 

I have been using Netbeans for a very long time now and never once found the "NEED" for word wrap. It is not essential. Regardless of what logic/programming decisions where made years ago that makes this feature difficult to implement without serious re-writes it is still what I use as my only IDE.

This application is free and open source and thousands of people would like to keep it that way. Thank you Sun.
Comment 60 marnen 2010-01-28 12:09:12 UTC
(In reply to comment #59)
> I think the developer bashing is totally un-called for.
> 
> Netbeans is a great IDE and the developers have done a tremendous job to
> provide a free product to the world over. I've tried using several over IDE's
> over the years and it is by far the only that satisfies all of my needs.
> Especially with the nbgit plugin. It uses less resources than any other java
> based IDE I have used that is this feature packed. 

Agreed.

> 
> Now down to wordwrap. Real programming does not need word wrap, plain and
> simple. 

That's not true.  I wouldn't have voted for this if I didn't need it.  And I need it for "real programming" in Ruby and Java.

> Every language has a way to wrap statements, expressions, strings, etc.

Yes, but that's inconvenient in many cases.  Perhaps you've never experienced this inconvenience.  That doesn't mean it doesn't exist.

This is particularly true with doc comments, by the way.

> The only time word wrap comes in handy at all is with HTML and even then in
> most cases you can wrap the html yourself 

But I shouldn't have to.  I prefer to write HTML without excessive physical line breaks.

> and even then, you shouldn't be
> hard-coding HTML these days.

Also not true.  No automated tool does as good a job as hand-coding.

> 
> Leaving extremely long horizontal statements in your code is discourteous to
> any other programmer that needs to read or modify your code. It is annoying and
> it makes it extremely difficult to read, __even__ when wrapped. Best coding
> practice is to wrap your code yourself with real line breaks. It's easier to
> read and understand if indented correctly. 

Ridiculous.  Yes, in most cases you shouldn't need long lines.  But there is *nothing* to be gained from splitting just for the sake of splitting.

Besides, you don't know what line length the other programmers who read your code will prefer.  That's why the editor should be able to wrap. 
> 
> I have been using Netbeans for a very long time now and never once found the
> "NEED" for word wrap. It is not essential. 

It is essential in any program that edits text.

> Regardless of what logic/programming
> decisions where made years ago that makes this feature difficult to implement
> without serious re-writes it is still what I use as my only IDE.

And it never will be my only IDE until it has word wrap.  You may not need that feature; I do.

> 
> This application is free and open source and thousands of people would like to
> keep it that way. Thank you Sun.

Yes, thank you Sun.  With all my complaints, I still think NetBeans is an excellent IDE.
Comment 61 chris4beta 2010-01-28 12:16:31 UTC
Ugh.

First off, bad-mouthing the developers is incredibly distasteful. Netbeans is a great IDE that also happens to be free of charge.

Second, I love reading the "real programmers don't need word wrap" argument along with their explanation of why long strings of text in your code make you a bad developer -  especially this last comment that "you shouldn't be hard-coding HTML these days".

A web developer is always going to have template/view pages that have _some_ hard-coded HTML in them - not every minutia of text is dynamically pulled from a DB. Maybe you're doing layout design work and have some Lorem Ipsum in there as placeholder text. Or, maybe you like keeping your indentation consistent with big tab spaces, and when you're nested 2-3 loops deep you're already halfway to the edge of the page when you need to echo a hard-coded message.

My point is, a supposed ubiquitous editor such as Netbeans needs to have word wrap, and taking over three years to begin implementing it is hard to understand. But, that doesn't give anyone the right to insult the people that work hard to give you something for nothing.

There are arguments for/against the necessity of word wrap, sure. All I can say is I'm happy to see they are finally working on it, and in my opinion it will make Netbeans a better IDE.
Comment 62 SebastianJu 2010-01-28 12:20:02 UTC
> Now down to wordwrap. Real programming does not need word wrap, plain and
> simple.

Thats nonsense.

Of course you can manually add linebreaks but whats the result? For example the azubi in my bureau always is working with fullscreen code. And he is breaking the code at the end of the line manually. Dont know why because he usese phped which has softwrap but he does. I dont work so and what do I have then? I need to scroll to see everything or have to rewrite every line of his code. Even with softwrap I have stupid lines where one line is full and second line always shows 10 signs or so. Thats stupid.
Others have different resolutions and at the end bringing in manual linebreaks makes a code less good to code. If you only work on the same pc with the same resolution and the same program you probably fine but thats not the case.
I dont like such manual wrapped code when I should change something in it. Softwrap is far better because it gives everyone the best view for the resolution and screenwidth he uses.
Comment 63 baffyofdaffy 2010-01-29 08:55:44 UTC
Hey look, perhaps we should quit arguing.

https://netbeans.org/bugzilla/show_bug.cgi?id=121357

This is the issue to be focusing on. After this comes word wrap (as is shown above "Depends on: 121357"
Comment 64 marnen 2010-01-29 09:16:06 UTC
(In reply to comment #63)
> Hey look, perhaps we should quit arguing.
> 
> https://netbeans.org/bugzilla/show_bug.cgi?id=121357
> 
> This is the issue to be focusing on. After this comes word wrap (as is shown
> above "Depends on: 121357"

What it depends on is frankly irrelevant to a user of the IDE.
Comment 65 yuri_ 2010-03-08 06:20:47 UTC
This is the most basic text editor functionality and is of utmost importance for php/html (but not limited to) developers.
Line breaks may cause html pages render differently and should often be avoided which makes a mile long lines of code. 
I have seen suggestion to implement word wrap subject to certain behaviour, eg maintaining the offset of the previous line.
I urge you to implement it in the quickest and easiest form asap so that the user does not have to use scrolling. 

Improving the behavior can wait till later due to this feature's importance.

Thank you for developing such a powerful otherwise product and please keep up the good work.
Comment 66 tarpatel 2010-03-09 15:14:18 UTC
i am a java developer and i would greatly appreciate window word wrapping at least.

i mainly work on a laptop and so word wrapping is a basic editor functionality that needs to happen regardless of what the programming snobs have said.

i agree that the good people that develop netbeans made a pretty huge oversight in getting this much much earlier. 

however they have made a great product otherwise and i want to thank them for what we get so far. I have been using Netbeans since 2003. i am sure there are faster, better, etc etc etc products out there but netbeans has served me well for 7 years+

i greatly anticipate the 6.9 beta with word wrapping.

thanks netbeans team.
Comment 67 Quality Engineering 2010-03-12 04:25:23 UTC
Integrated into 'main-golden', will be available in build *201003120200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/10eefd055421
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #89894: adding 'Line wrap' option to formatting options
Comment 68 nof8 2010-03-25 13:03:52 UTC
I've tested this new Line-wrap feature in NetBeans-dev-2010-03-25_12-23-45 -php

It works! Great.

But we are programmers and we need a little more flexibility.
For now it starts second and next parts of wrapped line at the leftmost column.
It ruins all indentation. I'd prefer an option to choose:
 - start other parts of wrapped line at leftmost column
 - start other parts of wrapped line one tab (or single indent) right to the column of the first part of wrapped line

and the second option should be default for most of programming languages.
Comment 69 Vitezslav Stejskal 2010-03-25 13:29:22 UTC
Not for 6.9, sorry. We will be very lucky to get the new view hierarchy stable enough for the release. I'd suggest to create a separate ENH request for any ideas/improvements that that anybody may have for line wrapping. Please make it depend on this issue. Thanks
Comment 70 tufan 2010-03-30 13:10:47 UTC
(In reply to comment #69)

please also note that internal diff tool apperantly has huge problems with line wrapping.
Comment 71 azizur 2010-04-14 21:37:40 UTC
I want this feature NOW. It far to late for NetBeans.

If this does not get implemented I am afraid I'd switch to other IDE eclipse is very much the candidate for replacement.
Comment 72 chris4beta 2010-04-14 21:42:46 UTC
@azizur

I believe you can have word wrap now if you install a nightly build. Otherwise, 6.9 will be out soon enough... Beta - 4/22, RC - 5/10, Final - 6/9.

By the way, thanks to Netbeans team for finally taking care of this!
Comment 73 Michel Graciano 2010-04-15 12:45:49 UTC
We are in phase of stabilization and any help to test NetBeans is really welcome. The line wrap feature will be turned off for Beta since it uses a new editor implementation which is really unstable for now but we are testing and helping developers to fix it. All you are welcome to join us [1] to make this stable for release. The developers are doing their best to make this available but if the editor won't be stable for release maybe we will see some feature just for next release.

Resgards and thank you for help
[1] http://wiki.netbeans.org/NetCAT
Comment 74 ericjs 2010-04-15 16:09:45 UTC
(In reply to comment #71)
> I want this feature NOW. It far to late for NetBeans.
> If this does not get implemented I am afraid I'd switch to other IDE eclipse is
> very much the candidate for replacement.

I hate to tell you, azizur, but Eclipse suffers from the same problem (see https://bugs.eclipse.org/bugs/show_bug.cgi?id=35779), however there doesn't seem to be anyone actively working on fixing it. (That being said I've gone back to working mainly in Eclipse for other reasons myself, though I keep both installed, prefer Ntbeans for some things, and keep an eye on the progress of both.)
Comment 75 slevin 2010-04-15 21:07:31 UTC
(In reply to comment #73)
> The developers are doing their best to make this available
> but if the editor won't be stable for release maybe we will see some feature
> just for next release.

Do you mean NB7.0 under "next release"?
Comment 76 Michel Graciano 2010-04-15 21:32:17 UTC
(In reply to comment #75)
> (In reply to comment #73)
> > The developers are doing their best to make this available
> > but if the editor won't be stable for release maybe we will see some feature
> > just for next release.
> 
> Do you mean NB7.0 under "next release"?

I mean 6.9.next, since I just don't know which version goes next, but probably it will be 7.0.
We need to release FCS with a stable editor so if some new feature makes the IDE unstable probably the FCS will have the release date changed or the feature removed. I really hope to help to stabilize it before the FCS and see all planned features working well.
Comment 77 chris4beta 2010-04-27 21:55:55 UTC
When you say line wrap is turned off in 6.9 beta, does that mean disabled by default, but we can turn it on? Or does it mean not available at all?

I'd upgrade to the beta if word wrap was there to test out, if not I'll just wait.
Comment 78 Michel Graciano 2010-04-27 22:45:18 UTC
(In reply to comment #77)
> When you say line wrap is turned off in 6.9 beta, does that mean disabled by
> default, but we can turn it on? Or does it mean not available at all?
> 
> I'd upgrade to the beta if word wrap was there to test out, if not I'll just
> wait.

This feature was removed from 6.9 and will be turned on again for 6.9.next and hopefully it will be stable for next release.
Comment 79 seena 2010-05-20 20:20:20 UTC
I just cannot believe netbeans does not have any word wrap function!!!
Even notepad has it!!!!
Comment 80 doomrider 2010-05-28 09:00:59 UTC
I voted to for this bug. It would be really great to have word wrap. It now is a bit of a pain in the ass, bud it doesn't change the fact it is a great piece of freeware! Go on like this!
Comment 81 NomikOS 2010-06-06 19:27:09 UTC
This is really cool!!! Thanks netbeans developers.
Now I got the perfect excuse to ask for a new super wide-screen monitor!
NomikOS.-
Comment 82 deemytch 2010-06-13 12:39:15 UTC
It would be very usefull not only for PHP or text, but also for sql long queries etc, eg. anywhere.
Comment 83 shunbul 2010-07-13 13:29:04 UTC
Line wrap should happen at the 80-character margin.  There should at least be an option to choose which margin to wrap (screen or margin).

It would also be nice to be able to disable the small arrow showing the soft line break.
Comment 84 700x23 2010-08-06 17:01:20 UTC
There is a whole crowd of PHP developers out there who will switch to NetBeans when word wrap becomes part of the IDE.  The lack of this feature is a show stopper for many potential users.

As many others have stated, EditPlus is one of the most friendly PHP editors to work in with the automatic word wrap with indentation and line numbers, highlighting and column markers.

Adding this feature will open NetBeans to a wider audience and will be well worth the effort.
Comment 85 glemigh 2010-08-06 17:35:27 UTC
Not that it matters, but for the record, I'm a PHP developer, and I've been watching this bug for 2 years.

When Netbeans gets this feature, I'll probably switch to it, but until then, I'm not going to even install it again.

I'm sure others feel the same, and I'm positive that Netbeans is a fantastic product, but without wordwrap, it's not for me.

Here's to looking forward.

cheers.
Comment 86 mikestopcontinues 2010-08-06 18:00:48 UTC
The same goes for me and my girlfriend. We've both tried it and we're both eagerly awaiting word wrap before we install NetBeans again.

And it doesn't even need to be awesome word wrap that auto-indents the following lines as well (though we wish it was). Just plain show-it-on-the-next-line would be enough for us to start using this product. Everything else about NetBeans seems ace.

Didn't you realize you'd be the best IDE if not for this simple oversight?
Comment 87 ooscarr 2010-08-09 14:37:47 UTC
They say word wrap will be implemented on Netbeans 6.10 http://wiki.netbeans.org/NetBeans_610#Additional_Themes
Comment 88 Michel Graciano 2010-08-09 17:03:12 UTC
Well, if you need this feature it is time to help to test this. Take a look at this blog [1] and help the team to test this feature to make possible stabilize this for next release.

Best regards
[1] http://blogs.sun.com/netbeansphp/entry/line_wrapping_help_us
Comment 89 NomikOS 2010-08-10 01:05:40 UTC
Yes, editplus is excellent for windows machines, not my case anymore...
I am using the last build to test as Michel Graciano suggest and all goes OK until now!
Comment 90 John Jullion-ceccarelli 2010-08-10 05:58:16 UTC
We tried to get this into 6.9 but it had some stability problems so we had to let it settle a bit more. We're turning it on in the trunk builds and if more stability problems don't raise their heads, it will be in 6.10.
Comment 91 jasim_ab 2010-08-11 20:25:31 UTC
NetBeans is great for web development and has fantastic HTML, CSS, JavaScript  support.

But lack of word wrap forces me to manually terminate long text content in normal HTML.  

Waiting eagerly for the feature.
Comment 92 Miloslav Metelka 2010-08-17 09:10:46 UTC
By committing issue #189557 the new view hierarchy supporting line-wrap is now turned on:

Integrated into 'main-golden', will be available in build *201008170001* on
http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/ce3fdc2a824f

The line wrapping mode can be controlled by Tools->Options->Editor->Formatting->Line Wrap option.
Also the non-printable characters visibility can be set by menu View->Show Non-printable Characters.

If you encounter any serious error you may switch back to old view hierarchy by adding the following into netbeans.conf:

-J-Dorg.netbeans.editor.linewrap=false

We mark the entered issues related to line wrap by using "linewrap" in status whiteboard. Currently we track the following open issues:
http://netbeans.org/bugzilla/buglist.cgi?product=editor&bug_status=NEW&bug_status=STARTED&bug_status=REOPENED&status_whiteboard=linewrap&status_whiteboard_type=substring&order=bugs.priority%2Cbugs.bug_id

At the moment I work on resolving of the following issues: issue #183219, issue #189554, issue #189214.

Thank you in advance for testing of this feature.
Comment 93 sunburned 2010-08-18 21:15:37 UTC
Can't wait to try it, but unfortunately the latest nightly build (netbeans-dev-201008180001) -- which I understand is the only one with word-wrap -- will not compile .jsp pages.

It has something to do with 
org.netbeans.modules.web.project.WebActionProvider.areIncludesModified

and not the word-wrapping.  See bug 189633
http://netbeans.org/bugzilla/show_bug.cgi?id=189633

Until this gets resolved, I'll have to stick to the old netbeans, which means I use something else when working with web pages.  But the wait ALMOST OVER!!!

Thanks for your work on this issue, Miloslav!
Comment 94 kewlashu 2010-12-16 06:29:05 UTC
Thanks to developers and community. This feature has made it easy for a large group of beginner and intermediates to stick with netbeans.
Comment 95 magickgardener 2013-03-07 10:31:52 UTC
Dead bugs, my favorite. I'm taking a few minutes to congratulate the people who implemented the feature. I'm stuck with version 6.9 for the moment but managed to activate the option. In general I found your comments quite interesting, useful and even inspiring.

The battle between Eclipse and NetBeans IDE is also entertaining to follow. The first has been wrap-less for 10 years now but apparently someone has finally found time to work on it. I'm sure that it's not as easy as it sounds considering the insane number of dependencies between components.

I would be damn proud if I had developed the Line Wrap feature. It's so cool ! Last but not least considering the bug's popularity I'm surprised only one user had posted so far to thank everyone.

7 years to complete, available in version 7.0… I see a design pattern !


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo