Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 34719 - source editor needs line wrap in addition to hard returns
source editor needs line wrap in addition to hard returns
Status: RESOLVED DUPLICATE of bug 89894
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
3.x
PC Windows XP
: P3 with 3 votes (vote)
: TBD
Assigned To: issues@editor
issues@editor
:
Depends on:
Blocks: 89483
  Show dependency treegraph
 
Reported: 2003-07-01 18:58 UTC by davidpaules
Modified: 2008-06-06 11:06 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description davidpaules 2003-07-01 18:58:05 UTC
Take a look at how Project Builder on Mac OS X implements 
line wrapping. Depending on the size of your text editor's 
screen real estate, the code within would wrap nicely so 
that ALL of the code was visible in that window. This way, 
javadoc comments can be written so that they are always 
visible with the code. Long method calls and deeply nested 
code is visible within the same space without requiring 
side-scrolling IN ADDITION TO vertical scrolling. The build 
tools on Mac OS X even performed smart indenting of the 
soft-wrapped lines, so that deeply nested method calls did 
not simply start at the leftmost column when wrapped, 
preserving the code format somewhat. That could be an 
option for the user to enable (smart indenting) just as 
line-wrapping could be an option. I think these options 
make editing, reading, and understanding code much more 
useful given the numerous windows developers already must 
manipulate.
Comment 1 Miloslav Metelka 2003-07-16 13:24:48 UTC
The new editor's view-based displaying system that I'm working on will
certainly support line-wrapping. Regarding smart-indenting of the
wrapped lines I can't tell when will we support that feature.
Comment 2 Roman Strobl 2005-01-21 14:58:57 UTC
Changed subcomponent to formatting.
Comment 3 Marek Fukala 2006-11-27 14:53:24 UTC
Any plans for this one? What about 6.0? It is quite useful... 
Comment 4 Vitezslav Stejskal 2006-11-27 20:06:18 UTC
Maybe, but it's not a priority. Have you got any spare cycles? ;-)
Comment 5 Vitezslav Stejskal 2008-06-06 11:06:58 UTC

*** This issue has been marked as a duplicate of 89894 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo