Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 42735 - Avoid version "seesawing" in GeneratedFilesHelper
Avoid version "seesawing" in GeneratedFilesHelper
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Ant Project
4.x
All All
: P2 (vote)
: 6.x
Assigned To: Jesse Glick
issues@projects
:
: 64058 72243 132255 (view as bug list)
Depends on:
Blocks: 41535 87596
  Show dependency treegraph
 
Reported: 2004-05-03 19:48 UTC by Jesse Glick
Modified: 2009-02-19 20:14 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2004-05-03 19:48:15 UTC
As needed:

- passing parameters to the stylesheet
(automatically affect CRC32 hash)

- passing an "extra hash" to represent any
included or imported or loaded resources

- include an explicit ordered version number to
prevent stylesheet "seesawing"

- ability to generate content w/o XSLT
Comment 1 Jesse Glick 2004-06-15 13:02:57 UTC
Not apparently needed for D. Should be considered for E.
Comment 2 Jesse Glick 2005-09-12 23:02:44 UTC
The third in particular is desirable.
Comment 3 Jesse Glick 2005-09-12 23:02:58 UTC
*** Issue 64058 has been marked as a duplicate of this issue. ***
Comment 4 Jesse Glick 2006-02-03 22:22:33 UTC
*** Issue 72243 has been marked as a duplicate of this issue. ***
Comment 5 Milan Kuchtiak 2006-02-28 09:26:24 UTC
We also need to add an extra parameter to transformer object that represents an
additional xml source.

e.g.
transformer.setParameter("jax_ws","file:/home/user/WebProject5/nbproject/jax-ws.xml");

Than we also need to provide the CRC calculation for this file.

Currently we use the custom copy of GeneratedFilesHelper class :
http://websvc.netbeans.org/source/browse/websvc/websvcapi/src/org/netbeans/modules/websvc/jaxws/spi/Attic/GeneratedFilesHelper.java?rev=1.1.2.1&only_with_tag=release55&content-type=text/vnd.viewcvs-markup
Comment 6 Milan Kuchtiak 2006-08-08 14:42:33 UTC
Generally, it is useful to generate build-impl not just from one xml source
(project.xml). Multiple project types can create multiple configuration files
for any reason.

There is another advantage: project.xml configuration data don't need to be
updated from release to release.
Comment 7 Jesse Glick 2008-04-09 20:05:18 UTC
*** Issue 132255 has been marked as a duplicate of this issue. ***
Comment 8 Jesse Glick 2009-01-06 14:54:23 UTC
I am working on #3 as that seems to be the major issue in practice. If other issues are still needed, please file them
separately.
Comment 9 Jesse Glick 2009-01-06 17:10:36 UTC
core-main #9f31b509242e
Comment 10 Quality Engineering 2009-01-07 05:37:06 UTC
Integrated into 'main-golden', will be available in build *200901070201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/9f31b509242e
User: Jesse Glick <jglick@netbeans.org>
Log: #42735: prevent "seesaw" effect on metadata from opening a project alternately in two different IDE versions.
As of now, the IDE will not refresh build scripts created with newer versions of stylesheets.
After a refresh, genfiles.properties will use @1.2.3.4 in *.stylesheet.crc32 to record the module spec version.
(6.5 and earlier IDEs will still overwrite scripts with their old stylesheets.)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo