Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 64058 - Frequent non-obvious conflicts in genfiles.properties
Frequent non-obvious conflicts in genfiles.properties
Status: RESOLVED DUPLICATE of bug 42735
Product: projects
Classification: Unclassified
Component: Ant Project
5.x
All All
: P3 (vote)
: 5.x
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-11 18:59 UTC by _ tboudreau
Modified: 2005-09-12 23:02 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2005-09-11 18:59:05 UTC
I frequently work on the same project on two different machines.  Very often I
get a message that there are conflicts, but I can see nothing in the projects
tab that has a conflict.

It turns out it is almost always genfiles.properties and friends in nbproject/.

I'm not sure what the right resolution for this is, but it seems like pretty
confusing behavior, especially since there is no obvious way for a user to tell
how they should resolve it - let the local revisions clobber the remote ones or
vice versa.

I *think* the right behavior is to always assume the local version is correct; 
the user can still screw this up if they, say, choose to include
genfiles.properties but exclude build-impl.xml when they commit.  At any rate,
some special handling seems pretty desirable here, as it's going to be very
non-obvious to the user what they should do, and the problem comes up almost
every time I switch which computer I'm working on the project on.
Comment 1 Maros Sandor 2005-09-12 08:18:20 UTC
This is not a bug in CVS. If project system modifies its metadata and there are
frequent conflicts in them I can do nothing about it. Reassigning.
Comment 2 Jesse Glick 2005-09-12 23:02:59 UTC
There should not be spurious changes to genfiles.properties; only if you make a
real change to project.xml, or you are using a new stylesheet. The former case I
cannot really do anything about without some API from the VCS module. The latter
case is mentioned in issue #42735.

Recent dev builds have problems with Mustang; see issue #62006.

*** This issue has been marked as a duplicate of 42735 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo