Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132255 - build-impl.xml changes between NB 6.0 and 6.1
build-impl.xml changes between NB 6.0 and 6.1
Status: RESOLVED DUPLICATE of bug 42735
Product: projects
Classification: Unclassified
Component: Ant Project
6.x
All All
: P2 (vote)
: TBD
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 20:16 UTC by chrispcampbell
Modified: 2008-04-09 20:05 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chrispcampbell 2008-04-07 20:16:21 UTC
We have a bunch of projects based on NB 6.0 (see https://scenegraph.dev.java.net).  When I open those projects in NB 6.1
(tried 6.1 200804060002 nightly build), build-impl.xml is changed just slightly:

=============
--- trunk/Reprise/nbproject/build-impl.xml	(original)
+++ trunk/Reprise/nbproject/build-impl.xml	2008-04-07 18:53:15+0000
@@ -19,7 +19,7 @@
   - cleanup
 
         -->
-<project xmlns:j2seproject1="http://www.netbeans.org/ns/j2se-project/1"
xmlns:j2seproject2="http://www.netbeans.org/ns/j2se-project/2"
xmlns:j2seproject3="http://www.netbeans.org/ns/j2se-project/3"
xmlns:jaxrpc="http://www.netbeans.org/ns/j2se-project/jax-rpc" basedir=".." default="default" name="Reprise-impl">
+<project xmlns:j2seproject1="http://www.netbeans.org/ns/j2se-project/1"
xmlns:j2seproject3="http://www.netbeans.org/ns/j2se-project/3"
xmlns:jaxrpc="http://www.netbeans.org/ns/j2se-project/jax-rpc" basedir=".." default="default" name="Reprise-impl">
     <target depends="test,jar,javadoc" description="Build and test whole project." name="default"/>
     <!-- 
                 ======================
@@ -235,7 +235,9 @@
             <attribute default="${build.classes.dir}" name="dir"/>
             <sequential>
                 <nbjpdareload>
-                    <fileset dir="@{dir}" includes="${fix.includes}*.class"/>
+                    <fileset dir="@{dir}" includes="${fix.classes}">
+                        <include name="${fix.includes}*.class"/>
+                    </fileset>
                 </nbjpdareload>
             </sequential>
         </macrodef>
===========

The changes seem harmless, so I committed them to SVN.  But if I then reopen the project in NB 6.0, that version of the
IDE tries to revert the file back to the way it was, so SVN shows changes in these files.  Since we have a mixture of
people on our team, some using 6.0, some trying out 6.1, this becomes a big nuisance, because it will show these files
being changed in SVN, and you have to do "Exclude from commit" to avoid changing them constantly.

Is there a way to stabilize these files from release to release?
Comment 1 Peter Pis 2008-04-09 06:56:18 UTC
Reassigning to "ant" for evaluation.
Comment 2 Jesse Glick 2008-04-09 20:05:26 UTC
No, there is no way currently to prevent the 6.0 IDE from installing old stylesheets. See point #2 in #42735, already filed.

*** This issue has been marked as a duplicate of 42735 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo