Bug 211406 - Views and Palettes keeps scrolling itself to the drag position after DnD
Views and Palettes keeps scrolling itself to the drag position after DnD
Status: REOPENED
Product: platform
Classification: Unclassified
Component: JDK Problems
7.1.2
PC Mac OS X
: P2 with 1 vote (vote)
: 7.2
Assigned To: Stanislav Aubrecht
issues@platform
jdk_bug_7171812-fixed-7u10b08
: JDK_1.7, JDK_SPECIFIC, RELNOTE
: 218510 218558 221610 240843 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 15:50 UTC by Stepan Zebra
Modified: 2014-04-15 09:31 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stepan Zebra 2012-04-18 15:50:03 UTC
Product Version: NetBeans IDE 7.1.2 (Build 201204101705)
Java: 1.7.0_04; Java HotSpot(TM) 64-Bit Server VM 23.0-b21
System: Mac OS X version 10.7.3 running on x86_64; US-ASCII; en_US (nb)

After dragging and dropping something from Projects or Files Views or Palette in GUI designers, when you scroll the View or Palette up/down, it keeps scrolling itself back to the drag position, making it impossible to select nodes/components not visible without scrolling to them.
Comment 1 Marian Mirilovic 2012-04-19 15:31:37 UTC
Release Note for NB 7.1.2 :
Broken Palette after DnD to GUI designer.  Workaround : restart of the IDE.
Comment 2 Tomas Danek 2012-04-19 20:38:31 UTC
I'm not sure if this is exactly the same, but I've seen this also in Projects/Files view - behavior that I'm not able to scroll down/up..scrolling gets "settled" in the middle of the window.
Comment 3 Antonin Nebuzelsky 2012-05-04 11:50:35 UTC
The palette case above is reproducible according to Tomas.

Stando, try debugging it and get details about the cause. With the details it can be filed to Java team, or workarounded probably.
Comment 4 Stanislav Aubrecht 2012-05-07 18:36:44 UTC
The scrolling is caused by java.awt.dnd.DropTarget.DropTargetAutoScroller. That class is responsible for scrolling a tree/list when something is dragged over it. For some reason the timer isn't reset when the item is dropped or the drag is aborted. Seems like JDK bug since it works fine in other JDK versions.
Comment 5 jportway 2012-05-23 11:29:24 UTC
I'm getting the same problem with the Projects view when running under  Java:1.6.0_31; Java HotSpot(TM) 64-Bit Server VM 20.6-b01-415

It pretty much makes Netbeans unusably irritating to work with.
Comment 6 Antonin Nebuzelsky 2012-05-25 14:26:49 UTC
JDK bug filed.

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7171812
Comment 7 Antonin Nebuzelsky 2012-09-10 10:22:04 UTC
Fix should appear in upcoming b08 of 7u10. Please verify.
Comment 8 Stanislav Aubrecht 2012-09-19 15:06:19 UTC
*** Bug 218558 has been marked as a duplicate of this bug. ***
Comment 9 Stanislav Aubrecht 2012-09-19 15:06:55 UTC
*** Bug 218510 has been marked as a duplicate of this bug. ***
Comment 10 Stepan Zebra 2012-10-04 14:02:16 UTC
verified on 1.7.0_10-ea-b09
Comment 11 Stanislav Aubrecht 2012-11-09 18:51:54 UTC
*** Bug 221610 has been marked as a duplicate of this bug. ***
Comment 12 pbw 2013-10-23 05:37:15 UTC
Can you revive the java bug?  This is hitting me again.

pbw$ java -version
java version "1.7.0_40"
Java(TM) SE Runtime Environment (build 1.7.0_40-b43)
Java HotSpot(TM) 64-Bit Server VM (build 24.0-b56, mixed mode)
pbw$ uname -a
Darwin lydia.local 12.5.0 Darwin Kernel Version 12.5.0: Sun Sep 29 13:33:47 PDT 2013; root:xnu-2050.48.12~1/RELEASE_X86_64 x86_64

Product Version: NetBeans IDE 7.4 (Build 201310111528)
Java: 1.7.0_40; Java HotSpot(TM) 64-Bit Server VM 24.0-b56
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b43
System: Mac OS X version 10.8.5 running on x86_64; UTF-8; en_US (nb)
User directory: /Users/pbw/Library/Application Support/NetBeans/7.4
Cache directory: /Users/pbw/Library/Caches/NetBeans/7.4
Comment 13 Stanislav Aubrecht 2014-01-27 14:40:18 UTC
*** Bug 240843 has been marked as a duplicate of this bug. ***
Comment 14 simon_vg 2014-02-24 10:13:46 UTC
This is particularly bad in this runtime environment:

Product Version: NetBeans IDE 8.0 Beta (Build 201401141042)
Java: 1.7.0_51; Java HotSpot(TM) 64-Bit Server VM 24.51-b03
Runtime: Java(TM) SE Runtime Environment 1.7.0_51-b13
System: Mac OS X version 10.9.1 running on x86_64; UTF-8; en_US (nb)

IT happens to me several times a day
Comment 15 simon_vg 2014-03-07 11:30:54 UTC
Still shocking on 

Product Version = NetBeans IDE 8.0 RC1 (Build 201402242200)
Operating System = Mac OS X version 10.9.1 running on x86_64
Java; VM; Vendor = 1.7.0_51
Runtime = Java HotSpot(TM) 64-Bit Server VM 24.51-b03
Comment 16 simon_vg 2014-03-27 15:19:45 UTC
I don't know if the VERIFIED WONTFIX status means nothing more is to be done of this but it actually appears to be worse with the full IDE 8.0 release. The project window stills scrolls uncontrollably and, if reduced to less than about a third of the total visible nodes, is unable to resolve so flickers constantly at different heights. 

Product Version: NetBeans IDE 8.0 (Build 201403101706)
Java: 1.7.0_51; Java HotSpot(TM) 64-Bit Server VM 24.51-b03
Runtime: Java(TM) SE Runtime Environment 1.7.0_51-b13
System: Mac OS X version 10.9.2 running on x86_64; UTF-8; en_US (nb)
User directory: /Users/simon/Library/Application Support/NetBeans/8.0
Cache directory: /Users/simon/Library/Caches/NetBeans/8.0
Comment 17 Stanislav Aubrecht 2014-03-28 14:25:29 UTC
Please reopen if reproducible with JDK 1.8

The original bug was fixed in JDK 8 and then backported back to JDK 7, perhaps the backport was messed up.
Comment 18 simon_vg 2014-04-10 09:15:14 UTC
You appear to be right, thanks. Upgrading Java to JDK 8 seems to have resolved the issue.
Comment 19 simon_vg 2014-04-11 15:56:06 UTC
Nope, still scrolls. It's much better - it took 1.5 days to reappear but I now have to restart the browser again.

Product Version: NetBeans IDE 8.0 (Build 201403101706)
Java: 1.8.0_20-ea; Java HotSpot(TM) 64-Bit Server VM 25.20-b05
Runtime: Java(TM) SE Runtime Environment 1.8.0_20-ea-b05
System: Mac OS X version 10.9.2 running on x86_64; UTF-8; en_US (nb)
User directory: /Users/simon/Library/Application Support/NetBeans/8.0
Cache directory: /Users/simon/Library/Caches/NetBeans/8.0
Comment 20 simon_vg 2014-04-15 09:31:13 UTC
In fact, same setup. I have now had the same issue after dragging and dropping in the main text editor window after which the vertical scroll flickers several times a second rendering the program entirely unusable.
Restating the IDE fixes.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo