Bug 68083 - [50cat] New empty toolbar isn't automatically deleted when it's added by advanced options.
[50cat] New empty toolbar isn't automatically deleted when it's added by adva...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
5.x
All All
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
: UI
Depends on: 42146
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-04 10:48 UTC by wulgar
Modified: 2009-02-19 22:53 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wulgar 2005-11-04 10:48:32 UTC
[ BUILD # : 200511011936 ]
[ JDK VERSION : 1.5.0_05 ]

When I choose Customize Toolbars, and click New Toolbar nothing is change. There is no exception also.
Comment 1 Zdenek Konecny 2005-11-04 11:08:27 UTC
Not reproducible in Build 200511031900. You mean, you click on "New Toolbar..."
button and nothing happen or you enter a name of new toolbar and nothing happen?
After entering a name of new toolbar, the new separator behind last toolbar
should be showed in toolbar area and the separator will stay here until you
closed the "Toolbar Customizer", because if you won't add a new action from
Toolbar Customizer, new toolbar would be automatically deleted.  
Comment 2 wulgar 2005-11-04 11:15:40 UTC
Why I cannot add new EMPTY tollbar?

In my case I want add new toolbar, and next add to this one shortcuts to ant task.
Comment 3 wulgar 2005-11-04 11:19:05 UTC
There is inconsistency here: I can add ampty toolbar by Tools->Options
Comment 4 Zdenek Konecny 2005-11-04 11:35:53 UTC
You are right. I've changed name of this issue. 
Comment 5 wulgar 2005-11-04 11:38:05 UTC
But my question is remain: why I cannot add EMPTY toolbar
Comment 6 Zdenek Konecny 2005-11-04 12:17:20 UTC
Sorry, I missed this comment. Automatically deleting of empty toolbars has been
implemented, because it provides a way to delete a toolbar without using of
advanced option dialog. So it's reason why add empty toolbar isn't possible.  
Comment 7 wulgar 2005-11-04 12:21:12 UTC
Yes. OK.

What about my scenario?

Now, I must add new Toolbar, add to this "something", close "customize
toolbars". Then add my ant target shortcut, open "customize toolbars" and remove
this "something". 

Blah... I dont wont do this that way.
Comment 8 Stanislav Aubrecht 2005-11-04 13:51:06 UTC
any comment from HIE?
Comment 9 Stanislav Aubrecht 2005-11-04 13:55:19 UTC
a possible workaround:

- add ant target to an existing toolbar
- open toolbar customizer
- create new toolbar
- drag and drop the ant target button to the new toolbar

(you don't have to open the toolbar customizer twice ;-))
Comment 10 jrojcek 2005-11-08 13:34:54 UTC
Yes, the Customize Toolbar dialog is non-modal. You can add your ant target into new toolbar without 
closing the dialog. I agree it's not very intuitive, though.

I suggest to change this to enhancement. We can solve it when we will work on DnD of toolbars. Then we 
don't have to remove toolbars automatically, but using DnD the same way as we remove toolbar buttons.
Comment 11 Stanislav Aubrecht 2005-11-09 10:54:41 UTC
changing issue type to 'enhancement' as suggested.
Comment 12 Stanislav Aubrecht 2008-11-28 11:35:43 UTC
fixed

4f828389f2be


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo