Bug 26965 - Crash: ".../wizard.inf (104)" when there's jre/lib/endorsed/sax.jar
Crash: ".../wizard.inf (104)" when there's jre/lib/endorsed/sax.jar
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: Code
3.x
All All
: P3 (vote)
: 6.x
Assigned To: dlipin
issues@installer
: RELNOTE
: 39705 39878 40255 42390 45990 52547 52875 66305 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-02 17:27 UTC by Martin Schovanek
Modified: 2007-08-21 15:17 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
log.txt (12.03 KB, text/plain)
2002-09-02 17:28 UTC, Martin Schovanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schovanek 2002-09-02 17:27:17 UTC
[W2k, jdk1.4.1-b20,
NetBeansIDE-release34-200208222340-win32.exe]

Steps to reproduce:
-------------------
1) download java_xml_pack-summer02_01.zip from
http://java.sun.com/xml/downloads/javaxmlpack.html
2) unpack it and copy
'java_xml_pack-summer02_01\jaxp-1.2_01\sax.jar'
into 'jre\lib\endorsed' directory
3) run the installer (with "-is:log log.txt" option)

Installer find JVM and exits with message:
"The wizard cannot continue because of the
following error: could not load wizard specified
in /wizard.inf (104)" see log.txt.

It looks like problem at "binary part" of the
installer. Instalation by using the setup.jar
works fine.
Comment 1 Martin Schovanek 2002-09-02 17:28:08 UTC
Created attachment 7279 [details]
log.txt
Comment 2 Richard Gregor 2003-05-15 08:22:50 UTC
Scheduled for 4.0
Comment 3 jonrichards 2004-02-08 21:44:08 UTC
*** Issue 39705 has been marked as a duplicate of this issue. ***
Comment 4 zikmund 2004-02-10 13:09:07 UTC
*** Issue 39878 has been marked as a duplicate of this issue. ***
Comment 5 George Hernandez 2004-02-24 01:03:13 UTC
I've talked to install shield about this problem. Since the problem
happens when files installed by the user, in the form of additions to
the jre/lib/endorsed directory, are conflicting with their parser,
they recommend removing the installed files. In other words, they
won't be fixing this.
Comment 6 George Hernandez 2004-02-25 16:46:53 UTC
*** Issue 40255 has been marked as a duplicate of this issue. ***
Comment 7 zikmund 2004-04-23 14:14:58 UTC
Workaround:
Temporarily remove "jre/lib/endorsed/sax.jar" for the installation.
Comment 8 zikmund 2004-04-23 14:16:04 UTC
*** Issue 42390 has been marked as a duplicate of this issue. ***
Comment 9 zikmund 2004-07-12 09:09:24 UTC
*** Issue 45990 has been marked as a duplicate of this issue. ***
Comment 10 Jan Chalupa 2004-08-24 11:01:37 UTC
Still occurs with the NB 4.0 beta 1 installer. Please release note it.
Comment 11 mslama 2004-12-17 12:52:24 UTC
*** Issue 52547 has been marked as a duplicate of this issue. ***
Comment 12 mslama 2005-01-05 09:21:03 UTC
*** Issue 52875 has been marked as a duplicate of this issue. ***
Comment 13 zikmund 2005-01-17 09:05:05 UTC
Reproducible on Windows & Solaris, JDK 1.4.2 & 1.5.0,  NB 4.1.
Comment 14 gsimmons 2005-01-25 14:16:56 UTC
This is reproducible on Solaris x86, NB 4.0, attempted with both JDK
1.5.0_01 and J2SDK 1.4.2_06. In my case I get the number "(106)" in
the message after "/wizard.inf" (instead of "(104)"). Furthermore, the
suggested workaround does *not* work, because there is no sax.jar, nor
even a subdirectory "endorsed" under jre/lib, in either JDK
installation.  A call to Unix "find" for the file "sax.jar" yields no
results in either JDK directory.

Presently I am unable to install Netbeans on my system. One of the
commenters wrote, "Instalation by using the setup.jar works fine."
What is this "Installation by using the setup.jar"?
Comment 15 Jan Chalupa 2005-01-25 14:57:05 UTC
gsimmons: the bug you're experiencing is different from this one. See
issue #48633. The bug description includes a workaround.
Comment 16 silalpha 2005-03-23 14:12:58 UTC
I encountered the ".../wizard.inf (104)" problem on a fresh install of WinXP SP2
when installing netbeans-4_1-beta-windows.exe after installing
jdk-1_5_0_02-windows-i586-p.exe .

The problem was caused by having a special character "!" in the windows
username. Renaming the only changed the visible logon name, and not the actual
username, so this didn't help.
I logged on as administrator, and got past the error in the netbeans installer.
I created a new user account with a plain name, and could also install netbeans
from this new account.
Before I fixed this error I also tried to install Poseidon for UML 3.0, and
encountered the same ".../wizard.inf (104)" problem. After fixing the problem
this also installed fine.
Comment 17 mslama 2005-10-19 08:03:20 UTC
*** Issue 66305 has been marked as a duplicate of this issue. ***
Comment 18 kyledr 2006-01-30 02:51:03 UTC
A "!" in my username caused this error for me as well.  I would like to confirm
that the steps silalpha layed out are correct.  Re-naming will not work: it must
be an account that was originally created with no special characters.  I don't
know how to define "special" in this case, as "!" is the only one encountered so
far.
Comment 19 waptir 2006-02-11 01:01:55 UTC
Executing launch script command: "D:\Program
Files\Java\jdk1.5.0_06/bin\java.exe" -cp
"";"C:\DOCUME~1\ACCFOR~1\LOCALS~1\Temp\LRE72.tmp\setup.jar";""
-Dtemp.dir="C:\DOCUME~1\ACCFOR~1\LOCALS~1\Temp" -Dis.jvm.home="D:\Program
Files\Java\jdk1.5.0_06" -Dsun.java2d.d3d=false -Dis.jvm.temp="0"
-Dis.media.home="C:\DOCUME~1\ACCFOR~1\LOCALS~1\Temp\LRE72.tmp\setup.jar"
-Dis.launcher.file="D:\downloads\firedowns\netbeans-5_0-windows.exe"
-Dis.jvm.file="C:\DOCUME~1\ACCFOR~1\LOCALS~1\Temp\LRE71.tmp"
-Dis.external.home="D:\downloads\firedowns"   -Xms64m -Xmx96m  run  in working
directory D:\downloads\firedowns
Output from the launch script execution
StdOut:

ErrOut:
The wizard cannot continue because of the following error: could not load wizard
specified in /wizard.inf (104)

WARNING: could not delete temporary file C:\DOCUME~1\ACCFOR~1\LOCALS~1\Temp\ismp004

WARNING: could not delete temporary file
C:\DOCUME~1\ACCFOR~1\LOCALS~1\Temp\ismp004\5017461

WARNING: could not delete temporary file
C:\DOCUME~1\ACCFOR~1\LOCALS~1\Temp\ismp004\5569928


here is the log file my acc name is "ACCFORJAVA" (no special chars) and also get
error in installation.
"D:\Program Files\Java\jdk1.5.0_06/bin\java.exe" here the slash is not back
slash i dont know it difference or not.
Comment 20 mrsea 2006-03-13 21:56:00 UTC
   I have same problem an a Windows 2000 + SP4 machine with default Turkish 
Locale. But after this error message I changed my default locale to English 
(US) then problem solved.

Also I could not find any sax.jar under my JRE 1.5.06 folder.
Comment 21 facimus 2007-06-11 21:50:20 UTC
I had no sax.jar on my PC , The only problem was the regional settings. I had 
TURKISH as the default input languge when the installation failed. After 
changing default input language to ENGLISH and rebooting the setup started 
normally and product intallation completed sucessfully. I think this is the 
general problem of java installers on windows platform having different 
default language settings other than ENGLISH.
Comment 22 mslama 2007-08-21 14:28:22 UTC
New installer engine does not show this behavior. Dmitry please can you verify this?
Comment 23 dlipin 2007-08-21 15:02:03 UTC
Marek,

I`ve put sax.jar to jre/lib/endorsed/ directory of JDK and had no problems while installation of NetBeans 6.0.

Dmitry
Comment 24 mslama 2007-08-21 15:17:00 UTC
Ok. closing as FIXED.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo