Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 236101 - NetBeans IDE becomes unresponsive
NetBeans IDE becomes unresponsive
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
7.4
Macintosh (x86) Mac OS X
: P1 with 3 votes (vote)
: TBD
Assigned To: Antonin Nebuzelsky
issues@platform
jdk_bug_8025588
:
: 236339 236361 236639 236786 236842 237148 237480 237483 238195 238483 238906 239067 239904 240004 240335 242027 242737 243304 243365 243779 244829 245239 245285 245953 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 10:41 UTC by ionuion
Modified: 2019-05-30 15:38 UTC (History)
29 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
log, thread dump, mac os process sample (37.67 KB, application/zip)
2013-09-18 10:41 UTC, ionuion
Details
log file for the development version of the ide (IDE dead, blocked, unresponsive) (236.20 KB, text/plain)
2013-09-19 18:15 UTC, ionuion
Details
logs taken after NetBeans died (became unresponsive) (47.29 KB, application/zip)
2013-09-25 09:38 UTC, ionuion
Details
log and thread dump (13.72 KB, application/zip)
2013-10-24 07:50 UTC, ionuion
Details
Output from Nb kill (222.47 KB, text/plain)
2014-02-19 00:06 UTC, rweaver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ionuion 2013-09-18 10:41:57 UTC
Created attachment 140205 [details]
log, thread dump, mac os process sample

Environment:

Product Version: NetBeans IDE 7.3.1 (Build 201306052037)
Java: 1.7.0_40; Java HotSpot(TM) 64-Bit Server VM 24.0-b56
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b43
System: Mac OS X version 10.7.5 running on x86_64; UTF-8; en_US (nb)
User directory: /Users/ionuion/Library/Application Support/NetBeans/7.3.1
Cache directory: /Users/ionuion/Library/Caches/NetBeans/7.3.1

Netbeans 7.3.1 blocks several times a day (as of now the 6th time today) and each time I lose my changes (both file contents as well as open files in the editor)

None of the threads seem to be blocked. The program continues to use CPU, however not 100% like other user report in other bugs.

Attaching:
- messages.log
- thread dump
- process sample taken with Mac OS Activity monitor

Thank you
Comment 1 Tomas Hurka 2013-09-19 07:00:42 UTC
This looks like duplicate of issue #235997.
Comment 2 Marian Mirilovic 2013-09-19 11:48:33 UTC
Could you please download latest 7.4 build available at 
http://bits.netbeans.org/7.4/daily/wdsjn742/2013-09-16_22-01-38/
and reopen if you are still able to reproduce ? Thanks in advance.
Comment 3 ionuion 2013-09-19 12:19:40 UTC
(In reply to Marian Mirilovic from comment #2)
> Could you please download latest 7.4 build available at 
> http://bits.netbeans.org/7.4/daily/wdsjn742/2013-09-16_22-01-38/
> and reopen if you are still able to reproduce ? Thanks in advance.

Marian,

I assume there may be many reason for the IDE becoming unresponsive. The latest version does block, but there may be other reasons. Should I reopen this issue nonetheless?

Could you guys find out what the cause of this was based on the attached logs? Can you tell me how I can find that myself for better future reports?
Comment 4 Tomas Hurka 2013-09-19 12:56:06 UTC
(In reply to ionuion from comment #3)
> (In reply to Marian Mirilovic from comment #2)
> > Could you please download latest 7.4 build available at 
> > http://bits.netbeans.org/7.4/daily/wdsjn742/2013-09-16_22-01-38/
> > and reopen if you are still able to reproduce ? Thanks in advance.
> 
> Marian,
> 
> I assume there may be many reason for the IDE becoming unresponsive. The
> latest version does block, but there may be other reasons. Should I reopen
> this issue nonetheless?
I am not sure what do you mean by 'latest version does block, but there may be other reasons'. Are you saying that you are able to reproduce the problem with the build linked above? If so, please attach the messages.log from that version.
 
> Could you guys find out what the cause of this was based on the attached
> logs?
It is not clear what is wrong. Can you better describe what does it mean 'becomes unresponsive'? Is there a deadlock? Does NetBeans consume CPU? Is it temporary and NetBeans becomes responsive again? Do you have steps how to reproduce it? Can you try older JDK - 1.7.0_25?

>Can you tell me how I can find that myself for better future reports?
Once we will get answer to above questions, we can tell you, what you should try next.
Comment 5 ionuion 2013-09-19 18:13:48 UTC
Tomas

Please find attached the messages.log for development version.

> I am not sure what do you mean by 'latest version does block, but there may
> be other reasons'. 

> If so, please attach the messages.log from that
> version.
Attached

>  
> It is not clear what is wrong. Can you better describe what does it mean
> 'becomes unresponsive'? 
becomes unresponsive means the IDE doesn't respond to commands, doesn't redraw the window. It is only possible to close the IDE by killing it (Force Close under Mac os x). When the window is still on top of the screen the only activity is the spinning circle. It's dead man, dead...

> Is there a deadlock? 
As seen in the attached thread dump there is no blocked thread. In case you mean something else by deadlock, please explain.

> Does NetBeans consume CPU? 
As described, it does consume CPU, however in the range of 3-5%, not above.
>Is it temporary and NetBeans becomes responsive again? 
No. In 15 minutes after the issue occurs there is no change (neither in 7.3.1. nor in dev)

> Do you have steps how to
> reproduce it? 
As described, there are no steps to reproduce. It happens randomly. Each time I perform different things.

> Can you try older JDK - 1.7.0_25?
Yes, I will try and come back with conclusions.

> Once we will get answer to above questions, we can tell you, what you should
> try next.

Looking forward to it.
Thank you
Comment 6 ionuion 2013-09-19 18:15:30 UTC
Created attachment 140263 [details]
log file for the development version of the ide (IDE dead, blocked, unresponsive)
Comment 7 Marian Mirilovic 2013-09-23 10:57:27 UTC
(In reply to ionuion from comment #6)
> Created attachment 140263 [details]
> log file for the development version of the ide (IDE dead, blocked,
> unresponsive)

- JDK 7u40
- development build

P2 - per http://wiki.netbeans.org/BugPriorityGuidelines
Comment 8 Tomas Hurka 2013-09-23 13:40:12 UTC
(In reply to ionuion from comment #5) 
> > If so, please attach the messages.log from that
> > version.
> Attached
This shows that you are running dev. version and not the version the Marian asked you to use (7.4 RC1).

> > Can you try older JDK - 1.7.0_25?
> Yes, I will try and come back with conclusions.
The problem looks like JDK issue, so it is important to test 1.7.0_25 version.
Comment 9 ionuion 2013-09-24 13:00:19 UTC
Two days running with jdk 1.7.0_25 and no blocking

Environment:
Product Version: NetBeans IDE 7.4 RC1 (Build 201309162201)
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b15
System: Mac OS X version 10.7.5 running on x86_64; UTF-8; en_US (nb)
User directory: /Users/ionuion/Library/Application Support/NetBeans/7.4rc1
Cache directory: /Users/ionuion/Library/Caches/NetBeans/7.4rc1

(In reply to Tomas Hurka from comment #8)
> (In reply to ionuion from comment #5) 
> > > If so, please attach the messages.log from that
> > > version.
> > Attached
> This shows that you are running dev. version and not the version the Marian
> asked you to use (7.4 RC1).
> 
> > > Can you try older JDK - 1.7.0_25?
> > Yes, I will try and come back with conclusions.
> The problem looks like JDK issue, so it is important to test 1.7.0_25
> version.
Comment 10 ionuion 2013-09-25 09:37:49 UTC
Switched RC1 to using 1.7.0_40 and NetBeans IDE dies again.

Attaching logs:
- messages.log
- Mac OS inspect sample (is it any good, I won't attach any in the future, unless you say it's worth it)
- thread dump

Environment:
Product Version: NetBeans IDE 7.4 RC1 (Build 201309162201)
Java: 1.7.0_40; Java HotSpot(TM) 64-Bit Server VM 24.0-b56
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b43
System: Mac OS X version 10.7.5 running on x86_64; UTF-8; en_US (nb)



Please tell me what is the term you use for these symptoms:
- IDE doesn't respond to commands
- the only activity is the spinning circle (under Mac OS)
- IDE doesn't redraw the window; once the application is drawn on the screen, NetBeans won't be visible again
- close possible only by kill -9'ing

I used 'unresponsive' and that seems to not be a satisfying term. I will change the title of the bug to reflect that, as well as use the term in the future when logging similar bugs.

What further steps can I perform when this happens next time to help you guys?

Thank you
Comment 11 ionuion 2013-09-25 09:38:34 UTC
Created attachment 140439 [details]
logs taken after NetBeans died (became unresponsive)
Comment 12 Tomas Hurka 2013-09-25 10:54:45 UTC
AppKit thread seems to be blocked in sun.lwawt.macosx.LWCToolkit.doAWTRunLoop().
This looks like JDK problem introduced in JDK 7u40, since reverting to JDK 7u25 fixes the problem.
Comment 13 Antonin Nebuzelsky 2013-09-27 15:14:35 UTC
JDK bug #8025588 filed.
Comment 14 Antonin Nebuzelsky 2013-09-27 15:42:15 UTC
*** Bug 236339 has been marked as a duplicate of this bug. ***
Comment 15 Pchelko 2013-09-30 08:10:19 UTC
Judging from the stacktrace you are using some accessibility features. Do you really use them? I mean Voice Over, zooming or something like this?
Comment 16 Antonin Nebuzelsky 2013-09-30 11:06:05 UTC
*** Bug 236361 has been marked as a duplicate of this bug. ***
Comment 17 Antonin Nebuzelsky 2013-09-30 13:44:05 UTC
*** Bug 236361 has been marked as a duplicate of this bug. ***
Comment 18 Milutin Kristofic 2013-10-02 13:53:16 UTC
*** Bug 236639 has been marked as a duplicate of this bug. ***
Comment 19 ionuion 2013-10-17 20:07:29 UTC
(In reply to Pchelko from comment #15)
> Judging from the stacktrace you are using some accessibility features. Do
> you really use them? I mean Voice Over, zooming or something like this?

I never used those, but they might have been set by default or activated by mistake (e.g. pressing the Shift key 5 times or similar)
Comment 20 Antonin Nebuzelsky 2013-10-18 13:36:44 UTC
*** Bug 237148 has been marked as a duplicate of this bug. ***
Comment 21 Antonin Nebuzelsky 2013-10-23 13:47:39 UTC
*** Bug 237483 has been marked as a duplicate of this bug. ***
Comment 22 abien 2013-10-23 13:56:51 UTC
The problem still persists with JDK 1.7u45. It seems like the problem is getting worse after opening NetBeans preferences dialogs. I opened "Preferences" to adjust the "on save" settings and NetBeans "beach balled" 3 times in a row. Before that I worked for about 3h without any issues. 

Also it seems like my font rendering was affected after I opened the preferences dialog. However I'm not entirely sure here.
Comment 23 Antonin Nebuzelsky 2013-10-23 14:08:32 UTC
(In reply to abien from comment #22)
> The problem still persists with JDK 7u45.

Correct. The fix on JDK side is only in JDK 8 codebase so far.

See the discussion in the JDK bug
https://bugs.openjdk.java.net/browse/JDK-8025588
Comment 24 abien 2013-10-23 14:11:34 UTC
(In reply to Antonin Nebuzelsky from comment #23)
> (In reply to abien from comment #22)
> > The problem still persists with JDK 7u45.
> 
> Correct. The fix on JDK side is only in JDK 8 codebase so far.
> 
> See the discussion in the JDK bug
> https://bugs.openjdk.java.net/browse/JDK-8025588

Indeed: I worked with NetBeans 7.4 the whole day with: 1.8.0-ea-b111 without any problems. NB was fast and reliable.

With cut & paste we would have a perfect solution :-)
Comment 25 ionuion 2013-10-24 07:50:35 UTC
Created attachment 141500 [details]
log and thread dump

Environment:
Product Version: NetBeans IDE 7.4 (Build 201310111528)
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Mac OS X version 10.7.5 running on x86_64; UTF-8; en_US (nb)

Netbeans not responding.

The only difference from the behavior in the initial bug description is that NetBeans IDE redraws the screen successfully and no spinning beach ball is displayed. Clicks and shortcuts are ignored, however.

Attaching thread dump and log file.
Comment 26 Jiri Prox 2013-10-24 14:23:31 UTC
*** Bug 237480 has been marked as a duplicate of this bug. ***
Comment 27 Antonin Nebuzelsky 2013-10-25 14:50:23 UTC
(In reply to ionuion from comment #25)
> Created attachment 141500 [details]
> log and thread dump

Actually based on the thread dump this is a different problem. I have filed a separate report, see issue 237670.
Comment 28 beniguet 2013-10-25 14:53:34 UTC
(I had opened the duplicate bug 237480)

I just downgraded my JDK to 1.7.0_25, all is apparently back to normal now.

So far, so good.
Thanks!
Comment 29 ChrisJamesWright 2013-11-07 11:39:42 UTC
(In reply to abien from comment #24)
> (In reply to Antonin Nebuzelsky from comment #23)
> > (In reply to abien from comment #22)
> > > The problem still persists with JDK 7u45.
> > 
> > Correct. The fix on JDK side is only in JDK 8 codebase so far.
> > 
> > See the discussion in the JDK bug
> > https://bugs.openjdk.java.net/browse/JDK-8025588
> 
> Indeed: I worked with NetBeans 7.4 the whole day with: 1.8.0-ea-b111 without
> any problems. NB was fast and reliable.
> 
> With cut & paste we would have a perfect solution :-)

Interesting – having tried 1.8.0-ea-b114, it seems the problems still persist for me (triggered easily by deleting a file in a project).

I noticed in the JDK bug tracker, it is listed as fixed in master. Does this mean it should be resolved in b114 or will it be part of a later build?

Thanks
Comment 30 abien 2013-11-07 17:38:50 UTC
(In reply to ChrisJamesWright from comment #29)
> (In reply to abien from comment #24)
> > (In reply to Antonin Nebuzelsky from comment #23)
> > > (In reply to abien from comment #22)
> > > > The problem still persists with JDK 7u45.
> > > 
> > > Correct. The fix on JDK side is only in JDK 8 codebase so far.
> > > 
> > > See the discussion in the JDK bug
> > > https://bugs.openjdk.java.net/browse/JDK-8025588
> > 
> > Indeed: I worked with NetBeans 7.4 the whole day with: 1.8.0-ea-b111 without
> > any problems. NB was fast and reliable.
> > 
> > With cut & paste we would have a perfect solution :-)
> 
> Interesting – having tried 1.8.0-ea-b114, it seems the problems still
> persist for me (triggered easily by deleting a file in a project).
> 
> I noticed in the JDK bug tracker, it is listed as fixed in master. Does this
> mean it should be resolved in b114 or will it be part of a later build?
> 
> Thanks

It is strange: but the build 1.8.0-ea-b114 does not work at all for me. 1.8.0-ea-b113 was broken as well. However: in >=1.8.0-ea-b113 copy and paste seems to work, but NB freezes again. It seems like even we get copy and paste or stability but never both.
Comment 31 Antonin Nebuzelsky 2013-11-08 09:58:25 UTC
See the upcoming JDK8 b115 which has fixes of #8025588 and #8026262 finally included.

https://bugs.openjdk.java.net/browse/JDK-8025588
https://bugs.openjdk.java.net/browse/JDK-8026262
Comment 32 Tomas Hurka 2013-11-11 14:57:54 UTC
*** Bug 238195 has been marked as a duplicate of this bug. ***
Comment 33 Antonin Nebuzelsky 2013-11-21 15:49:27 UTC
*** Bug 238483 has been marked as a duplicate of this bug. ***
Comment 34 markee174 2013-11-21 17:54:30 UTC
I have been testing NetBeans 7.4 patch 1 with JDK1.7.0b45 and no problem found
Comment 35 jcstritt 2013-11-26 07:45:16 UTC
No the bug is still here with JDK1.7.0b45 and NetBeans 7.4 with patch 1. This is reproductible when you search on a reference (Find Usages ^F7). With JDK1.7.0b25 this is OK.
Comment 36 Antonin Nebuzelsky 2013-11-26 09:12:40 UTC
(In reply to jcstritt from comment #35)
> No the bug is still here with JDK1.7.0b45 and NetBeans 7.4 with patch 1.

Right. The JDK bug will not be fixed on NetBeans side.

The fix on the Java side is in JDK 8 build number b115. It will also appear in one of the upcoming JDK 7 updates, most probably 7u55.
Comment 37 Antonin Nebuzelsky 2013-12-02 10:11:27 UTC
*** Bug 238906 has been marked as a duplicate of this bug. ***
Comment 38 Antonin Nebuzelsky 2013-12-04 10:00:11 UTC
*** Bug 239067 has been marked as a duplicate of this bug. ***
Comment 39 Antonin Nebuzelsky 2013-12-12 12:35:44 UTC
*** Bug 236842 has been marked as a duplicate of this bug. ***
Comment 40 toddfast 2013-12-12 19:37:26 UTC
FYI, it is NOT fixed in JDK 7u60 Build b01.
Comment 41 Antonin Nebuzelsky 2013-12-13 15:49:49 UTC
(In reply to toddfast from comment #40)
> FYI, it is NOT fixed in JDK 7u60 Build b01.

Not yet backported.

Could you verify that you don't encounter the problem with the latest promoted JDK8 build? Thanks.
Comment 42 Tomas Hurka 2013-12-31 11:42:47 UTC
*** Bug 236786 has been marked as a duplicate of this bug. ***
Comment 43 dgradwell 2014-01-08 13:58:40 UTC
Bug fixed by deploying jdk 8 Build b121 from https://jdk8.java.net/download.html
Comment 44 Antonin Nebuzelsky 2014-01-09 10:56:41 UTC
*** Bug 239904 has been marked as a duplicate of this bug. ***
Comment 45 Antonin Nebuzelsky 2014-01-13 09:02:26 UTC
*** Bug 240335 has been marked as a duplicate of this bug. ***
Comment 46 dgradwell 2014-01-13 09:53:39 UTC
(In reply to Antonin Nebuzelsky from comment #41)
> (In reply to toddfast from comment #40)
> > FYI, it is NOT fixed in JDK 7u60 Build b01.
> 
> Not yet backported.
> 
> Could you verify that you don't encounter the problem with the latest
> promoted JDK8 build? Thanks.

I've now been running for a week with NetBeans 7.4 and jdk 8 Build b121 from https://jdk8.java.net/download.html with no hangs.  This compares with a hang every 20 mins before I installed jdk 8.
Comment 47 Martin Entlicher 2014-01-21 16:17:07 UTC
*** Bug 240004 has been marked as a duplicate of this bug. ***
Comment 48 Ondrej Vrabec 2014-02-18 15:42:28 UTC
*** Bug 242027 has been marked as a duplicate of this bug. ***
Comment 49 rweaver 2014-02-19 00:06:24 UTC
Created attachment 145380 [details]
Output from Nb kill

Let me know if you need anything else
Comment 50 rweaver 2014-02-19 00:09:50 UTC
BTW, I can reproduce this 100% of the time by doing a Git commit followed by a push.

Workaround for me is to close down NB after commit and then do the push which seems to succeed every time.

Message from push is displayed in NB, hang appears to happen after the push is successful.

Also noticed a couple of scenarios in the Maven properties that can reliably hang NB, not sure if they are related.
Comment 51 Antonin Nebuzelsky 2014-02-19 11:51:29 UTC
Right. The JDK bug is manifesting at various places. For now to eliminate the issue on OS-X you need to use the promoted early access build of JDK8 (https://jdk8.java.net/download.html) where the JDK bug has been already fixed. Later the next JDK 7 update 55 will also include the fix.
Comment 52 rweaver 2014-02-21 00:01:11 UTC
I've validated that this doesn't occur on Windoze with 7.4 or 8.0 of NB and current JDK

Also verified that upgrading to JDK 1.8 corrects the issue.

Thanks !
Comment 53 Ondrej Vrabec 2014-03-10 12:08:25 UTC
*** Bug 242737 has been marked as a duplicate of this bug. ***
Comment 54 Antonin Nebuzelsky 2014-04-28 12:09:44 UTC
*** Bug 243779 has been marked as a duplicate of this bug. ***
Comment 55 Antonin Nebuzelsky 2014-05-26 10:29:03 UTC
*** Bug 243365 has been marked as a duplicate of this bug. ***
Comment 56 Tomas Hurka 2014-06-06 07:08:16 UTC
*** Bug 243304 has been marked as a duplicate of this bug. ***
Comment 57 Tomas Hurka 2014-06-06 07:10:04 UTC
*** Bug 244829 has been marked as a duplicate of this bug. ***
Comment 58 Tomas Hurka 2014-06-27 08:01:42 UTC
*** Bug 245239 has been marked as a duplicate of this bug. ***
Comment 59 Jaroslav Havlin 2014-08-04 14:01:27 UTC
*** Bug 245953 has been marked as a duplicate of this bug. ***
Comment 60 Ondrej Vrabec 2014-08-05 10:42:12 UTC
*** Bug 245285 has been marked as a duplicate of this bug. ***
Comment 61 AlexJuvion 2019-01-22 05:51:12 UTC
Majority of developers are using this software as it allows to develop desktop, mobile, and web applications with any popular programming languages that too free and easy & quick. And it is expected that some time it nor work fine and get some error while programming and such platform is best to share bugs and solution with experts and users to get feedback. 

Alex,
http://www.qualityassignment.co.uk/
Comment 62 hailiehills 2019-04-16 07:19:32 UTC
I'm not a developer but I know that your ideas are interesting for them. I like reading about innovations, especially in cinematography. My favorite site is http://essaystore.net/film-review. Check it if you are also interested in this.
Comment 63 Susancarer 2019-05-28 09:55:33 UTC
Hi there. Hi! Thanks for the article! If students don't know how to write test question, I stumbled upon one website, where they can read some useful tips. https://mid-terms.com/answer-my-test-questions/
Comment 64 elzasmitt 2019-05-30 15:38:22 UTC
For me as for the student of the New Yok Legal School articles you posted here are quite helpful and I always use them like the addition to the essays which I ordered at the https://exclusive-paper.net/ and where I always get the neccessar asssictancfe concerning the topic of creating diffeent term papers for the university


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo