Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 238483 - Netbeans 7.4 always freezes in OSX Mavericks
Netbeans 7.4 always freezes in OSX Mavericks
Status: RESOLVED DUPLICATE of bug 236101
Product: platform
Classification: Unclassified
Component: -- Other --
7.4
Macintosh (x86) Mac OS X
: P1 (vote)
: TBD
Assigned To: Antonin Nebuzelsky
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-17 22:29 UTC by a_smucig
Modified: 2013-11-21 15:49 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump of my locked up nb made with jvisualvm... (20.53 KB, text/plain)
2013-11-17 22:29 UTC, a_smucig
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a_smucig 2013-11-17 22:29:10 UTC
Created attachment 142291 [details]
Thread dump of my locked up nb made with jvisualvm...

The IDE locks up after a few minutes of usage. So far i see no connection between the freezes and the component used at the time. It have locked up in the editor, resolve conflict window, settings, plugins and UI editor. I tried out build 201311170002 and it is still hanging. The operating system is OSX Mavericks.
java -version:
java version "1.7.0_40"
Java(TM) SE Runtime Environment (build 1.7.0_40-b43)
Java HotSpot(TM) 64-Bit Server VM (build 24.0-b56, mixed mode)
Attached a thread dump made with visual vm. Since I can reproduce this any time, feel free to ask for logs or whatever you need from the IDE. Just tell me where it is. I also have a thread dump if you need it.
Comment 1 Antonin Nebuzelsky 2013-11-21 15:49:27 UTC
A known problem, has been filed to JDK.

Fixed in promoted builds of JDK8 so far, since b115. You can get JDK8 builds at

https://jdk8.java.net/download.html

In JDK 7uX codeline, the regression was introduced in 7u40 and not fixed yet in the last 7u45.

*** This bug has been marked as a duplicate of bug 236101 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo