Bug 228729 - Submenu of hints is not shown on secondary screen (dual monitor setup)
Submenu of hints is not shown on secondary screen (dual monitor setup)
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Hints & Annotations
7.3.1
PC Windows 7
: P2 (vote)
: 7.4
Assigned To: Jan Lahoda
issues@editor
73patch-candidate
:
: 223717 232126 (view as bug list)
Depends on: 229200
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-18 22:05 UTC by markiewb
Modified: 2013-07-03 08:27 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Shows the missing submenu (132.06 KB, image/png)
2013-04-18 22:05 UTC, markiewb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description markiewb 2013-04-18 22:05:09 UTC
Created attachment 133577 [details]
Shows the missing submenu

Setup: dual monitor
LEFT: main screen RIGHT: secondary screen

ACTUAL:
Submenu of hints is shown on main screen OK
Submenu of hints is not shown on secondary screen NOK - see screenshot

EXPECTED:
Submenu of hints is shown on main screen AND secondary screen

This issue has also been seen in the build from 2013/04/15. Please check also 7.3.1!
Comment 1 markiewb 2013-04-23 21:29:03 UTC
Tested. This issue can also be reproduced in 7.3.1
Comment 2 Quality Engineering 2013-04-28 02:18:29 UTC
Integrated into 'main-golden', will be available in build *201304272301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d0b42d846791
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #228729: trying to get the correct screen bounds by enumerating all devices
Comment 3 Jan Lahoda 2013-04-29 18:00:45 UTC
The above might work, but needs to be tested very carefully.
Comment 4 markiewb 2013-04-29 20:44:47 UTC
Thanks Jan. It works on my system using dev build from 20130428
Comment 5 Jan Lahoda 2013-05-03 07:34:01 UTC
Backported to release73:
http://hg.netbeans.org/releases/rev/c8690d29099b
Comment 6 Quality Engineering 2013-05-05 00:26:13 UTC
Integrated into 'releases', will be available in build *201305042200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/c8690d29099b
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #228729: trying to get the correct screen bounds by enumerating all devices
Comment 7 Jan Lahoda 2013-05-09 07:02:22 UTC
Marian, I am afraid we may need to rollback the patch 2 change: first invocation of GraphicsDevice.getConfigurations(), used by the patch, can take ages (>36s) on single-headed Windows. That basically means the first hint popup may take tens of seconds.

Whatever workaround we may find for that is likely to be too dangerous for inclusion into the patch2 release.

NetBeans bug:
https://netbeans.org/bugzilla/show_bug.cgi?id=229200
JDK bug:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6477756
Comment 8 Marian Mirilovic 2013-05-09 08:12:26 UTC
(In reply to comment #7)
> Marian, I am afraid we may need to rollback the patch 2 change: first
> invocation of GraphicsDevice.getConfigurations(), used by the patch, can take
> ages (>36s) on single-headed Windows. That basically means the first hint popup
> may take tens of seconds.

Ok, please do so NOW
Comment 9 Jan Lahoda 2013-05-09 09:15:04 UTC
Reverted from release73 branch:
http://hg.netbeans.org/releases/rev/d6fe1814d087
Comment 10 markiewb 2013-05-09 22:38:32 UTC
(In reply to comment #9)
> Reverted from release73 branch:
> http://hg.netbeans.org/releases/rev/d6fe1814d087

@Jan: Do you like to reopen the issue?! The state is still "verified fixed".

* Is any of the workarounds described in [1] (jvm-arg or warmup-task) suitable as a fix? 
* How do other IDEs workaround this issue? For example IDEA - they also have submenus in their code completions/hints/intensions... You may have a look at their sources as they are free (community edition).

[1] http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6477756
Comment 11 Quality Engineering 2013-05-10 00:26:03 UTC
Integrated into 'releases', will be available in build *201305092200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/d6fe1814d087
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #228729: reverting effects of the fix from the release73 branch, as it is causing a regression in hint popup time (#229200)
Comment 12 Jan Lahoda 2013-05-10 07:28:47 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > Reverted from release73 branch:
> > http://hg.netbeans.org/releases/rev/d6fe1814d087
> 
> @Jan: Do you like to reopen the issue?! The state is still "verified fixed".

The fix has been reverted only from release73 branch, it still is in the trunk/7.4. The status of this bug has also been reverted to be consistent with the status of the code. But if you still can reproduce in trunk/7.4, then by all means reopen the issue.

> 
> * Is any of the workarounds described in [1] (jvm-arg or warmup-task) suitable
> as a fix? 

I don't think so: the side-effects of the jvm-arg are unclear (seemed dangerous even in the JVM bug) and I think the warm-up task would still need to run in AWT (i.e. there would be at least one long lag).

Tried to workaround here by not calling the method for single-headed environments:
http://hg.netbeans.org/main-golden/rev/9b89676e0140
Comment 13 markiewb 2013-05-10 16:22:28 UTC
(In reply to comment #12)
>But if you still can reproduce in trunk/7.4, then by all means reopen the issue.

Thanks Jan for the clarification. It still works with the dev build from the last night. So keeping this issue in the state "fixed".
Comment 14 markiewb 2013-05-13 21:56:12 UTC
*** Bug 223717 has been marked as a duplicate of this bug. ***
Comment 15 Jan Lahoda 2013-07-03 08:27:20 UTC
*** Bug 232126 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo