Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 229200 - org.netbeans.modules.editor.hints.HintsUI.showPopup: LowPerformance took 41090 ms.
org.netbeans.modules.editor.hints.HintsUI.showPopup: LowPerformance took 4109...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Hints & Annotations
7.4
All All
: P3 (vote)
: 7.4
Assigned To: Jan Lahoda
issues@editor
jdk_bug_6477756 EXCEPTIONS_REPORT per...
: PERFORMANCE
Depends on:
Blocks: 228729
  Show dependency treegraph
 
Reported: 2013-04-30 10:34 UTC by dynamite
Modified: 2013-07-03 20:04 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (134.20 KB, application/nps)
2013-04-30 10:34 UTC, dynamite
Details
nps snapshot (52.56 KB, application/nps)
2013-05-08 18:55 UTC, pwade
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dynamite 2013-04-30 10:34:48 UTC
Build: NetBeans IDE Dev (Build 201304292301)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.21-b01, Java(TM) SE Runtime Environment, 1.7.0_21-b11
OS: Windows 7

User Comments:
dynamite: After renaming directories I get this UI lock-up after trying to trigger the identification of a class that no longer seems to be found.



Maximum slowness yet reported was 41090 ms, average is 22529
Comment 1 dynamite 2013-04-30 10:34:51 UTC
Created attachment 133967 [details]
nps snapshot
Comment 2 pwade 2013-05-08 18:55:47 UTC
Created attachment 134230 [details]
nps snapshot

Trying to bring up hint
Comment 3 Jan Lahoda 2013-05-09 07:05:24 UTC
Caused by the fix of bug #228729, which calls GraphicsDevice.getConfigurations(), first invocation of which can take
ages on single-headed Windows.

JDK bug:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6477756
Comment 4 Jan Lahoda 2013-05-09 07:50:17 UTC
Tried preventing invocation of GraphicsDevice.getConfigurations() for single-headed configurations:
http://hg.netbeans.org/jet-main/rev/9b89676e0140

Could someone with Window please test?

Thanks.
Comment 5 Quality Engineering 2013-05-10 00:25:58 UTC
Integrated into 'releases', will be available in build *201305092200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/d6fe1814d087
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #228729: reverting effects of the fix from the release73 branch, as it is causing a regression in hint popup time (#229200)
Comment 6 Quality Engineering 2013-05-10 02:36:47 UTC
Integrated into 'main-golden', will be available in build *201305092300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/9b89676e0140
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #229200: first invocation of GraphicsDevice.getConfigurations() can be very slow on single-headed Windows, prevent calling it when there is only one GraphicsDevice.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo