Bug 217446 - AssertionError at org.openide.loaders.TemplateWizard.updateState
AssertionError at org.openide.loaders.TemplateWizard.updateState
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Stanislav Aubrecht
issues@platform
EXCEPTIONS_REPORT
:
: 217536 217729 218103 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 07:53 UTC by Chiana
Modified: 2012-10-22 21:36 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (6.20 KB, text/plain)
2012-08-27 07:53 UTC, Chiana
Details
stacktrace (8.54 KB, text/plain)
2012-09-05 12:17 UTC, Vladimir Riha
Details
stacktrace (11.02 KB, text/plain)
2012-09-10 12:38 UTC, David Strupl
Details
stacktrace (9.36 KB, text/plain)
2012-09-12 06:59 UTC, lehel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chiana 2012-08-27 07:53:28 UTC
Build: NetBeans IDE Dev (Build 201208260001)
VM: Java HotSpot(TM) 64-Bit Server VM, 22.1-b02, Java(TM) SE Runtime Environment, 1.7.0_03-b05
OS: Windows 7

User Comments:
Chiana: Created .dll project with cygWin




Stacktrace: 
java.lang.AssertionError
   at org.openide.loaders.TemplateWizard.updateState(TemplateWizard.java:745)
   at org.netbeans.modules.project.ui.NewProjectWizard.updateState(NewProjectWizard.java:71)
   at org.openide.WizardDescriptor.updateStateWithFeedback(WizardDescriptor.java:1010)
   at org.openide.WizardDescriptor.access$1900(WizardDescriptor.java:89)
   at org.openide.WizardDescriptor$Listener$2$1.run(WizardDescriptor.java:2147)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1454)
Comment 1 Chiana 2012-08-27 07:53:29 UTC
Created attachment 123596 [details]
stacktrace
Comment 2 Milos Kleint 2012-08-29 09:20:32 UTC
*** Bug 217536 has been marked as a duplicate of this bug. ***
Comment 3 Milos Kleint 2012-09-03 10:52:23 UTC
*** Bug 217729 has been marked as a duplicate of this bug. ***
Comment 4 Milos Kleint 2012-09-03 11:01:04 UTC
I suppose the problem is in WizardDescriptor$Listener that listens on stuff and calls updateState() on wizard and doesn't fulfill the contract expressed in the assert (or the assert is wrong, cannot tell)
Comment 5 Vladimir Riha 2012-09-05 12:17:00 UTC
Created attachment 123950 [details]
stacktrace

activating JavaFX
Comment 6 David Strupl 2012-09-10 12:38:13 UTC
Created attachment 124097 [details]
stacktrace

Create new JavaFX project.
Comment 7 Exceptions Reporter 2012-09-10 12:38:27 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=191864
Comment 8 Stanislav Aubrecht 2012-09-10 13:38:37 UTC
core-main b9ce7d724c13
Comment 9 Stanislav Aubrecht 2012-09-11 08:32:31 UTC
*** Bug 218103 has been marked as a duplicate of this bug. ***
Comment 10 Quality Engineering 2012-09-12 02:08:26 UTC
Integrated into 'main-golden', will be available in build *201209120001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/b9ce7d724c13
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #217446 - call updateState() from EDT
Comment 11 lehel 2012-09-12 06:59:12 UTC
Created attachment 124193 [details]
stacktrace

Trying a JavaFx Sample Project, Netbeans was activating the JavaFx Sdk
Comment 12 Chiana 2012-10-22 21:36:55 UTC
Tested several ways to create new class files, template projects, seems ok now.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo