Bug 218103 - AssertionError at org.openide.loaders.TemplateWizard.updateState
AssertionError at org.openide.loaders.TemplateWizard.updateState
Status: RESOLVED DUPLICATE of bug 217446
Product: cnd
Classification: Unclassified
Component: -- Other --
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Andrew Krasny
issues@cnd
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 08:29 UTC by Andrew Krasny
Modified: 2012-09-11 09:07 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.99 KB, text/plain)
2012-09-11 08:29 UTC, Andrew Krasny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Krasny 2012-09-11 08:29:48 UTC
Build: NetBeans IDE Dev (Build 20120911-b40fb9b903f0)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: SunOS

Stacktrace: 
java.lang.AssertionError
   at org.openide.loaders.TemplateWizard.updateState(TemplateWizard.java:745)
   at org.openide.WizardDescriptor$Listener.stateChanged(WizardDescriptor.java:2062)
   at org.openide.util.WeakListenerImpl$Change.stateChanged(WeakListenerImpl.java:329)
   at org.openide.util.ChangeSupport.fireChange(ChangeSupport.java:133)
   at org.openide.util.ChangeSupport.fireChange(ChangeSupport.java:119)
   at org.netbeans.modules.cnd.editor.filecreation.CndPanel.stateChanged(CndPanel.java:178)
Comment 1 Andrew Krasny 2012-09-11 08:29:52 UTC
Created attachment 124140 [details]
stacktrace
Comment 2 Stanislav Aubrecht 2012-09-11 08:32:31 UTC

*** This bug has been marked as a duplicate of bug 217446 ***
Comment 3 Andrew Krasny 2012-09-11 09:07:16 UTC
even if it is a duplicate, it's better to file UI-related changes in EDT... 
Related patch for cnd:
http://hg.netbeans.org/cnd-main/rev/bce82e893ff2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo