Bug 197210 - NPE from DefaultMetadataResolver.resolve in BasicPanelVisual.downloadArchetype
NPE from DefaultMetadataResolver.resolve in BasicPanelVisual.downloadArchetype
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Maven
7.0
PC Linux
: P2 (vote)
: 7.0
Assigned To: Jesse Glick
issues@projects
EXCEPTIONS_REPORT
: 70_HR_FIX
Depends on: 196861 197146
Blocks: 196044
  Show dependency treegraph
 
Reported: 2011-03-30 02:03 UTC by Jesse Glick
Modified: 2011-04-01 10:53 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-03-30 02:03:58 UTC
See bug #196044 comment #8.
Comment 1 Jesse Glick 2011-03-30 02:06:02 UTC
core-main #b50eb95e3fce
Comment 2 Tomas Danek 2011-03-30 12:22:13 UTC
Verified in core-main, please proceed with backporting to 7.0.

Product Version: NetBeans IDE Dev (Build 20110330-41234cdb139c)
Java: 1.6.0_24; Java HotSpot(TM) 64-Bit Server VM 19.1-b02-334
System: Mac OS X version 10.6.7 running on x86_64; MacRoman; en_US (nb)
Userdir: /tmp/ud3
Comment 3 Martin Fousek 2011-03-30 12:55:07 UTC
Agree, doesn't appear any more.
Comment 4 Jesse Glick 2011-03-30 21:33:40 UTC
releases #9e042b327f70
Comment 5 Quality Engineering 2011-03-31 08:50:22 UTC
Integrated into 'main-golden', will be available in build *201103310400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/b50eb95e3fce
User: Jesse Glick <jglick@netbeans.org>
Log: #197210: NPE from DefaultMetadataResolver.resolve in BasicPanelVisual.downloadArchetype
Comment 6 Tomas Danek 2011-04-01 10:53:57 UTC
cannot reproduce in latest 7.0 build - verified

Product Version: NetBeans IDE 7.0 RC2 (Build 201103310000)
Java: 1.6.0_24; Java HotSpot(TM) 64-Bit Server VM 19.1-b02-334
System: Mac OS X version 10.6.7 running on x86_64; MacRoman; en_US (nb)
Userdir: /Users/tomas/.netbeans/7.0rc2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo