Bug 196861 - NullPointerException at org.sonatype.aether.impl.internal.DefaultMetadataResolver.resolve
NullPointerException at org.sonatype.aether.impl.internal.DefaultMetadataReso...
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: 7.0
Assigned To: Jesse Glick
issues@projects
EXCEPTIONS_REPORT
: 70_HR_FIX
Depends on:
Blocks: 197210
  Show dependency treegraph
 
Reported: 2011-03-18 16:48 UTC by athompson
Modified: 2011-03-30 21:33 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.63 KB, text/plain)
2011-03-18 16:48 UTC, athompson
Details
stacktrace (4.63 KB, text/plain)
2011-03-18 17:49 UTC, athompson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description athompson 2011-03-18 16:48:24 UTC
This bug was originally marked as duplicate of bug 196044, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201103180400)
VM: Java HotSpot(TM) 64-Bit Server VM, 19.1-b02, Java(TM) SE Runtime Environment, 1.6.0_24-b07
OS: Windows 7

User Comments:
FrantaM: Maven project; clicked Download javadoc on Dependecies node.

fleka: download sources on dependencies

athompson: tried to download dependency sources for a Maven project




Stacktrace: 
java.lang.NullPointerException
   at org.sonatype.aether.impl.internal.DefaultMetadataResolver.resolve(DefaultMetadataResolver.java:283)
   at org.sonatype.aether.impl.internal.DefaultMetadataResolver.resolveMetadata(DefaultMetadataResolver.java:177)
   at org.apache.maven.repository.internal.DefaultVersionResolver.resolveVersion(DefaultVersionResolver.java:211)
   at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:276)
   at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:220)
   at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:197)
Comment 1 athompson 2011-03-18 16:48:28 UTC
Created attachment 107112 [details]
stacktrace
Comment 2 athompson 2011-03-18 17:49:02 UTC
Created attachment 107116 [details]
stacktrace
Comment 3 Jesse Glick 2011-03-18 21:53:13 UTC
core-main #6d0f27703fa9
Comment 4 Quality Engineering 2011-03-19 09:42:48 UTC
Integrated into 'main-golden', will be available in build *201103190400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/6d0f27703fa9
User: Jesse Glick <jglick@netbeans.org>
Log: #196861: NullPointerException at org.sonatype.aether.impl.internal.DefaultMetadataResolver.resolve
No idea how to reproduce but this may fix it.
Comment 5 pekarna 2011-03-22 18:46:03 UTC
I have a project on which I can reliably reproduce this.
I'll try the new build, and if still happens, I'll upload it somewhere.
Comment 6 Jesse Glick 2011-03-22 20:31:48 UTC
Yes please, verify or reopen as appropriate. (If this exception happens frequently and interferes with routine work, it may be P2 and thus a 70_HR_FIX_CANDIDATE.)
Comment 7 pekarna 2011-03-23 00:10:11 UTC
Seems to be fixed in 201103220400.
Comment 8 Jesse Glick 2011-03-23 01:17:34 UTC
Great! (Feel free to mark bugs VERIFIED yourself if you could reproduce before but not after the fix.)
Comment 9 Jesse Glick 2011-03-30 21:33:50 UTC
More general fix in bug #197210, but backporting as a prerequisite: releases #c5914517657c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo