Bug 197146 - NullPointerException at org.sonatype.aether.impl.internal.DefaultMetadataResolver.resolve
NullPointerException at org.sonatype.aether.impl.internal.DefaultMetadataReso...
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
7.0
All All
: P2 (vote)
: 7.0
Assigned To: Jesse Glick
issues@projects
EXCEPTIONS_REPORT
: 70_HR_FIX
: 197154 197238 (view as bug list)
Depends on:
Blocks: 197210
  Show dependency treegraph
 
Reported: 2011-03-28 09:06 UTC by pekarna
Modified: 2011-03-30 21:45 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.84 KB, text/plain)
2011-03-28 09:06 UTC, pekarna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pekarna 2011-03-28 09:06:51 UTC
This bug was originally marked as duplicate of bug 196044, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201103220400)
VM: Java HotSpot(TM) 64-Bit Server VM, 19.1-b02, Java(TM) SE Runtime Environment, 1.6.0_24-b07
OS: Linux

User Comments:
pekarna: I opened a maven project this probably happened while scanning.




Stacktrace: 
java.lang.NullPointerException
   at org.sonatype.aether.impl.internal.DefaultMetadataResolver.resolve(DefaultMetadataResolver.java:283)
   at org.sonatype.aether.impl.internal.DefaultMetadataResolver.resolveMetadata(DefaultMetadataResolver.java:177)
   at org.apache.maven.repository.internal.DefaultVersionResolver.resolveVersion(DefaultVersionResolver.java:211)
   at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:276)
   at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:220)
   at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:197)
Comment 1 pekarna 2011-03-28 09:06:55 UTC
Created attachment 107329 [details]
stacktrace
Comment 2 Jesse Glick 2011-03-28 20:17:59 UTC
Yet another one. Unfortunately I do not know how to find them, since I cannot reproduce locally. May depend on some particular aspect of the edited Maven projects, or settings.xml.
Comment 3 Jesse Glick 2011-03-28 20:19:22 UTC
core-main #024252ce599b
Comment 4 Jesse Glick 2011-03-29 03:29:32 UTC
*** Bug 197154 has been marked as a duplicate of this bug. ***
Comment 5 Quality Engineering 2011-03-29 08:40:54 UTC
Integrated into 'main-golden', will be available in build *201103290400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/024252ce599b
User: Jesse Glick <jglick@netbeans.org>
Log: #197146: NullPointerException at org.sonatype.aether.impl.internal.DefaultMetadataResolver.resolve
Comment 6 Jesse Glick 2011-03-30 16:43:16 UTC
*** Bug 197238 has been marked as a duplicate of this bug. ***
Comment 7 Jesse Glick 2011-03-30 16:43:59 UTC
Bug #197210 has a more general fix.
Comment 8 Jesse Glick 2011-03-30 21:33:45 UTC
releases #1be7bafa3ebb


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo