Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 185030 - Provide common pop-up actions for files in the Search Results window
Provide common pop-up actions for files in the Search Results window
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Search
6.x
All All
: P3 (vote)
: 8.0
Assigned To: Jaroslav Havlin
issues@utilities
:
: 106670 239311 (view as bug list)
Depends on:
Blocks: 33418
  Show dependency treegraph
 
Reported: 2010-04-26 16:34 UTC by rptmaestro
Modified: 2013-12-10 14:35 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rptmaestro 2010-04-26 16:34:20 UTC
When getting a list of files in the search results window, it would be extremely useful to be able to invoke some of the common actions via a popup window rather than having to find the file in the explorer.

Actions that I would particularly like to see on search results are:

- Diff (to other search results)
- Find Usages
- Refactoring actions
- Versioning actions

Pretty much, all (or at least, most) actions from the explorer pop-up menu should show up when right-clicking on one or more files in the Search Results window.
Comment 1 Peter Pis 2010-04-27 06:48:13 UTC
Reassigning.
Comment 2 Jaroslav Havlin 2013-10-04 11:20:01 UTC
http://hg.netbeans.org/core-main/rev/63eee5b4139e
Fixed.
Thank you for reporting.
Comment 3 Quality Engineering 2013-10-05 03:48:37 UTC
Integrated into 'main-silver', will be available in build *201310050001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/63eee5b4139e
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #185030: Provide common pop-up actions for files in the Search Results window
Comment 4 Jaroslav Havlin 2013-10-07 09:44:14 UTC
*** Bug 106670 has been marked as a duplicate of this bug. ***
Comment 5 Jaroslav Havlin 2013-12-10 14:35:52 UTC
*** Bug 239311 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo