Bug 33418 - Redesign UI for displaying search results
Redesign UI for displaying search results
Status: RESOLVED WORKSFORME
Product: utilities
Classification: Unclassified
Component: Search
3.x
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Havlin
issues@utilities
: UI, UMBRELLA
Depends on: 7150 10796 17633 26595 30152 33190 33717 33719 103791 183760 185030 190352 190892 190961 191749 196871 200020
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-06 13:07 UTC by Marian Petras
Modified: 2013-11-07 15:53 UTC (History)
3 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Petras 2003-05-06 13:07:59 UTC
There are many issues regarding the Search Results
dialog. This is an umbrella issue covering these
issues.
Comment 1 Marian Petras 2003-05-06 13:22:44 UTC
The new design and all interactions must be properly specified/documented.
Comment 2 Marian Petras 2003-08-04 10:04:20 UTC
Issue #7311 was marked as a duplicate of issue #33717 so I remove it
from the dependency tree.
Comment 3 Marian Petras 2004-10-18 16:01:19 UTC
A major change has been made in the design of the Search Results
window. The search results window is no longer split into two panels.
When a node representing a matching object is expanded, its subnodes
display matching lines found in the object's primary file. Within each
line, the matching text is in bold.

The current design is very close to design suggested in issue #17633
("Info on right of Search Filesystems result dialog is not seen by new
users"). It has been implemented together during fixing of bug #19484
("OOME when performing search on larger FS").

Although the current design is much better than the previous one, it
is not based on any study and was made as a quick fix.
Comment 4 _ mihmax 2004-10-19 11:10:03 UTC
If I may add my 2 cents,
the current design is much, much better than the previous one.

Of course, professional usability study and a formal UI spec wouldn't
harm, but UI is already close to perfect.
Comment 5 Jaroslav Havlin 2013-11-07 15:53:10 UTC
All sub-issues are resolved, so this bug can be closed, too.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo