Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 239311 - Add 'Diff To' Action in 'Search Results' view
Add 'Diff To' Action in 'Search Results' view
Status: RESOLVED DUPLICATE of bug 185030
Product: utilities
Classification: Unclassified
Component: Search
7.4
PC Linux
: P3 (vote)
: 8.0
Assigned To: Jaroslav Havlin
issues@utilities
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-10 12:47 UTC by tomzi
Modified: 2013-12-10 14:35 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tomzi 2013-12-10 12:47:18 UTC
The fastest way to get a diff of one file between to branches if you have them checked out locally is:
Currently:
.) Select the two parentdirectory of both branches in 'Favourites View' 
   eg. branch1, branch2
.) Right click 'Find...'
.) Enter 'MyFile.java'
This will show:
[-] Found 2 matching files.
     MyFile.java [branch1]
     MyFile.java [branch2]
    
But I can not 'Diff' between them, currently only the actions 'Edit' and 'Hide' can be selected.

Expected:
.) Select both file and 'right-click'/Diff To.

I know there exists a workaround by
.) opening both files in favourites view
.) select one file, shift select the other file
,) select 'diff'

But this is way complicated if I already have the two files in the 'Search result' view.


Product Version = NetBeans IDE 7.4 (Build 201310111528)
Operating System = Linux version 3.8.0-32-generic running on amd64
Java; VM; Vendor = 1.7.0_45
Runtime = Java HotSpot(TM) 64-Bit Server VM 24.45-b08
Comment 1 Jaroslav Havlin 2013-12-10 14:35:51 UTC
Already fixed in daily builds:

Select both files -> right-click -> More -> Tools -> Diff.

Thank you for reporting.

*** This bug has been marked as a duplicate of bug 185030 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo