Bug 182653 - [69cat] Transaction index for indexing
[69cat] Transaction index for indexing
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
PC All
: P2 with 4 votes (vote)
: 7.2
Assigned To: Tomas Zezula
issues@editor
: PERFORMANCE, PLAN
: 134990 182190 (view as bug list)
Depends on:
Blocks: 180193 183380 184342 202573 203422
  Show dependency treegraph
 
Reported: 2010-03-24 10:48 UTC by Tomas Zezula
Modified: 2012-02-06 09:03 UTC (History)
8 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Zezula 2010-03-24 10:48:36 UTC
Currently indexing blocks nearly all editor features. The only way how to fix it is to use a transactional storage and change the RepositoryUpdater to run outside the TaskProcessor thread.
Comment 1 Dusan Balek 2010-03-24 10:51:29 UTC
*** Bug 182190 has been marked as a duplicate of this bug. ***
Comment 2 stefan79 2010-04-08 14:16:10 UTC
What is the plan for this bug?
I think this feature was planed for 6.8(make NB usable while scanning projects), but some of the problems while scanning-projects are still alive).
Comment 3 Tomas Zezula 2010-04-08 14:19:12 UTC
>I think this feature was planed for 6.8(make NB usable while scanning projects)
No, it's a new feature and it's not yet a part of any official plan.
Comment 4 David Strupl 2010-06-30 13:20:04 UTC
I am putting this to http://wiki.netbeans.org/EditorPlan610
Comment 5 David Strupl 2011-02-24 08:25:04 UTC
This is not finished in 7.0 - I am changing the target milestone to next and this has to be planned for some future release.
Comment 6 David Strupl 2011-02-24 08:37:27 UTC
*** Bug 134990 has been marked as a duplicate of this bug. ***
Comment 7 Tomas Zezula 2012-01-26 12:41:34 UTC
Fixed jet-main 41985eb45913
Comment 8 jessholle 2012-01-26 12:42:48 UTC
Will this be coming to a 7.1 update?  [Please.]
Comment 9 Marian Mirilovic 2012-01-26 12:49:58 UTC
(In reply to comment #8)
> Will this be coming to a 7.1 update?  [Please.]

Definitely NOT. We are far from saying "it's working and it's stable"
Comment 10 Tomas Zezula 2012-01-26 12:55:35 UTC
>Will this be coming to a 7.1 update?
No, the changes set is just a branch merge. The change itself has more than 150 change sets with 25K line diff. This cannot be merged into 7.1
Comment 11 Egor Ushakov 2012-02-06 09:03:05 UTC
I've just tried dev build and it works like a charm!
Tomas thank you so much!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo