Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 184342 - Navigator is empty until all projects are fully parsed
Navigator is empty until all projects are fully parsed
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Navigation
6.x
PC Solaris
: P3 (vote)
: 7.2
Assigned To: Tomas Zezula
issues@java
:
Depends on: 182653
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-16 09:53 UTC by Egor Ushakov
Modified: 2012-01-26 12:44 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Ushakov 2010-04-16 09:53:24 UTC
When "parsing projects" is active navigator for any opened files is empty.
Can navigator be filled with higher priority to have it immediately as soon as I open any file?
Comment 1 Egor Ushakov 2010-04-16 09:55:12 UTC
If I have a file opened with navigator filled with data and I open more projects IDE starts to scan again and navigator for opened file becomes empty again! How can that be???
Comment 2 Tomas Zezula 2010-04-19 07:18:37 UTC
Yes, it can be done. It's not so easy as Java is strongly typed and the scans build caches to do type resolution. The resolution from sources may be very memory expensive due to AST nodes count. The problem is that java navigator allows "Show Inherited" which needs to resolve super types.
>If I have a file opened with navigator filled with data and I open more projects IDE starts to scan again >and navigator for opened file becomes empty again!
As you lost a focus and the navigator infrastructure forced recalculation of it. During the scan the java module is not able to do certain things as explained above. Anyway in my free time I am playing with fully transactional java module which allows all features during scan if the source root was already scanned at least once.
Comment 3 Tomas Zezula 2012-01-26 12:44:44 UTC
Fixed jet-main 41985eb45913


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo