Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 182190 - [69cat] [editor] Fix Imports while Scanning Projects
[69cat] [editor] Fix Imports while Scanning Projects
Status: RESOLVED DUPLICATE of bug 182653
Product: java
Classification: Unclassified
Component: Editor
-S1S-
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-17 11:58 UTC by stefan79
Modified: 2010-03-24 10:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Snapshot while scanning projects and started fix import. (193.66 KB, application/octet-stream)
2010-03-17 14:17 UTC, stefan79
Details
An other Snapshot. (103.14 KB, application/octet-stream)
2010-03-18 08:35 UTC, stefan79
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stefan79 2010-03-17 11:58:51 UTC
While Scanning project the Fix-Imports - Action is blocked I can see (and cancel) the "lengthy operation" - Dialog.
But I think this dialog isn´t the resolution for the problem, that I can´t finish my work.

Is it really necessary, to block this Action?

Reproduce-Steps:
-) Start NetBeans
-) Open a File and press Fix Imports

I´ll attach a Snapshot

---
Product Version = NetBeans IDE Dev (Build 201003160201)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.6.0_18
Runtime = Java HotSpot(TM) Client VM 16.0-b13
Comment 1 stefan79 2010-03-17 14:17:11 UTC
Created attachment 95299 [details]
Snapshot while scanning projects and started fix import.
Comment 2 stefan79 2010-03-18 08:35:02 UTC
Created attachment 95353 [details]
An other Snapshot.
Comment 3 Dusan Balek 2010-03-24 10:51:29 UTC
Requires transactional index. Scanning should behave like a transaction - other threads should be able to continue seamlessly using old data until new data is
provided by the scanning thread.

*** This bug has been marked as a duplicate of bug 182653 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo