Bug 202573 - Debugger does not work while scanning
Debugger does not work while scanning
Status: RESOLVED FIXED
Product: debugger
Classification: Unclassified
Component: Java
7.0.1
PC All
: P2 (vote)
: 7.2
Assigned To: Martin Entlicher
issues@debugger
: 7.1_WAIVER_APPROVED, PERFORMANCE, PLAN
: 206846 (view as bug list)
Depends on: 182653 206137
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-23 15:29 UTC by Egor Ushakov
Modified: 2012-01-25 16:32 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.17 KB, text/plain)
2012-01-19 08:51 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Ushakov 2011-09-23 15:29:38 UTC
steps to reproduce:
- start debug session
- open new project
while IDE is scanning debugger is unable to step or do anything
Comment 1 Martin Entlicher 2011-09-23 17:27:18 UTC
This can not be fixed, since we need the parser information to properly highlight where the debugger is stopped.
We could, in theory, just to show the regular line highlight when the parser information is not available. Bu we can never know when the parsing will be finished and this could cause that the more detailed highlighting will not be visible too often due to some random re-scanning of sources.
Comment 2 Egor Ushakov 2011-09-23 20:34:27 UTC
Martin, the project that I was debugging had been opened and fully parsed long ago, so all information should have been available. The project I opened was another project that had nothing in common with the project I was debugging. I understand that probably it should be fixed in code model, so that it provides information for already parsed projects and do not block if another project is being parsed, so maybe you could reassign it to parser if nothing could be done in debugger part?
Comment 3 Egor Ushakov 2011-10-11 14:25:30 UTC
it is really annoying: step over can be performed while scanning and it looks like debugger accepts it BUT it will really stop on the next line only after scanning is done!
Comment 4 David Strupl 2011-11-29 18:34:43 UTC
Making this P2 for 7.2. Maybe this could be addressed even without 182653 being implemented. Please consult with Tomas Zezula. Thanks.
Comment 5 Martin Entlicher 2012-01-13 15:57:03 UTC
*** Bug 206846 has been marked as a duplicate of this bug. ***
Comment 6 Jiri Skrivanek 2012-01-19 08:51:27 UTC
Created attachment 115065 [details]
stacktrace
Comment 7 Martin Entlicher 2012-01-19 09:33:37 UTC
Jirka, your stack trace seems to be unrelated. There's nothing from debugger.
Comment 8 Jiri Skrivanek 2012-01-19 09:39:21 UTC
Comment on attachment 115065 [details]
stacktrace

You are right. It was added mistakenly by exception reporter.
Comment 9 Tomas Zezula 2012-01-19 09:40:39 UTC
The problem was also fixed on background_scan branch.
Comment 10 Martin Entlicher 2012-01-19 09:45:01 UTC
How it could be added by exception reporter, when there's nothing in "Exception Report" field in this issue?
Is there some severe bug in the exceptions reporter?
Comment 11 Martin Entlicher 2012-01-19 13:50:36 UTC
Fixed by changeset:   211053:5b10fd88134c
http://hg.netbeans.org/main/rev/5b10fd88134c
Comment 12 Quality Engineering 2012-01-25 16:32:39 UTC
Integrated into 'main-golden', will be available in build *201201250600* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/5b10fd88134c
User: mentlicher@netbeans.org
Log: #202573: Update the thread's operations lazily so that we do not have to wait for Java parser. After the operations are updated, refresh the current thread annotation, print more detailed message to Debugger Console and refresh Variables view to have the info about the current operation.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo