Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 136658 - consider replacing TreeTableView with OutlineView
consider replacing TreeTableView with OutlineView
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
:
Depends on: 33281 140365 150115 150169 150170 150173 150175 151289 151294 151412
Blocks: 37757 44575 153004
  Show dependency treegraph
 
Reported: 2008-06-06 15:08 UTC by Stanislav Aubrecht
Modified: 2009-02-19 20:38 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Aubrecht 2008-06-06 15:08:33 UTC
a new treetable-like component has been added to netbeans code base. it has some advantages over the existing and buggy
treetableview: multicolumn sorting, drag and drop support, in-place editing of tree cells etc. so please consider
replacing TreeTableView with the new OutlineView in your code. the TreeTableView will be deprecated at the end netbeans
6.5 Milestone 2 and there is still some room for extensions and enhancements to OutlineView API depending on your
requirements.
Comment 1 Martin Entlicher 2008-06-06 15:22:58 UTC
We're going to evaluate the OutlineView soon...
Comment 2 Martin Entlicher 2008-07-16 22:48:01 UTC
It's almost ready.
Currently I have problems with missing content in the tables after TopComponents with views are closed and opened again.
Comment 3 Martin Entlicher 2008-07-17 12:33:07 UTC
Unfortunately we need to leave this for the next release.
There are more issues associated with the transition. Columns are treated differently than in TTV, there is no column
model for Nodes column. This implies different internal management of settings like visible columns, sorted columns,
order of visible columns.
Due to that, we would have to make big changes in org.netbeans.modules.viewmodel.TreeTable and we consider them to be
risky at this point.
Furter, there are some bugs like on Gnome L&F no expansion sign are visible and messages are not localizable - will
submit separate issues for that.
Comment 4 Martin Entlicher 2008-10-27 15:33:09 UTC
In changeset:   106686:0742eb00bc60 I've added an experimental implementation of Outline view as a replacement of TTV.
It's activated when system property "debugger.outline" is set to "true". It can be used for an easier reproduction of
issues we depend on.
http://hg.netbeans.org/main/rev/0742eb00bc60
Comment 5 Quality Engineering 2008-10-28 05:02:32 UTC
Integrated into 'main-golden', will be available in build *200810280201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0742eb00bc60
User: mentlicher@netbeans.org
Log: #136658 - Experimental implementation of Outline view as a replacement of TTV added conditionally, it's activated when system property debugger.outline is set to true.
Comment 6 Martin Entlicher 2009-01-15 15:30:38 UTC
As most of the issues with Outline were solved, we're switching from TreeTableView to OutlineView for all debugger views
in changeset:   114101:4e3017d5c912
http://hg.netbeans.org/main/rev/4e3017d5c912
Comment 7 Quality Engineering 2009-01-16 07:18:59 UTC
Integrated into 'main-golden', will be available in build *200901160201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/4e3017d5c912
User: mentlicher@netbeans.org
Log: #136658 - As most of the issues with Outline were solved, we're switching from TreeTableView to OutlineView for all debugger views.
Comment 8 Filip Zamboj 2009-02-16 13:34:40 UTC
issue verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo